aboutsummaryrefslogtreecommitdiff
path: root/devel/jakarta-commons-daemon
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-09 17:09:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-09 17:09:58 +0000
commitb16e2aed9480e63a5142cee0a33d5855b8d5d03a (patch)
treebaa3f50af9d1c633cf4a04cce103cfbdfcc3205d /devel/jakarta-commons-daemon
parent1978f32ecb5ac75c6d630c7378a69381ae2994e9 (diff)
downloadports-b16e2aed9480e63a5142cee0a33d5855b8d5d03a.tar.gz
ports-b16e2aed9480e63a5142cee0a33d5855b8d5d03a.zip
Notes
Diffstat (limited to 'devel/jakarta-commons-daemon')
-rw-r--r--devel/jakarta-commons-daemon/Makefile45
-rw-r--r--devel/jakarta-commons-daemon/Makefile.orgi47
-rw-r--r--devel/jakarta-commons-daemon/distinfo3
-rw-r--r--devel/jakarta-commons-daemon/files/patch-configure7
-rw-r--r--devel/jakarta-commons-daemon/pkg-descr6
5 files changed, 108 insertions, 0 deletions
diff --git a/devel/jakarta-commons-daemon/Makefile b/devel/jakarta-commons-daemon/Makefile
new file mode 100644
index 000000000000..895cb200df3f
--- /dev/null
+++ b/devel/jakarta-commons-daemon/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: commons-daemon
+# Date created: 9 July 2007
+# Whom: Ronald Klop <ronald@echteman.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= commons-daemon
+PORTVERSION= 1.0.1
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+MASTER_SITE_SUBDIR= commons/daemon/source
+PKGNAMEPREFIX= jakarta-
+DISTNAME= daemon-${PORTVERSION}
+
+MAINTAINER= ronald@echteman.nl
+COMMENT= Wrapper code to start/stop a Java application as a daemon.
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+JAVA_OS= native
+JAVA_BUILD= jdk
+NEED_JAVAC= yes
+USE_JIKES= no
+USE_ANT= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-java=${JAVA_HOME}
+
+ALL_TARGET=dist
+
+CONFIGURE_WRKSRC= ${WRKSRC}/src/native/unix/
+INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar bin/jsvc
+
+post-build:
+ cd ${INSTALL_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} all
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ ${INSTALL_DATA} ${WRKSRC}/dist/${PORTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/jsvc ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/devel/jakarta-commons-daemon/Makefile.orgi b/devel/jakarta-commons-daemon/Makefile.orgi
new file mode 100644
index 000000000000..7cf16e63a611
--- /dev/null
+++ b/devel/jakarta-commons-daemon/Makefile.orgi
@@ -0,0 +1,47 @@
+# New ports collection makefile for: commons-daemon
+# Date created: 9 July 2007
+# Whom: Ronald Klop <ronald@echteman.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= commons-daemon
+PORTVERSION= 1.0.1
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
+MASTER_SITE_SUBDIR= commons/daemon/source
+PKGNAMEPREFIX= jakarta-
+DISTNAME= daemon-${PORTVERSION}
+
+MAINTAINER= ronald@echteman.nl
+COMMENT= Wrapper code to start/stop a Java application as a daemon.
+
+BUILD_DEPENDS= gmake:${PORTSDIR}/devel/gmake
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+JAVA_OS= native
+JAVA_BUILD= jdk
+NEED_JAVAC= yes
+USE_JIKES= no
+USE_ANT= yes
+
+GNU_CONFIGURE= yes
+
+ALL_TARGET= dist
+
+PLIST_FILES= bin/jsvc share/java/classes/commons-daemon.jar
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ cd ${WRKSRC}/src/native/unix && ./configure --with-java=${JAVA_HOME}
+
+pre-build:
+ cd ${WRKSRC}/src/native/unix && ${GMAKE}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/native/unix/jsvc ${LOCALBASE}/bin
+ ${INSTALL} ${WRKSRC}/dist/commons-daemon.jar ${JAVAJARDIR}
+
+.include <bsd.port.post.mk>
diff --git a/devel/jakarta-commons-daemon/distinfo b/devel/jakarta-commons-daemon/distinfo
new file mode 100644
index 000000000000..5b7e213b9113
--- /dev/null
+++ b/devel/jakarta-commons-daemon/distinfo
@@ -0,0 +1,3 @@
+MD5 (daemon-1.0.1.tar.gz) = df3eb5aafa53ca530843a09d40b8a1c0
+SHA256 (daemon-1.0.1.tar.gz) = 177107b8d99cabdbcda58cec284a2e2ccb5063113cc1fdb1b672754d4652848c
+SIZE (daemon-1.0.1.tar.gz) = 301023
diff --git a/devel/jakarta-commons-daemon/files/patch-configure b/devel/jakarta-commons-daemon/files/patch-configure
new file mode 100644
index 000000000000..ffcd029ca069
--- /dev/null
+++ b/devel/jakarta-commons-daemon/files/patch-configure
@@ -0,0 +1,7 @@
+$FreeBSD$
+
+--- src/native/unix/configure.dist Mon Jul 9 10:35:45 2007
++++ src/native/unix/configure Mon Jul 9 10:36:04 2007
+@@ -2407 +2407 @@
+- freebsd4.?)
++ freebsd*)
diff --git a/devel/jakarta-commons-daemon/pkg-descr b/devel/jakarta-commons-daemon/pkg-descr
new file mode 100644
index 000000000000..a17aa741298b
--- /dev/null
+++ b/devel/jakarta-commons-daemon/pkg-descr
@@ -0,0 +1,6 @@
+Wrapper code to start/stop a Java application as a daemon.
+Daemon is made of 2 parts. One written in C that makes the
+interface to the operating system and the other in Java that
+provides the Daemon API.
+
+WWW: http://jakarta.apache.org/commons/daemon/