aboutsummaryrefslogtreecommitdiff
path: root/devel/java-util-concurrent
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-11-19 14:31:35 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-11-19 14:31:35 +0000
commitb933de4aaa16a51020f61f87f64063a97fc5b6d1 (patch)
tree5701048fb59c8b74acff6db606164733434824b7 /devel/java-util-concurrent
parent578714486767646ae5fbc76cac14d3d8e4a080a5 (diff)
downloadports-b933de4aaa16a51020f61f87f64063a97fc5b6d1.tar.gz
ports-b933de4aaa16a51020f61f87f64063a97fc5b6d1.zip
Notes
Diffstat (limited to 'devel/java-util-concurrent')
-rw-r--r--devel/java-util-concurrent/Makefile48
-rw-r--r--devel/java-util-concurrent/distinfo2
-rw-r--r--devel/java-util-concurrent/pkg-descr19
3 files changed, 69 insertions, 0 deletions
diff --git a/devel/java-util-concurrent/Makefile b/devel/java-util-concurrent/Makefile
new file mode 100644
index 000000000000..bb1fa1b40184
--- /dev/null
+++ b/devel/java-util-concurrent/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: java-util-concurrent
+# Date created: 2004-11-19
+# Whom: Herve Quiroz <hq@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= util-concurrent
+PORTVERSION= 1.3.4
+CATEGORIES= devel java
+MASTER_SITES= http://gee.cs.oswego.edu/dl/classes/EDU/oswego/cs/dl/current/
+PKGNAMEPREFIX= java-
+DISTNAME= concurrent
+
+MAINTAINER= hq@FreeBSD.org
+COMMENT= Utility classes for concurrent Java programming
+
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+
+USE_ANT= yes
+ALL_TARGET= dist
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= javadoc
+.endif
+
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
+.if !defined(NOPORTDOCS)
+PORTDOCS= apidocs index.html
+.endif
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${PORTNAME}.jar..."
+ @${MKDIR} ${JAVAJARDIR}
+ @${INSTALL_DATA} ${WRKSRC}/lib/${DISTNAME}.jar ${JAVAJARDIR}/${PORTNAME}.jar
+ @${ECHO_MSG} " [ DONE ]"
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}/..."
+ @cd ${WRKSRC}/docs \
+ && ${FIND} . -type d -exec ${MKDIR} ${DOCSDIR}/apidocs/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/apidocs/{} \;
+ @${INSTALL_DATA} ${WRKSRC}/intro.html ${DOCSDIR}/index.html
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/java-util-concurrent/distinfo b/devel/java-util-concurrent/distinfo
new file mode 100644
index 000000000000..51ced5b18398
--- /dev/null
+++ b/devel/java-util-concurrent/distinfo
@@ -0,0 +1,2 @@
+MD5 (concurrent.tar.gz) = 6a7898a403c3c400f271c6e9285ce9a2
+SIZE (concurrent.tar.gz) = 522717
diff --git a/devel/java-util-concurrent/pkg-descr b/devel/java-util-concurrent/pkg-descr
new file mode 100644
index 000000000000..8a08058187bb
--- /dev/null
+++ b/devel/java-util-concurrent/pkg-descr
@@ -0,0 +1,19 @@
+This package provides standardized, efficient versions of utility classes
+commonly encountered in concurrent Java programming. This code consists of
+implementations of ideas that have been around for ages, and is merely intended
+to save you the trouble of coding them.
+
+The package mainly consists of implementations of a few interfaces:
+
+ * Sync -- locks, conditions
+ * Channel -- queues, buffers
+ * Barrier -- multi-party synchronization
+ * SynchronizedVariable -- atomic ints, refs etc
+ * java.util.Collection -- collections
+ * Executor -- replacements for direct use of Thread
+
+Plus some utilities and frameworks that build upon these.
+
+This package was the precursor to java.util.concurrent.
+
+WWW: http://gee.cs.oswego.edu/dl/classes/EDU/oswego/cs/dl/util/concurrent/intro.html