aboutsummaryrefslogtreecommitdiff
path: root/devel/jcmdline
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2005-06-12 19:16:37 +0000
committerThierry Thomas <thierry@FreeBSD.org>2005-06-12 19:16:37 +0000
commit30ff38e70f3aa3801cb8f39484706c3fd1cc410f (patch)
treee846a6fcce5216e99614b9764c158aeabea11533 /devel/jcmdline
parentcf1691877a4bc15db0519e5402da630533c33570 (diff)
downloadports-30ff38e70f3aa3801cb8f39484706c3fd1cc410f.tar.gz
ports-30ff38e70f3aa3801cb8f39484706c3fd1cc410f.zip
Notes
Diffstat (limited to 'devel/jcmdline')
-rw-r--r--devel/jcmdline/Makefile37
-rw-r--r--devel/jcmdline/distinfo2
-rw-r--r--devel/jcmdline/pkg-descr9
3 files changed, 48 insertions, 0 deletions
diff --git a/devel/jcmdline/Makefile b/devel/jcmdline/Makefile
new file mode 100644
index 000000000000..7da085a754ea
--- /dev/null
+++ b/devel/jcmdline/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: jcmdline
+# Date created: 22 May 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jcmdline
+PORTVERSION= 1.0.3
+CATEGORIES= devel java
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= A Java command line processor
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+JARFILE= ${PORTNAME}.jar
+
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+DOCFILES= CHANGES CREDITS README
+PORTDOCS= *
+
+do-install:
+ ${INSTALL_DATA} ${JARFILE:S|.jar|-${PORTVERSION}.jar|:S|^|${WRKSRC}/|} \
+ ${JAVAJARDIR}/${JARFILE}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${DOCFILES:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/jcmdline/distinfo b/devel/jcmdline/distinfo
new file mode 100644
index 000000000000..a16533d3e285
--- /dev/null
+++ b/devel/jcmdline/distinfo
@@ -0,0 +1,2 @@
+MD5 (jcmdline-1.0.3.tar.gz) = d75af2e06c8dc1643bd1ad745001faba
+SIZE (jcmdline-1.0.3.tar.gz) = 263024
diff --git a/devel/jcmdline/pkg-descr b/devel/jcmdline/pkg-descr
new file mode 100644
index 000000000000..4b578fbd89f3
--- /dev/null
+++ b/devel/jcmdline/pkg-descr
@@ -0,0 +1,9 @@
+The jcmdline package is a Java package with the following goals:
+
+ * Facilitate parsing/handling of command line parameters.
+ * Add consistency to command line parameter parsing and command usage display
+ through all executables of a Java application.
+ * Automatically generate a command usage based upon defined command line
+ parameters.
+
+WWW: http://jcmdline.sourceforge.net/