aboutsummaryrefslogtreecommitdiff
path: root/devel/jenkins
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2013-10-05 16:11:37 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2013-10-05 16:11:37 +0000
commit8d37b5059aaae16aa356b8d978002a8def39e9ee (patch)
tree8a7befb22252b6f491c36d157601d0d16ff3cfca /devel/jenkins
parenta9b67764b33b491c484ab70ccb7e59db32ce81d5 (diff)
downloadports-8d37b5059aaae16aa356b8d978002a8def39e9ee.tar.gz
ports-8d37b5059aaae16aa356b8d978002a8def39e9ee.zip
Notes
Diffstat (limited to 'devel/jenkins')
-rw-r--r--devel/jenkins/Makefile5
-rw-r--r--devel/jenkins/files/jenkins.in3
-rw-r--r--devel/jenkins/files/pkg-deinstall.in38
3 files changed, 3 insertions, 43 deletions
diff --git a/devel/jenkins/Makefile b/devel/jenkins/Makefile
index 60c849a2154c..dab2d015fc66 100644
--- a/devel/jenkins/Makefile
+++ b/devel/jenkins/Makefile
@@ -2,6 +2,7 @@
PORTNAME= jenkins
PORTVERSION= 1.533
+PORTREVISION= 1
CATEGORIES= devel java
MASTER_SITES= http://mirrors.jenkins-ci.org/war/${PORTVERSION}/
DISTNAME= jenkins
@@ -21,7 +22,6 @@ FETCH_ARGS= -Fpr
NO_BUILD= yes
USE_RC_SUBR= jenkins
-SUB_FILES+= pkg-deinstall
JENKINS_HOME?= ${PREFIX}/jenkins
JENKINS_USER?= jenkins
@@ -37,12 +37,13 @@ GROUPS= jenkins
PLIST_FILES= %%DATADIR%%/${DISTNAME}${EXTRACT_SUFX}
PLIST_DIRS= %%DATADIR%%
+PLIST_DIRSTRY= jenkins
SUB_LIST+= JENKINS_HOME=${JENKINS_HOME} JENKINS_USER=${JENKINS_USER} JENKINS_GROUP=${JENKINS_GROUP} JAVA_HOME=${JAVA_HOME} JENKINS_LOG_FILE=${JENKINS_LOG_FILE}
.include <bsd.port.pre.mk>
do-install:
- ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${MKDIR} ${STAGEDIR}${DATADIR} ${STAGEDIR}${JENKINS_HOME}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX} ${STAGEDIR}${DATADIR}
.include <bsd.port.post.mk>
diff --git a/devel/jenkins/files/jenkins.in b/devel/jenkins/files/jenkins.in
index bb1dae703e91..ef08865ab1d7 100644
--- a/devel/jenkins/files/jenkins.in
+++ b/devel/jenkins/files/jenkins.in
@@ -72,9 +72,6 @@ jenkins_prestart() {
chown "${jenkins_user}:${jenkins_group}" "${jenkins_log_file}"
chmod 640 "${jenkins_log_file}"
fi
- if [ ! -d "${jenkins_home}" ]; then
- install -d -o "${jenkins_user}" -g "${jenkins_group}" -m 750 "${jenkins_home}"
- fi
if [ ! -d "/var/run/jenkins" ]; then
install -d -o "${jenkins_user}" -g "${jenkins_group}" -m 750 "/var/run/jenkins"
fi
diff --git a/devel/jenkins/files/pkg-deinstall.in b/devel/jenkins/files/pkg-deinstall.in
deleted file mode 100644
index 96d7d8b15513..000000000000
--- a/devel/jenkins/files/pkg-deinstall.in
+++ /dev/null
@@ -1,38 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-PATH=/bin:/usr/bin:/usr/sbin
-
-case $2 in
-DEINSTALL)
- # try to cleanup %%JENKINS_HOME%%
- rmdir %%JENKINS_HOME%% 2>/dev/null
- ;;
-POST-DEINSTALL)
- echo "===> post-deinstallation information for $1:"
- echo ""
- echo " Note:"
- echo " jenkins related user accounts and groups were not removed."
- echo ""
- echo " To remove the '%%JENKINS_USER%%' user and the '%%JENKINS_GROUP%%' group which were"
- echo " created by a default installation of this package, run"
- echo ""
- echo " pw userdel %%JENKINS_USER%%"
- echo " pw groupdel %%JENKINS_GROUP%%"
- if [ -d %%JENKINS_HOME%% ] ; then
- echo ""
- echo " In order to ease updates, the job directories, plugins"
- echo " and all configuration files were preserved."
- echo ""
- echo " Please remove %%JENKINS_HOME%% manually if you do not want to use"
- echo " jenkins any longer."
- fi
- echo ""
- ;;
-*)
- exit 64
- ;;
-esac
-exit 0