aboutsummaryrefslogtreecommitdiff
path: root/devel/jrtplib
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2008-11-17 17:01:29 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2008-11-17 17:01:29 +0000
commit73e91847d955580232a2576890b026ace384eed6 (patch)
tree57fc1015e848e3d02565f205326b6f64473981a0 /devel/jrtplib
parentc78c4f90f3d93c76db664afa533277c5e651a0ec (diff)
downloadports-73e91847d955580232a2576890b026ace384eed6.tar.gz
ports-73e91847d955580232a2576890b026ace384eed6.zip
Notes
Diffstat (limited to 'devel/jrtplib')
-rw-r--r--devel/jrtplib/Makefile4
-rw-r--r--devel/jrtplib/distinfo6
-rw-r--r--devel/jrtplib/files/patch-src-rtperrors.cpp11
-rw-r--r--devel/jrtplib/pkg-plist2
4 files changed, 18 insertions, 5 deletions
diff --git a/devel/jrtplib/Makefile b/devel/jrtplib/Makefile
index fad2fe6be335..677244b124a0 100644
--- a/devel/jrtplib/Makefile
+++ b/devel/jrtplib/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jrtplib
-PORTVERSION= 3.7.0
+PORTVERSION= 3.7.1
CATEGORIES= devel
MASTER_SITES= http://research.edm.uhasselt.be/jori/jrtplib/
@@ -19,6 +19,8 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --disable-jthread
+PLIST_SUB+= JRTPLIB_VER=${PORTVERSION}
+
post-patch:
@${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
${WRKSRC}/pkgconfig/Makefile.in
diff --git a/devel/jrtplib/distinfo b/devel/jrtplib/distinfo
index 9ea61d23e7c9..3cab67705a44 100644
--- a/devel/jrtplib/distinfo
+++ b/devel/jrtplib/distinfo
@@ -1,3 +1,3 @@
-MD5 (jrtplib-3.7.0.tar.gz) = 685488079c007383763acdf509d6f11c
-SHA256 (jrtplib-3.7.0.tar.gz) = c144afb896225297d2db042a00a6df8ff3b307804ebb7369b5f73a1a90e8e7f2
-SIZE (jrtplib-3.7.0.tar.gz) = 466289
+MD5 (jrtplib-3.7.1.tar.gz) = 18e33752ac51304cba7313c39ca39903
+SHA256 (jrtplib-3.7.1.tar.gz) = 9c098c4778aee40df55fd00831a29d247336c2a7a3ac0692e79e5693b6d87cd6
+SIZE (jrtplib-3.7.1.tar.gz) = 474916
diff --git a/devel/jrtplib/files/patch-src-rtperrors.cpp b/devel/jrtplib/files/patch-src-rtperrors.cpp
new file mode 100644
index 000000000000..7abf4425b426
--- /dev/null
+++ b/devel/jrtplib/files/patch-src-rtperrors.cpp
@@ -0,0 +1,11 @@
+--- src/rtperrors.cpp.orig 2008-11-17 14:35:19.000000000 +0800
++++ src/rtperrors.cpp 2008-11-17 14:35:50.000000000 +0800
+@@ -38,7 +38,7 @@
+ struct RTPErrorInfo
+ {
+ int code;
+- char *description;
++ std::string description;
+ };
+
+ static RTPErrorInfo ErrorDescriptions[]=
diff --git a/devel/jrtplib/pkg-plist b/devel/jrtplib/pkg-plist
index 4a9cb7939a1c..67ea0f17ddfa 100644
--- a/devel/jrtplib/pkg-plist
+++ b/devel/jrtplib/pkg-plist
@@ -47,7 +47,7 @@ include/jrtplib3/rtptypes_unix.h
include/jrtplib3/rtptypes_win.h
include/jrtplib3/rtpudpv4transmitter.h
include/jrtplib3/rtpudpv6transmitter.h
-lib/libjrtp-3.7.0.so
+lib/libjrtp-%%JRTPLIB_VER%%.so
lib/libjrtp.a
lib/libjrtp.la
lib/libjrtp.so