aboutsummaryrefslogtreecommitdiff
path: root/devel/json-c
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-08-19 08:49:07 +0000
committerJohn Marino <marino@FreeBSD.org>2014-08-19 08:49:07 +0000
commit0398131bd45d8d49c5aa8914318cfaebc9419ffb (patch)
treee318c89f6ed247eb9246c36ee4f29e866f207a70 /devel/json-c
parentde20b1d61b096100a931e0cd671991d63645d808 (diff)
Notes
Diffstat (limited to 'devel/json-c')
-rw-r--r--devel/json-c/Makefile10
-rw-r--r--devel/json-c/distinfo4
-rw-r--r--devel/json-c/pkg-plist10
3 files changed, 10 insertions, 14 deletions
diff --git a/devel/json-c/Makefile b/devel/json-c/Makefile
index 38a3b1a97973..9076824a7f39 100644
--- a/devel/json-c/Makefile
+++ b/devel/json-c/Makefile
@@ -2,24 +2,26 @@
# $FreeBSD$
PORTNAME= json-c
-PORTVERSION= 0.11
+PORTVERSION= 0.12
CATEGORIES= devel
MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/archive/
MAINTAINER= gno@yahoo-inc.com
COMMENT= JSON (JavaScript Object Notation) implementation in C
+LICENSE= MIT
+
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USES= gmake pathfix pkgconfig zip
+USES= gmake pathfix pkgconfig libtool
USE_GITHUB= yes
-MAKE_JOBS_UNSAFE= yes
GH_ACCOUNT= ${PORTNAME}
GH_PROJECT= ${PORTNAME}
-GH_TAGNAME= 20130402
+GH_TAGNAME= 20140410
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-${PORTVERSION}
+INSTALL_TARGET= install-strip
CONFLICTS= cocaine-core-[0-9]*
diff --git a/devel/json-c/distinfo b/devel/json-c/distinfo
index 99597aa507e3..5e71b52c95ce 100644
--- a/devel/json-c/distinfo
+++ b/devel/json-c/distinfo
@@ -1,2 +1,2 @@
-SHA256 (json-c-0.11.zip) = b32bedb692ab0ab8205df7837e806082ec459b55693730238ca03238cf896e95
-SIZE (json-c-0.11.zip) = 550947
+SHA256 (json-c-0.12.tar.gz) = de5f051019c3273b9165134394fb5d459a22a554947a7004237a9edd77069e4a
+SIZE (json-c-0.12.tar.gz) = 507377
diff --git a/devel/json-c/pkg-plist b/devel/json-c/pkg-plist
index e6db1e7922cc..6cff0bd7b6d8 100644
--- a/devel/json-c/pkg-plist
+++ b/devel/json-c/pkg-plist
@@ -1,11 +1,7 @@
-lib/libjson.a
-lib/libjson.la
-lib/libjson.so
-lib/libjson.so.1
lib/libjson-c.a
-lib/libjson-c.la
lib/libjson-c.so
lib/libjson-c.so.2
+lib/libjson-c.so.2.0.1
include/json-c/arraylist.h
include/json-c/bits.h
include/json-c/debug.h
@@ -20,8 +16,6 @@ include/json-c/json_tokener.h
include/json-c/json_util.h
include/json-c/linkhash.h
include/json-c/printbuf.h
-include/json
-libdata/pkgconfig/json.pc
+include/json-c/random_seed.h
libdata/pkgconfig/json-c.pc
-@dirrmtry include/json
@dirrm include/json-c