aboutsummaryrefslogtreecommitdiff
path: root/devel/json-glib
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-12-26 01:47:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-12-26 01:47:45 +0000
commit2f779b63319c486e26fce6eed52ae7519b004c20 (patch)
treead3368a9c8ca51f09b7dfd189f6268f6cb01f4bc /devel/json-glib
parentdd235d055b9d6b653064873add7e48886fc9e290 (diff)
downloadports-2f779b63319c486e26fce6eed52ae7519b004c20.tar.gz
ports-2f779b63319c486e26fce6eed52ae7519b004c20.zip
Notes
Diffstat (limited to 'devel/json-glib')
-rw-r--r--devel/json-glib/Makefile23
-rw-r--r--devel/json-glib/distinfo3
-rw-r--r--devel/json-glib/pkg-descr23
-rw-r--r--devel/json-glib/pkg-plist42
4 files changed, 91 insertions, 0 deletions
diff --git a/devel/json-glib/Makefile b/devel/json-glib/Makefile
new file mode 100644
index 000000000000..6e25e37c2c47
--- /dev/null
+++ b/devel/json-glib/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: json-glib
+# Date created: 25 December 2008
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= json-glib
+PORTVERSION= 0.6.2
+CATEGORIES= devel
+MASTER_SITES= http://folks.o-hand.com/~ebassi/sources/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= JSON (RFC 4627) interface for Glib
+
+USE_GMAKE= yes
+USE_GNOME= glib20 gnomehack gnomeprefix ltverhack
+USE_AUTOTOOLS= libtool:15
+USE_LDCONFIG= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/devel/json-glib/distinfo b/devel/json-glib/distinfo
new file mode 100644
index 000000000000..8068b304c217
--- /dev/null
+++ b/devel/json-glib/distinfo
@@ -0,0 +1,3 @@
+MD5 (json-glib-0.6.2.tar.gz) = d98f5580035ad0b37fa11896053a57af
+SHA256 (json-glib-0.6.2.tar.gz) = 7befca7f7d7d65cbb260eacd86eff2c1dcae8d859ae2c3e3002e2536d02b2c49
+SIZE (json-glib-0.6.2.tar.gz) = 453865
diff --git a/devel/json-glib/pkg-descr b/devel/json-glib/pkg-descr
new file mode 100644
index 000000000000..9f3efb50d510
--- /dev/null
+++ b/devel/json-glib/pkg-descr
@@ -0,0 +1,23 @@
+JSON-GLib is a library providing serialization and deserialization support
+for the JavaScript Object Notation (JSON) format described by RFC 4627. JSON is:
+
+a lightweight data-interchange format. It is easy for humans to read and write.
+It is easy for machines to parse and generate. It is based on a subset of the
+JavaScript Programming Language, Standard ECMA-262 3rd Edition - December 1999.
+JSON is a text format that is completely language independent but uses
+conventions that are familiar to programmers of the C-family of languages,
+including C, C++, C#, Java, JavaScript, Perl, Python, and many others. These
+properties make JSON an ideal data-interchange language. -- From Introducing
+JSON
+
+Many high-level languages already provide native modules for parsing, generating
+and manipulating JSON data streams. JSON-GLib is a C library based on GLib and
+released under the terms of the GNU Lesser General Public License version 2.1.
+It provides a parser and a generator GObject classes and various wrappers for
+the complex data types employed by JSON, such as arrays and objects.
+
+JSON-GLib uses GLib native data types and the generic value container GValue
+for ease of development. It also provides integration with the GObject classes
+for direct serialization into, and deserialization from, JSON data streams.
+
+WWW: http://live.gnome.org/JsonGlib
diff --git a/devel/json-glib/pkg-plist b/devel/json-glib/pkg-plist
new file mode 100644
index 000000000000..41dae00996b1
--- /dev/null
+++ b/devel/json-glib/pkg-plist
@@ -0,0 +1,42 @@
+include/json-glib-1.0/json-glib/json-enum-types.h
+include/json-glib-1.0/json-glib/json-generator.h
+include/json-glib-1.0/json-glib/json-glib.h
+include/json-glib-1.0/json-glib/json-gobject.h
+include/json-glib-1.0/json-glib/json-parser.h
+include/json-glib-1.0/json-glib/json-types.h
+include/json-glib-1.0/json-glib/json-version.h
+lib/libjson-glib-1.0.a
+lib/libjson-glib-1.0.la
+lib/libjson-glib-1.0.so
+lib/libjson-glib-1.0.so.0
+libdata/pkgconfig/json-glib-1.0.pc
+%%DOCSDIR%%/JsonGenerator.html
+%%DOCSDIR%%/JsonParser.html
+%%DOCSDIR%%/ch01.html
+%%DOCSDIR%%/ch02.html
+%%DOCSDIR%%/ch03.html
+%%DOCSDIR%%/home.png
+%%DOCSDIR%%/index.html
+%%DOCSDIR%%/index.sgml
+%%DOCSDIR%%/ix01.html
+%%DOCSDIR%%/ix02.html
+%%DOCSDIR%%/json-advanced.html
+%%DOCSDIR%%/json-base.html
+%%DOCSDIR%%/json-glib-GObject-integration.html
+%%DOCSDIR%%/json-glib-JsonArray.html
+%%DOCSDIR%%/json-glib-JsonNode.html
+%%DOCSDIR%%/json-glib-JsonObject.html
+%%DOCSDIR%%/json-glib-Versioning-information.html
+%%DOCSDIR%%/json-glib.devhelp
+%%DOCSDIR%%/json-glib.devhelp2
+%%DOCSDIR%%/json-glib.html
+%%DOCSDIR%%/json-streams.html
+%%DOCSDIR%%/json-tools.html
+%%DOCSDIR%%/left.png
+%%DOCSDIR%%/license.html
+%%DOCSDIR%%/right.png
+%%DOCSDIR%%/style.css
+%%DOCSDIR%%/up.png
+@dirrm %%DOCSDIR%%
+@dirrm include/json-glib-1.0/json-glib
+@dirrm include/json-glib-1.0