aboutsummaryrefslogtreecommitdiff
path: root/devel/jude-community
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-12-03 22:28:08 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-12-03 22:28:08 +0000
commitcbb6145dd6fe1099a6a9dc45fc1580f4776652bc (patch)
tree7658c795e7ee648de34619e7d8dc1adc87df655b /devel/jude-community
parent64832d2c123fb815c89fef63fa38f95cd35ea5fd (diff)
downloadports-cbb6145dd6fe1099a6a9dc45fc1580f4776652bc.tar.gz
ports-cbb6145dd6fe1099a6a9dc45fc1580f4776652bc.zip
Notes
Diffstat (limited to 'devel/jude-community')
-rw-r--r--devel/jude-community/Makefile43
-rw-r--r--devel/jude-community/distinfo6
-rw-r--r--devel/jude-community/files/mozilla2
3 files changed, 24 insertions, 27 deletions
diff --git a/devel/jude-community/Makefile b/devel/jude-community/Makefile
index f56c32101464..f5cc1cd826e5 100644
--- a/devel/jude-community/Makefile
+++ b/devel/jude-community/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jude-community
-PORTVERSION= 5.2.2
+PORTVERSION= 5.4
CATEGORIES= devel java
MASTER_SITES= # you have to register yourself as a member to download
DISTNAME= ${PORTNAME}-${PORTVERSION:S!.!_!g}
@@ -39,53 +39,50 @@ NO_BUILD= yes
.include "${PORTSDIR}/Mk/bsd.java.mk"
RESTRICTED= See http://jude.change-vision.com/jude-web/notes/ProductLicenseAgreement.html
-
WRKSRC= ${WRKDIR}/${PORTNAME:S!-!_!}
+REINPLACE_ARGS= -i ""
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
DOWNLOAD_URL= http://jude.change-vision.com/jude-web/download/index.html
+IGNORE= needs you to fetch manually the distribution file\
+ from ${DOWNLOAD_URL}, \
+ then place it in ${DISTDIR} and run make again
+.endif
-PLIST_FILES= bin/jude share/${PORTNAME}/mozilla
-DATA_FILES= ${PORTNAME}.jar jude-api.jar jude-gui_en.properties_org \
+PLIST_FILES= bin/jude
+.if !defined(NOPORTDATA)
+PORTDATA= ${PORTNAME}.jar jude-api.jar jude-gui_en.properties_org \
jude.ico jude-doc.ico Welcome.jude Welcome_ja.jude \
- template/project/Java1.4.jude template/project/Java5.jude
-
-.for file in ${DATA_FILES}
-PLIST_FILES+= share/${PORTNAME}/${file}
-.endfor
+ template \
+ mozilla
+.endif
.if defined(WITH_EXPORT_HTML)
-PLIST_FILES+= share/${PORTNAME}/tools.jar
+PORTDATA+= tools.jar
.endif
-PLIST_DIRS= share/${PORTNAME}/template/project \
- share/${PORTNAME}/template \
- share/${PORTNAME}
.if !defined(NOPORTDOCS)
-PORTDOCS+= README-e.txt README.txt ReleaseNote-e.html ReleaseNote.html \
+PORTDOCS= README-e.txt README.txt ReleaseNote-e.html ReleaseNote.html \
ProductInformation.txt
.endif
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= needs you to fetch manually the distribution file\
- from ${DOWNLOAD_URL}, \
- then place it in ${DISTDIR} and run make again
-.endif
-
post-patch:
${REINPLACE_CMD} -e "s!%%JAVA_HOME%%!${JAVA_HOME}!; \
s!%%DATADIR%%!${DATADIR}!" ${WRKSRC}/jude
.if !defined(NOPORTDOCS)
- ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/index.html
+ ${REINPLACE_CMD} 's/png\\/png\//' ${WRKSRC}/api/*/doc/JudeAPI_reference.html
.endif
do-install:
- ${MKDIR} ${DATADIR}
${INSTALL_SCRIPT} ${WRKSRC}/jude ${PREFIX}/bin
+.if !defined(NOPORTDATA)
+ ${MKDIR} ${DATADIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} "${PORTDATA:Nmozilla}" ${DATADIR})
${INSTALL_SCRIPT} ${FILESDIR}/mozilla ${DATADIR}
- (cd ${WRKSRC} && ${COPYTREE_SHARE} "${DATA_FILES}" ${DATADIR})
.if defined(WITH_EXPORT_HTML)
# ExportHTML needs lib/tools.jar of JDK1.4
${LN} -s ${JAVA_HOME}/lib/tools.jar ${DATADIR}
.endif
+.endif
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
.for docfile in ${PORTDOCS}
diff --git a/devel/jude-community/distinfo b/devel/jude-community/distinfo
index fea7f0e49036..1b0ab7dae953 100644
--- a/devel/jude-community/distinfo
+++ b/devel/jude-community/distinfo
@@ -1,3 +1,3 @@
-MD5 (jude-community-5_2_2.zip) = 9ec2f0f6b6311a0d5adbbb3d82fbe085
-SHA256 (jude-community-5_2_2.zip) = eb1e8a90554d2b5e046002ffe68cde615a15ca0225f2b7769f6e5dbfec07bcd5
-SIZE (jude-community-5_2_2.zip) = 8263661
+MD5 (jude-community-5_4.zip) = c216de471db05db627d27bb2b74b91bf
+SHA256 (jude-community-5_4.zip) = 07ebfee6f801b1ed425e72c3b6448fc6178a26be8b56958aa41868e490974fee
+SIZE (jude-community-5_4.zip) = 10241271
diff --git a/devel/jude-community/files/mozilla b/devel/jude-community/files/mozilla
index 5ece63ef79c9..3d89ee859656 100644
--- a/devel/jude-community/files/mozilla
+++ b/devel/jude-community/files/mozilla
@@ -4,7 +4,7 @@
PATH=${PATH#$(dirname $0)}
# add your favorite browser in the top of the list
-for browser in mozilla linux-mozilla firefox linux-mozillafirebird opera linux-opera
+for browser in mozilla linux-mozilla firefox3 firefox linux-firefox firebird opera linux-opera
do
type $browser > /dev/null 2>&1 && exec $browser "$@"
done