aboutsummaryrefslogtreecommitdiff
path: root/devel/jude_take/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-04-20 13:50:33 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-04-20 13:50:33 +0000
commit17b42fa78f5c9208eef84fc6e5e56c3b7e1676ad (patch)
tree73b71a76e0a1d945febd2f11147601d9a16c5934 /devel/jude_take/Makefile
parent4171a9b4856da24b9eaddf6311ea0f5808d21873 (diff)
downloadports-17b42fa78f5c9208eef84fc6e5e56c3b7e1676ad.tar.gz
ports-17b42fa78f5c9208eef84fc6e5e56c3b7e1676ad.zip
Notes
Diffstat (limited to 'devel/jude_take/Makefile')
-rw-r--r--devel/jude_take/Makefile63
1 files changed, 63 insertions, 0 deletions
diff --git a/devel/jude_take/Makefile b/devel/jude_take/Makefile
new file mode 100644
index 000000000000..a79df1afc374
--- /dev/null
+++ b/devel/jude_take/Makefile
@@ -0,0 +1,63 @@
+# New ports collection makefile for: jude_take
+# Date created: 19 April 2004
+# Whom: Yoshihiko Sarumaru <mistral@imasy.or.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jude_take
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= # you have to answer some enquetes to download
+DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/g}
+EXTRACT_SUFX= .zip
+
+MAINTAINER= mistral@imasy.or.jp
+COMMENT= A Java/UML Object-Oriented Design Tool
+
+USE_ZIP= yes
+USE_JAVA= 1.4+
+# It doesn't work well with linux-sun-jdk14
+# I haven't tested with the jdks of blackdown or ibm
+JAVA_OS= native
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+RESTRICTED= "See http://objectclub.esm.co.jp/Jude/permission_e.html"
+NO_CDROM= ${RESTRICTED}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+DOWNLOAD_URL= http://objectclub.esm.co.jp/Jude/enquete_e.html
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README-e.txt README.txt Release_Note-e.html Release_Note.html
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= "You must manually fetch the distribution file ${DISTNAME}${EXTRACT_SUFX} from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again"
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e "s!%%JAVA_HOME%%!${JAVA_HOME}!" ${WRKSRC}/jude
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/jude ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/jude-take.jar ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/JudeDefaultModel.jude ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/jude.ico ${DATADIR}
+ # ExportHTML needs lib/tools.jar to be copied
+ # ExportHTML doesn't work with version 1.3 (Known Problem)
+ #${LN} -s ${JAVA_HOME}/lib/tools.jar ${DATADIR}
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>