aboutsummaryrefslogtreecommitdiff
path: root/devel/judy
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-08-19 12:30:27 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-08-19 12:30:27 +0000
commit94497daa1696ff5ed3f323ce9514aebc1f540983 (patch)
tree800b578fbcd31a3600654728400e0dfa869235bd /devel/judy
parent8bb0846a2035989ed69570399c765b6b0e6be06b (diff)
downloadports-94497daa1696ff5ed3f323ce9514aebc1f540983.tar.gz
ports-94497daa1696ff5ed3f323ce9514aebc1f540983.zip
Notes
Diffstat (limited to 'devel/judy')
-rw-r--r--devel/judy/Makefile85
-rw-r--r--devel/judy/distinfo2
-rw-r--r--devel/judy/files/patch-platform.bsd_ia32.mk25
-rw-r--r--devel/judy/pkg-descr5
-rw-r--r--devel/judy/pkg-plist23
5 files changed, 140 insertions, 0 deletions
diff --git a/devel/judy/Makefile b/devel/judy/Makefile
new file mode 100644
index 000000000000..cbf9f5c9ebc0
--- /dev/null
+++ b/devel/judy/Makefile
@@ -0,0 +1,85 @@
+# New ports collection makefile for: Judy
+# Date created: 19 August 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Judy
+PORTVERSION= 0.1.8
+CATEGORIES= devel
+MASTER_SITES= http://judy.sourceforge.net/downloads/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+EXTRACT_SUFX= .tar.bz
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= General purpose dynamic array
+
+USE_BZIP2= YES
+HAS_CONFIGURE= YES
+INSTALLS_SHLIB= YES
+USE_REINPLACE= YES
+
+MAN3= Judy.3x Judy1.3x Judy1_funcs.3x JudyHS.3x JudyHS_funcs.3x \
+ JudyL.3x JudyL_funcs.3x JudySL.3x JudySL_funcs.3x
+
+MLINKS= Judy1.3x J1T.3x Judy1.3x J1S.3x Judy1.3x J1U.3x Judy1.3x J1F.3x \
+ Judy1.3x J1N.3x Judy1.3x J1L.3x Judy1.3x J1P.3x Judy1.3x J1FE.3x \
+ Judy1.3x J1NE.3x Judy1.3x J1LE.3x Judy1.3x J1PE.3x Judy1.3x J1C.3x \
+ Judy1.3x J1BC.3x Judy1.3x J1FA.3x Judy1.3x J1MU.3x \
+ Judy1_funcs.3x Judy1Test.3x Judy1_funcs.3x Judy1Set.3x \
+ Judy1_funcs.3x Judy1Unset.3x Judy1_funcs.3x Judy1First.3x \
+ Judy1_funcs.3x Judy1Next.3x Judy1_funcs.3x Judy1Last.3x \
+ Judy1_funcs.3x Judy1Prev.3x Judy1_funcs.3x Judy1FirstEmpty.3x \
+ Judy1_funcs.3x Judy1NextEmpty.3x Judy1_funcs.3x Judy1LastEmpty.3x \
+ Judy1_funcs.3x Judy1PrevEmpty.3x Judy1_funcs.3x Judy1Count.3x \
+ Judy1_funcs.3x Judy1ByCount.3x Judy1_funcs.3x Judy1FreeArray.3x \
+ Judy1_funcs.3x Judy1MemUsed.3x \
+ JudyHS.3x JHSG.3x JudyHS.3x JHSI.3x JudyHS.3x JHSD.3x \
+ JudyHS.3x JHSFA.3x \
+ JudyHS_funcs.3x JudyHSGet.3x JudyHS_funcs.3x JudyHSIns.3x \
+ JudyHS_funcs.3x JudyHSDel.3x JudyHS_funcs.3x JudyHSFreeArray.3x \
+ JudyL.3x JLG.3x JudyL.3x JLI.3x JudyL.3x JLD.3x JudyL.3x JLF.3x \
+ JudyL.3x JLN.3x JudyL.3x JLL.3x JudyL.3x JLP.3x JudyL.3x JLFE.3x \
+ JudyL.3x JLNE.3x JudyL.3x JLLE.3x JudyL.3x JLPE.3x JudyL.3x JLC.3x \
+ JudyL.3x JLBC.3x JudyL.3x JLFA.3x JudyL.3x JLMU.3x \
+ JudyL_funcs.3x JudyLGet.3x JudyL_funcs.3x JudyLIns.3x \
+ JudyL_funcs.3x JudyLDel.3x JudyL_funcs.3x JudyLFirst.3x \
+ JudyL_funcs.3x JudyLNext.3x JudyL_funcs.3x JudyLLast.3x \
+ JudyL_funcs.3x JudyLPrev.3x JudyL_funcs.3x JudyLFirstEmpty.3x \
+ JudyL_funcs.3x JudyLNextEmpty.3x JudyL_funcs.3x JudyLLastEmpty.3x \
+ JudyL_funcs.3x JudyLPrevEmpty.3x JudyL_funcs.3x JudyLCount.3x \
+ JudyL_funcs.3x JudyLByCount.3x JudyL_funcs.3x JudyLFreeArray.3x \
+ JudyL_funcs.3x JudyLMemUsed.3x \
+ JudySL.3x JSLG.3x JudySL.3x JSLI.3x JudySL.3x JSLD.3x \
+ JudySL.3x JSLF.3x JudySL.3x JSLN.3x JudySL.3x JSLL.3x \
+ JudySL.3x JSLP.3x JudySL.3x JSLFA.3x \
+ JudySL_funcs.3x JudySLGet.3x JudySL_funcs.3x JudySLIns.3x \
+ JudySL_funcs.3x JudySLDel.3x JudySL_funcs.3x JudySLFirst.3x \
+ JudySL_funcs.3x JudySLNext.3x JudySL_funcs.3x JudySLLast.3x \
+ JudySL_funcs.3x JudySLPrev.3x JudySL_funcs.3x JudySLFreeArray.3x
+
+DLVDIR= ${WRKSRC}/src/bsd_ia32/product/deliver/usr
+
+LIST_DOCS= COPYRIGHT README *.htm
+LIST_EXAMPLES= Makefile README *.c
+
+post-patch:
+ @${REINPLACE_CMD} -e 's!%%CC%%!${CC}!' \
+ ${WRKSRC}/make_includes/platform.bsd_ia32.mk
+
+do-install:
+ ${INSTALL_DATA} ${DLVDIR}/include/Judy.h ${PREFIX}/include
+ ${INSTALL_DATA} ${DLVDIR}/lib/libJudy.* ${PREFIX}/lib
+ ${INSTALL_MAN} ${DLVDIR}/share/man/man3/*.3x ${MANPREFIX}/man/man3
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${LIST_DOCS:S!^!${DLVDIR}/share/doc/Judy/!} ${DOCSDIR}
+ @${ECHO_MSG} "===> Installing examples for ${PKGNAME}"
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${LIST_EXAMPLES:S!^!${DLVDIR}/share/doc/Judy/demo/!} ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${DLVDIR}/share/doc/Judy/demo/run_demo ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/judy/distinfo b/devel/judy/distinfo
new file mode 100644
index 000000000000..b3b683d9f0f8
--- /dev/null
+++ b/devel/judy/distinfo
@@ -0,0 +1,2 @@
+MD5 (Judy.0.1.8.tar.bz) = a68acfabc73e3f395ca6ad5628c1f18b
+SIZE (Judy.0.1.8.tar.bz) = 333651
diff --git a/devel/judy/files/patch-platform.bsd_ia32.mk b/devel/judy/files/patch-platform.bsd_ia32.mk
new file mode 100644
index 000000000000..50150f9f6ee6
--- /dev/null
+++ b/devel/judy/files/patch-platform.bsd_ia32.mk
@@ -0,0 +1,25 @@
+--- make_includes/platform.bsd_ia32.mk.orig Thu Aug 19 14:55:28 2004
++++ make_includes/platform.bsd_ia32.mk Thu Aug 19 14:59:35 2004
+@@ -3,12 +3,11 @@
+ # Makefile fragment for Judy* for platform "freebsd_ia32".
+ # See platform.hpux_pa.mk for more comments.
+
+-SHELL = /bin/sh
+
+ # For portability use the generic names for cc, ld, and ar, which are typically
+ # symlinks to more specific names, such as /usr/bin/cc -> /opt/ansic/bin/cc.
+
+-CCPATH = cc
++CCPATH = %%CC%%
+ LDPATH = ld
+ ARPATH = ar
+ AR = $(ARPATH)
+@@ -106,7 +105,7 @@
+ # flavors, so spell them out here by flavor, meaning this file cannot be
+ # flavor-ignorant:
+
+-CC_OPTS_product = -Wall -O2
++CC_OPTS_product = $(CFLAGS)
+ CC_OPTS_cov = -Wall -O -DJU_FLAVOR_COV
+ CC_OPTS_debug = -Wall -g -DJU_FLAVOR_DEBUG
+
diff --git a/devel/judy/pkg-descr b/devel/judy/pkg-descr
new file mode 100644
index 000000000000..7898f032b39a
--- /dev/null
+++ b/devel/judy/pkg-descr
@@ -0,0 +1,5 @@
+Judy is a general purpose dynamic array implemented as a C callable
+library. Judy's speed and memory usage are typically better than other
+data storage models and improves with very large data sets.
+
+WWW: http://judy.sourceforge.net/
diff --git a/devel/judy/pkg-plist b/devel/judy/pkg-plist
new file mode 100644
index 000000000000..9058ad67760a
--- /dev/null
+++ b/devel/judy/pkg-plist
@@ -0,0 +1,23 @@
+include/Judy.h
+lib/libJudy.a
+lib/libJudy.so
+%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT
+%%PORTDOCS%%%%DOCSDIR%%/Judy1_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/Judy1_funcs_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/JudyHS_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/JudyHS_funcs_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/JudyL_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/JudyL_funcs_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/JudySL_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/JudySL_funcs_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/Judy_3x.htm
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/run_demo
+%%PORTDOCS%%%%EXAMPLESDIR%%/interSL.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/interL.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/funhist.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/JudySort.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%