aboutsummaryrefslogtreecommitdiff
path: root/devel/kBuild/Makefile
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2012-02-21 11:59:33 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2012-02-21 11:59:33 +0000
commitee62a65d32d36f6923f63205ae640c1a3703d429 (patch)
treed2ebac493d840c6587234120e924b487344c870b /devel/kBuild/Makefile
parentb0adc60ab315ef0289d83e7a4fe34cfdea5161dd (diff)
downloadports-ee62a65d32d36f6923f63205ae640c1a3703d429.tar.gz
ports-ee62a65d32d36f6923f63205ae640c1a3703d429.zip
Notes
Diffstat (limited to 'devel/kBuild/Makefile')
-rw-r--r--devel/kBuild/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/devel/kBuild/Makefile b/devel/kBuild/Makefile
index 88ac7778ee58..cee4621785f2 100644
--- a/devel/kBuild/Makefile
+++ b/devel/kBuild/Makefile
@@ -7,7 +7,7 @@
PORTNAME= kBuild
DISTVERSION= ${KBUILD_VERSION}-p2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.netlabs.org/pub/kbuild/
DISTNAME= ${PORTNAME}-${DISTVERSION}-src
@@ -15,9 +15,13 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-src
MAINTAINER= gahr@FreeBSD.org
COMMENT= Makefile framework
+BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
+
USE_AUTOTOOLS= automake autoconf
USE_GMAKE= yes
+CONFLICTS_INSTALL= kBuild-devel-[0-9]*
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
KBUILD_VERSION= 0.1.5
@@ -36,6 +40,7 @@ PORTDOCS= QuickReference-kmk.html \
post-patch:
${REINPLACE_CMD} -e '11269d;11274d' ${WRKSRC}/src/sed/configure
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/Config.kmk
# Override autotools
run-autotools: