aboutsummaryrefslogtreecommitdiff
path: root/devel/kdesdk4/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-08-09 16:52:28 +0000
commit568f8e877fb50618d4813b943d712e3bc08fd147 (patch)
tree16eef3a555a802ca06d05606c7f2a75ccbc6a431 /devel/kdesdk4/Makefile
parentbdcf355d6dedb8678255a8053a2b423f9cc7cc6c (diff)
The KDE FreeBSD team is proud to announce the release of KDE 4.1.0
for FreeBSD. The official KDE 4.1.0 release notes can be found at http://www.kde.org/announcements/4.1/. Some note: * Prefix KDE4 will be install into a custom prefixes namely ${LOCALBASE}/kde4. KDE4 and KDE3 can co-exist * Sound For sound to work, it is necessary to have dbus and hal enabled in your system. Please see the respective documentation on how to enable these. For more Informations see the HEADS UP at ports@ and kde-freebsd@ or our wiki page http://wiki.freebsd.org/KDE4/Install. Have fun!
Notes
Notes: svn path=/head/; revision=218272
Diffstat (limited to 'devel/kdesdk4/Makefile')
-rw-r--r--devel/kdesdk4/Makefile62
1 files changed, 16 insertions, 46 deletions
diff --git a/devel/kdesdk4/Makefile b/devel/kdesdk4/Makefile
index 665f21035c7e..c52634785ec2 100644
--- a/devel/kdesdk4/Makefile
+++ b/devel/kdesdk4/Makefile
@@ -1,16 +1,14 @@
-# New ports collection makefile for: KDE SDK
-# Date created: 2 March 2001
-# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
+# New ports collection Makefile for: kdesdk
+# Date created: 2008-01-31
+# Whom: Martin Wilke <miwi@FreeBSD.org>
#
# $FreeBSD$
-#
PORTNAME= kdesdk
-PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 2
+PORTVERSION= ${KDE4_VERSION}
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_KDE}
-MASTER_SITE_SUBDIR= stable/${PORTVERSION:S/.0//}/src
+MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
DIST_SUBDIR= KDE
MAINTAINER= kde@FreeBSD.org
@@ -19,48 +17,20 @@ COMMENT= KDE Software Development Kit
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
LIB_DEPENDS= svn_client-1.0:${PORTSDIR}/devel/subversion
-CONFLICTS= umbrello-[0-9]* kcachegrind-[0-9]*
-
-USE_KDEBASE_VER=3
-PREFIX= ${KDE_PREFIX}
+LATEST_LINK= ${PORTNAME}4
-USE_PERL5= yes
USE_BZIP2= yes
-USE_GMAKE= yes
-USE_BDB= yes
-USE_AUTOTOOLS= libtool:15
-
-USE_LDCONFIG= yes
-
-CONFIGURE_ARGS+=--mandir=${MANPREFIX}/man \
- --with-db-include-dir=${BDB_INCLUDE_DIR} \
- --with-db-lib-dir=${BDB_LIB_DIR} --with-db-name=${BDB_LIB_NAME} \
- --with-apr-config=${LOCALBASE}/bin/apr-1-config \
- --with-apu-config=${LOCALBASE}/bin/apu-1-config \
- --with-svn-include=${LOCALBASE}/include \
- --with-svn-lib=${LOCALBASE}/lib
-
-MAN1= cervisia.1 cvsblame.1 cvscheck.1 cvsversion.1 includemocs.1 kde-build.1 kdesvn-build.1 noncvslist.1
-
-.include "${.CURDIR}/../../x11/kde3/Makefile.kde"
-.include <bsd.port.pre.mk>
+KDE4_BUILDENV= yes
+USE_KDE4= kdelibs pimlibs workspace kdeprefix kdehier \
+ automoc4 akonadi
+USE_QT_VER= 4
+QT_COMPONENTS= network gui moc rcc uic svg qt3support
-pre-everything::
-.if !defined(WITH_OPTIONAL_DEPENDS)
- @${ECHO_MSG}
- @${ECHO_MSG} "You may define WITH_OPTIONAL_DEPENDS (make WITH_OPTIONAL_DEPENDS=YES)"
- @${ECHO_MSG} "to automatically build the suggested programs to complement kdesdk3."
- @${ECHO_MSG}
-.endif
+MAN1= cervisia.1
-# callgrind is optional. It depends on valgrind, which is i386 only.
-.if defined(WITH_OPTIONAL_DEPENDS) && ${ARCH} == "i386"
-RUN_DEPENDS+= callgrind:${PORTSDIR}/devel/callgrind
-.endif
+CMAKE_ARGS+= -DBUILD_kapptemplate:BOOL=Off
-post-patch:
-# Breakage might be caused by security/heimdal's broken fnmatch.h
- @${REINPLACE_CMD} -e 's|<\(fnmatch.h\)>|"/usr/include/\1"|' \
- ${WRKSRC}/cervisia/stringmatcher.cpp
+post-extract:
+ ${MKDIR} ${WRKSRC}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>