aboutsummaryrefslogtreecommitdiff
path: root/devel/kdesdk4
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-05 22:42:37 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-05 22:42:37 +0000
commit21d7095abe4ddfde2bfd56ca2378134d9640d565 (patch)
tree9d83bb3615d2bebc58ebb49b4e90af0150b030a5 /devel/kdesdk4
parent2fd00fb7a0a7e5a114e152c8a04d33811dbd9668 (diff)
downloadports-21d7095abe4ddfde2bfd56ca2378134d9640d565.tar.gz
ports-21d7095abe4ddfde2bfd56ca2378134d9640d565.zip
Notes
Diffstat (limited to 'devel/kdesdk4')
-rw-r--r--devel/kdesdk4/files/patch-libcxx20
1 files changed, 10 insertions, 10 deletions
diff --git a/devel/kdesdk4/files/patch-libcxx b/devel/kdesdk4/files/patch-libcxx
index 779b54f37008..ee855cc39d31 100644
--- a/devel/kdesdk4/files/patch-libcxx
+++ b/devel/kdesdk4/files/patch-libcxx
@@ -42,8 +42,8 @@ Date: Sun Nov 3 13:19:56 2013 +0200
It also allows us to remove the MSVC/SunPro workarounds from the code and
the build system.
---- umbrello/CMakeLists.txt
-+++ umbrello/CMakeLists.txt
+--- umbrello/umbrello/CMakeLists.txt
++++ umbrello/umbrello/CMakeLists.txt
@@ -267,37 +267,21 @@ set(libcodeimport_SRCS
codeimport/csharp/csharpimport.cpp
)
@@ -97,8 +97,8 @@ Date: Sun Nov 3 13:19:56 2013 +0200
set(libclipboard_SRCS
clipboard/umldragdata.cpp
---- umbrello/codeimport/classimport.cpp
-+++ umbrello/codeimport/classimport.cpp
+--- umbrello/umbrello/codeimport/classimport.cpp
++++ umbrello/umbrello/codeimport/classimport.cpp
@@ -20,9 +20,7 @@
#include "javaimport.h"
#include "adaimport.h"
@@ -123,8 +123,8 @@ Date: Sun Nov 3 13:19:56 2013 +0200
return classImporter;
}
---- umbrello/codeimport/kdevcppparser/position.h
-+++ umbrello/codeimport/kdevcppparser/position.h
+--- umbrello/umbrello/codeimport/kdevcppparser/position.h
++++ umbrello/umbrello/codeimport/kdevcppparser/position.h
@@ -20,22 +20,6 @@
#ifndef POSITION_H
#define POSITION_H
@@ -184,16 +184,16 @@ Date: Sun Nov 3 13:19:56 2013 +0200
typedef boost::spirit::classic::file_position_base<PositionFilename> PositionType;
class Position : public PositionType
---- umbrello/codeimport/kdevcppparser/preprocesslexer.cpp
-+++ umbrello/codeimport/kdevcppparser/preprocesslexer.cpp
+--- umbrello/umbrello/codeimport/kdevcppparser/preprocesslexer.cpp
++++ umbrello/umbrello/codeimport/kdevcppparser/preprocesslexer.cpp
@@ -41,13 +41,11 @@
#define PREPROCESSLEXER_DEBUG
-#ifdef Q_CC_MSVC
template <class _Tp>
--struct _Identity : public std::unary_function<_Tp, _Tp> {
-+struct identity : public std::unary_function<_Tp, _Tp> {
+-struct _Identity : public std::unary_function<_Tp,_Tp> {
++struct identity : public std::unary_function<_Tp,_Tp> {
_Tp& operator()(_Tp& __x) const { return __x; }
const _Tp& operator()(const _Tp& __x) const { return __x; }
};