aboutsummaryrefslogtreecommitdiff
path: root/devel/kdevelop-pg-qt
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-06 12:40:11 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2013-11-06 12:40:11 +0000
commitfcb5176bc8ea49e0b9cb283e100e49f3ea6eeed3 (patch)
treeee9d38702c0ee50066f37574ae4c76a77733f3c6 /devel/kdevelop-pg-qt
parent9120c1f74473aa5402c5547e5f2436354691d957 (diff)
Notes
Diffstat (limited to 'devel/kdevelop-pg-qt')
-rw-r--r--devel/kdevelop-pg-qt/Makefile5
-rw-r--r--devel/kdevelop-pg-qt/files/patch-git_f32988db..5209a04331
2 files changed, 33 insertions, 3 deletions
diff --git a/devel/kdevelop-pg-qt/Makefile b/devel/kdevelop-pg-qt/Makefile
index 3a37725feb17..410e01428f0f 100644
--- a/devel/kdevelop-pg-qt/Makefile
+++ b/devel/kdevelop-pg-qt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kdevelop
PORTVERSION= 1.0.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTNAME}${PKGNAMESUFFIX}/${PORTVERSION}/src
@@ -18,9 +18,8 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
USE_GCC= yes
USE_BZIP2= yes
-USES= bison cmake:outsource
+USES= bison cmake:outsource compiler:c++11-lib
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
USE_QT4= qmake_build moc_build uic_build rcc_build
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/kdevelop-pg-qt/files/patch-git_f32988db..5209a043 b/devel/kdevelop-pg-qt/files/patch-git_f32988db..5209a043
new file mode 100644
index 000000000000..b989000f4798
--- /dev/null
+++ b/devel/kdevelop-pg-qt/files/patch-git_f32988db..5209a043
@@ -0,0 +1,31 @@
+commit f32988dbaefcad34ab7966676058629e73c438fd
+Author: Milian Wolff <mail@milianw.de>
+Date: Sun Aug 4 21:37:01 2013 +0200
+
+ Fix compile with clang, also enable exceptions there.
+
+commit 5209a0439006c1ceac6e25fe583a8f1e068af0b8
+Author: Sven Brauch <svenbrauch@googlemail.com>
+Date: Sun Sep 8 01:24:00 2013 +0200
+
+ -std=c++11 -> -std=c++0x to fix build on build.kde.org
+
+ still builds with gcc 4.8
+
+diff --git a/kdev-pg/CMakeLists.txt b/kdev-pg/CMakeLists.txt
+index 7022121..57eb03b 100644
+--- kdev-pg/CMakeLists.txt
++++ kdev-pg/CMakeLists.txt
+@@ -4,9 +4,9 @@ PROJECT(kdevpg)
+ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+ REMOVE_DEFINITIONS(-DQT_NO_STL)
+ ADD_DEFINITIONS(-DQT_STL)
+-if(CMAKE_COMPILER_IS_GNUCC)
+- add_definitions(-fexceptions)
+-endif(CMAKE_COMPILER_IS_GNUCC)
++if(CMAKE_COMPILER_IS_GNUCC OR CMAKE_CXX_COMPILER_ID MATCHES Clang)
++ add_definitions(-fexceptions -std=c++0x)
++endif(CMAKE_COMPILER_IS_GNUCC OR CMAKE_CXX_COMPILER_ID MATCHES Clang)
+
+ QT4_ADD_RESOURCES(kdevpg_rcc_srcs ../unidata.qrc)
+