aboutsummaryrefslogtreecommitdiff
path: root/devel/kdevplatform/Makefile
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2010-11-09 01:52:43 +0000
committerAlberto Villa <avilla@FreeBSD.org>2010-11-09 01:52:43 +0000
commit7cb7cd17443355145d0673f1bc30814fc270a034 (patch)
tree199d9dc267934eee48ca2ddb9c43d6e20a19f411 /devel/kdevplatform/Makefile
parent1ae32977e33f4d0a1c285e5bb532a5746e2c512d (diff)
Notes
Diffstat (limited to 'devel/kdevplatform/Makefile')
-rw-r--r--devel/kdevplatform/Makefile11
1 files changed, 5 insertions, 6 deletions
diff --git a/devel/kdevplatform/Makefile b/devel/kdevplatform/Makefile
index 322fb7ac3abb..f713266342e3 100644
--- a/devel/kdevplatform/Makefile
+++ b/devel/kdevplatform/Makefile
@@ -15,11 +15,11 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= KDE development platform
LIB_DEPENDS= svn_client-1.0:${PORTSDIR}/devel/subversion \
- boost_thread.4:${PORTSDIR}/devel/boost-libs
+ boost_thread.4:${PORTSDIR}/devel/boost-libs \
+ qjson.0:${PORTSDIR}/devel/qjson
USE_BZIP2= yes
-USE_CMAKE= yes
-USE_KDE4= kdelibs kdeprefix automoc4
+USE_KDE4= automoc4 kdehier kdelibs kdeprefix
KDE4_BUILDENV= yes
USE_QT_VER= 4
QT_COMPONENTS= corelib assistant assistantclient clucene \
@@ -27,11 +27,10 @@ QT_COMPONENTS= corelib assistant assistantclient clucene \
opengl qt3support qtestlib script sql svg \
scripttools webkit xml xmlpatterns phonon \
qmake_build moc_build uic_build rcc_build
-
-.include <bsd.port.pre.mk>
+MAKE_JOBS_SAFE= yes
post-patch:
${REINPLACE_CMD} -e 's|$${LIB_INSTALL_DIR}/kdevplatform|$${LIB_INSTALL_DIR}/kdevplatform/cmake|g' \
${PATCH_WRKSRC}/CMakeLists.txt
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>