aboutsummaryrefslogtreecommitdiff
path: root/devel/kimwitu
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-23 12:16:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-23 12:16:37 +0000
commit31f85c255f8ca048d9795c7805297d3f8c9357ac (patch)
tree328e7abb83b3f48c91ebdfe60882b1fca12c4f64 /devel/kimwitu
parent9f6848fe1a7f62535f22d4dd0eae9b0d9bb5eabf (diff)
downloadports-31f85c255f8ca048d9795c7805297d3f8c9357ac.tar.gz
ports-31f85c255f8ca048d9795c7805297d3f8c9357ac.zip
Notes
Diffstat (limited to 'devel/kimwitu')
-rw-r--r--devel/kimwitu/Makefile26
-rw-r--r--devel/kimwitu/distinfo1
-rw-r--r--devel/kimwitu/files/patch-Makefile11
-rw-r--r--devel/kimwitu/pkg-comment1
-rw-r--r--devel/kimwitu/pkg-descr14
-rw-r--r--devel/kimwitu/pkg-plist1
6 files changed, 54 insertions, 0 deletions
diff --git a/devel/kimwitu/Makefile b/devel/kimwitu/Makefile
new file mode 100644
index 000000000000..54c68eaf8c8d
--- /dev/null
+++ b/devel/kimwitu/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# New ports collection makefile for: kimwitu
+# Date created: Apr 23, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kimwitu
+PORTVERSION= 4.6.1
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.cs.utwente.nl/pub/src/kimwitu/
+DISTNAME= kc-distr.V${PORTVERSION:S/./_/g}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+ALL_TARGET=
+
+MAN1= kc.1
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/Gen/kc ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/../man/kc.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/devel/kimwitu/distinfo b/devel/kimwitu/distinfo
new file mode 100644
index 000000000000..6f6eb0aadc97
--- /dev/null
+++ b/devel/kimwitu/distinfo
@@ -0,0 +1 @@
+MD5 (kc-distr.V4_6_1.tar.gz) = e3a5a3eec5a8c7be55ae78eb6db8fec9
diff --git a/devel/kimwitu/files/patch-Makefile b/devel/kimwitu/files/patch-Makefile
new file mode 100644
index 000000000000..73991e0686ce
--- /dev/null
+++ b/devel/kimwitu/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig Mon Apr 23 19:49:32 2001
++++ Makefile Mon Apr 23 19:55:00 2001
+@@ -184,7 +184,7 @@
+ ANY_ARCH_MALLOC_LDFLAGS =
+ HP_MALLOC_LDFLAGS = -lmalloc
+ ARCH_DEPEND_MALLOC_LDFLAGS = `(if hp9000s300 ; then echo $(HP_MALLOC_LDFLAGS); fi) 2>>/dev/null`
+-CFLAGS = $(ANY_ARCH_CFLAGS) $(ARCH_DEPEND_CFLAGS)
++CFLAGS += $(ANY_ARCH_CFLAGS) $(ARCH_DEPEND_CFLAGS)
+ # LIBS = -ll
+ SABER_CFLAGS = $(SABER_ANY_ARCH_CFLAGS) $(ARCH_DEPEND_CFLAGS)
+ LINT_CFLAGS = $(INCLUDES) $(LINT_ARCH_DEPEND_CFLAGS) $(GENDEFINES)
diff --git a/devel/kimwitu/pkg-comment b/devel/kimwitu/pkg-comment
new file mode 100644
index 000000000000..12e1aa304eb3
--- /dev/null
+++ b/devel/kimwitu/pkg-comment
@@ -0,0 +1 @@
+A tool for processing trees (i.e. terms)
diff --git a/devel/kimwitu/pkg-descr b/devel/kimwitu/pkg-descr
new file mode 100644
index 000000000000..d030654f20e1
--- /dev/null
+++ b/devel/kimwitu/pkg-descr
@@ -0,0 +1,14 @@
+Kimwitu is a system that supports the construction of programs that use
+trees or terms as their main data structure. It is a `meta-tool' in the
+development process of tools. Its input is an abstract description of
+terms, annotated with implementation directives, plus a definition of
+functions on these terms. The output consists of a number of C-files that
+contain data-structure definitions for the terms, a number of standard
+functions on those terms, and a translation (in C) of the function
+definitions in the input (eg. term rewriting).
+
+The standard functions can be used to create terms, compare them for
+equality, read and write them on files in various formats and do
+manipulations like list concatenation.
+
+WWW: http://purl.oclc.org/net/kimwitu/
diff --git a/devel/kimwitu/pkg-plist b/devel/kimwitu/pkg-plist
new file mode 100644
index 000000000000..f15098dc95d3
--- /dev/null
+++ b/devel/kimwitu/pkg-plist
@@ -0,0 +1 @@
+bin/kc