aboutsummaryrefslogtreecommitdiff
path: root/devel/kscope/Makefile
diff options
context:
space:
mode:
authorBrian Feldman <green@FreeBSD.org>2004-04-30 03:02:33 +0000
committerBrian Feldman <green@FreeBSD.org>2004-04-30 03:02:33 +0000
commit77617709172415e13ef67e9e67856d4b669de3af (patch)
tree732fd9e75fe3ebe5927f2cdfe88f00f9f4d304cc /devel/kscope/Makefile
parenta2a5be2c06b665275933e67203e995933ebb5d35 (diff)
downloadports-77617709172415e13ef67e9e67856d4b669de3af.tar.gz
ports-77617709172415e13ef67e9e67856d4b669de3af.zip
Notes
Diffstat (limited to 'devel/kscope/Makefile')
-rw-r--r--devel/kscope/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/kscope/Makefile b/devel/kscope/Makefile
new file mode 100644
index 000000000000..dbef57d5f591
--- /dev/null
+++ b/devel/kscope/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: kscope
+# Date created: 2004-04-21
+# Whom: Frank Mayhar <frank@exit.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= kscope
+PORTVERSION= 0.6
+CATEGORIES= devel kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=${PORTNAME}/
+
+MAINTAINER= frank@exit.com
+COMMENT= KDE front-end to Cscope
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+RUN_DEPENDS= exctags:${PORTSDIR}/devel/ctags \
+ cscope:${PORTSDIR}/devel/cscope
+
+USE_KDELIBS_VER=3
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+MAKE_ENV= EXTRA_LIBRARIES="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+=--with-extra-includes=${LOCALBASE}/include \
+ --with-extra-libs=${LOCALBASE}/lib
+
+pre-build:
+ ${REINPLACE_CMD} "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/Makefile
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11/kde3/Makefile.kde"
+.include <bsd.port.post.mk>