aboutsummaryrefslogtreecommitdiff
path: root/devel/lasi
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-02 12:12:16 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-02 12:12:16 +0000
commit1ed619a3d6fc0b2086db7e9e81fd3d2bdcef7317 (patch)
treed3359f9ae9440bbc76d0106a86a9f5f9cc53bdcb /devel/lasi
parentdf63713fe1b0295ec3d5f844be8f469af39ef102 (diff)
downloadports-1ed619a3d6fc0b2086db7e9e81fd3d2bdcef7317.tar.gz
ports-1ed619a3d6fc0b2086db7e9e81fd3d2bdcef7317.zip
Notes
Diffstat (limited to 'devel/lasi')
-rw-r--r--devel/lasi/Makefile5
-rw-r--r--devel/lasi/distinfo6
-rw-r--r--devel/lasi/files/patch-src_drawGlyph.cpp34
3 files changed, 5 insertions, 40 deletions
diff --git a/devel/lasi/Makefile b/devel/lasi/Makefile
index ae7a79f49543..17bb2e05dbe4 100644
--- a/devel/lasi/Makefile
+++ b/devel/lasi/Makefile
@@ -6,12 +6,11 @@
# $MCom: ports/devel/lasi/Makefile,v 1.1 2006/10/04 20:25:40 ahze Exp $
PORTNAME= lasi
-PORTVERSION= 1.0.5
-PORTREVISION= 2
+PORTVERSION= 1.0.6
CATEGORIES= devel
MASTER_SITES= http://www.unifont.org/lasi/download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= lars.engels@0x20.net
COMMENT= C++ stream output interface for creating Postscript documents
USE_GCC= 3.2+
diff --git a/devel/lasi/distinfo b/devel/lasi/distinfo
index 50ceccc5eba1..433a81b7380a 100644
--- a/devel/lasi/distinfo
+++ b/devel/lasi/distinfo
@@ -1,3 +1,3 @@
-MD5 (lasi-1.0.5.tar.gz) = b9f766f0b262bd3a5365fa81aea47ed8
-SHA256 (lasi-1.0.5.tar.gz) = 06f0b9b7310fad2a19d7f20c2501c795173799f20a85dc0996c422de80ee0610
-SIZE (lasi-1.0.5.tar.gz) = 465931
+MD5 (lasi-1.0.6.tar.gz) = 2afd4359c2708949e8aa13ab9944ce7a
+SHA256 (lasi-1.0.6.tar.gz) = 011c4d9242edce718663f0ca8e5bbffb445ce5aa3e28d8ea564fe1678ab2e4bf
+SIZE (lasi-1.0.6.tar.gz) = 466078
diff --git a/devel/lasi/files/patch-src_drawGlyph.cpp b/devel/lasi/files/patch-src_drawGlyph.cpp
deleted file mode 100644
index 18338e6e1dda..000000000000
--- a/devel/lasi/files/patch-src_drawGlyph.cpp
+++ /dev/null
@@ -1,34 +0,0 @@
---- src/drawGlyph.cpp.orig Wed Oct 4 16:21:41 2006
-+++ src/drawGlyph.cpp Wed Oct 4 16:23:29 2006
-@@ -81,7 +81,7 @@
- return 0;
- }
-
--static int moveTo(FT_Vector* pftVec, void* data) {
-+static int moveTo(const FT_Vector* pftVec, void* data) {
- StateOfDrawGlyph* const state = reinterpret_cast<StateOfDrawGlyph* const>(data);
- state->os() << (state->isNewPath() ? "newpath" : "closepath") << endl;
- state->setNewPathFalse();
-@@ -89,19 +89,19 @@
- return 0;
- }
-
--static int lineTo(FT_Vector* pftVec, void* data) {
-+static int lineTo(const FT_Vector* pftVec, void* data) {
- xTo(pftVec, data, "lineto");
- return 0;
- }
-
--static int cubicTo(FT_Vector* ctrlPt1, FT_Vector* ctrlPt2, FT_Vector* pEndPt, void* data) {
-+static int cubicTo(const FT_Vector* ctrlPt1, const FT_Vector* ctrlPt2, const FT_Vector* pEndPt, void* data) {
- StateOfDrawGlyph* const state = reinterpret_cast<StateOfDrawGlyph* const>(data);
- state->os() << *ctrlPt1 << " " << *ctrlPt2 << " " << *pEndPt << " curveto" << endl;
- state->setStartPt(*pEndPt);
- return 0;
- }
-
--static int conicTo(FT_Vector* pCtrlPt, FT_Vector* pEndPt, void* data) {
-+static int conicTo(const FT_Vector* pCtrlPt, const FT_Vector* pEndPt, void* data) {
- StateOfDrawGlyph* const state = reinterpret_cast<StateOfDrawGlyph* const>(data);
- FT_Vector ctrlPt1 = (state->startPt() + 2 * *pCtrlPt) / 3;
- FT_Vector ctrlPt2 = (*pEndPt + 2 * *pCtrlPt) / 3;