aboutsummaryrefslogtreecommitdiff
path: root/devel/lasi
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:54:54 +0000
commit29747f458a1eb2ce23b4594b09d0256dd62760b8 (patch)
tree1b71ba5d9ffdd308b6c18130f7c116f5bab5dc12 /devel/lasi
parent7aad84f808b93baa6a7077ce0b47573b9c4c79a0 (diff)
downloadports-29747f458a1eb2ce23b4594b09d0256dd62760b8.tar.gz
ports-29747f458a1eb2ce23b4594b09d0256dd62760b8.zip
Notes
Diffstat (limited to 'devel/lasi')
-rw-r--r--devel/lasi/Makefile3
-rw-r--r--devel/lasi/files/patch-src_drawGlyph.cpp34
2 files changed, 36 insertions, 1 deletions
diff --git a/devel/lasi/Makefile b/devel/lasi/Makefile
index cc1457909986..d2d590d4a4d7 100644
--- a/devel/lasi/Makefile
+++ b/devel/lasi/Makefile
@@ -3,10 +3,11 @@
# Whom: giffunip
#
# $FreeBSD$
-#
+# $MCom: ports/devel/lasi/Makefile,v 1.1 2006/10/04 20:25:40 ahze Exp $
PORTNAME= lasi
PORTVERSION= 1.0.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.unifont.org/lasi/download/
diff --git a/devel/lasi/files/patch-src_drawGlyph.cpp b/devel/lasi/files/patch-src_drawGlyph.cpp
new file mode 100644
index 000000000000..18338e6e1dda
--- /dev/null
+++ b/devel/lasi/files/patch-src_drawGlyph.cpp
@@ -0,0 +1,34 @@
+--- src/drawGlyph.cpp.orig Wed Oct 4 16:21:41 2006
++++ src/drawGlyph.cpp Wed Oct 4 16:23:29 2006
+@@ -81,7 +81,7 @@
+ return 0;
+ }
+
+-static int moveTo(FT_Vector* pftVec, void* data) {
++static int moveTo(const FT_Vector* pftVec, void* data) {
+ StateOfDrawGlyph* const state = reinterpret_cast<StateOfDrawGlyph* const>(data);
+ state->os() << (state->isNewPath() ? "newpath" : "closepath") << endl;
+ state->setNewPathFalse();
+@@ -89,19 +89,19 @@
+ return 0;
+ }
+
+-static int lineTo(FT_Vector* pftVec, void* data) {
++static int lineTo(const FT_Vector* pftVec, void* data) {
+ xTo(pftVec, data, "lineto");
+ return 0;
+ }
+
+-static int cubicTo(FT_Vector* ctrlPt1, FT_Vector* ctrlPt2, FT_Vector* pEndPt, void* data) {
++static int cubicTo(const FT_Vector* ctrlPt1, const FT_Vector* ctrlPt2, const FT_Vector* pEndPt, void* data) {
+ StateOfDrawGlyph* const state = reinterpret_cast<StateOfDrawGlyph* const>(data);
+ state->os() << *ctrlPt1 << " " << *ctrlPt2 << " " << *pEndPt << " curveto" << endl;
+ state->setStartPt(*pEndPt);
+ return 0;
+ }
+
+-static int conicTo(FT_Vector* pCtrlPt, FT_Vector* pEndPt, void* data) {
++static int conicTo(const FT_Vector* pCtrlPt, const FT_Vector* pEndPt, void* data) {
+ StateOfDrawGlyph* const state = reinterpret_cast<StateOfDrawGlyph* const>(data);
+ FT_Vector ctrlPt1 = (state->startPt() + 2 * *pCtrlPt) / 3;
+ FT_Vector ctrlPt2 = (*pEndPt + 2 * *pCtrlPt) / 3;