aboutsummaryrefslogtreecommitdiff
path: root/devel/lfcxml
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-07-01 05:48:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-07-01 05:48:51 +0000
commit2e25ea11a0b2e15b698d252d204e9a9eeb77beb1 (patch)
tree9f8450ecfe48e3b56686c7fa1f8432e991625d45 /devel/lfcxml
parent3ab9816c0997f477eb665cdf052191382b2e0bc4 (diff)
downloadports-2e25ea11a0b2e15b698d252d204e9a9eeb77beb1.tar.gz
ports-2e25ea11a0b2e15b698d252d204e9a9eeb77beb1.zip
Notes
Diffstat (limited to 'devel/lfcxml')
-rw-r--r--devel/lfcxml/Makefile26
-rw-r--r--devel/lfcxml/distinfo3
-rw-r--r--devel/lfcxml/pkg-descr6
-rw-r--r--devel/lfcxml/pkg-plist15
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/lfcxml/Makefile b/devel/lfcxml/Makefile
new file mode 100644
index 000000000000..7dbf9e19f4e3
--- /dev/null
+++ b/devel/lfcxml/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: cego-xml
+# Date created: Jun 12, 2010
+# Whom: Kurt Jaeger <fbsd-ports@opsec.eu>
+#
+# $FreeBSD$
+
+PORTNAME= cego-xml
+PORTVERSION= 1.0.20
+CATEGORIES= devel
+MASTER_SITES= http://www.lemke-it.com/
+DISTNAME= xml-${PORTVERSION}
+
+MAINTAINER= fbsd-ports@opsec.eu
+COMMENT= C++ XML library, used for databases/cego
+
+LIB_DEPENDS= Base.1:${PORTSDIR}/devel/cego-base
+
+LICENSE= GPLv2
+WRKSRC= ${WRKDIR}/xml
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_LDCONFIG= yes
+USE_AUTOTOOLS= autoconf:262:env
+
+.include <bsd.port.mk>
diff --git a/devel/lfcxml/distinfo b/devel/lfcxml/distinfo
new file mode 100644
index 000000000000..b48eb352ba17
--- /dev/null
+++ b/devel/lfcxml/distinfo
@@ -0,0 +1,3 @@
+MD5 (xml-1.0.20.tar.gz) = 27dc6b987712a257af20c383f2a789a1
+SHA256 (xml-1.0.20.tar.gz) = 3aa2157d2b6905d7b74c832573f00ff0732d91e26c07e39098b9b84d4859ac47
+SIZE (xml-1.0.20.tar.gz) = 136694
diff --git a/devel/lfcxml/pkg-descr b/devel/lfcxml/pkg-descr
new file mode 100644
index 000000000000..08d9bf548091
--- /dev/null
+++ b/devel/lfcxml/pkg-descr
@@ -0,0 +1,6 @@
+This is a C++ XML library, used for databases/cego and probably
+other applications
+
+Many more details are available at:
+
+WWW: http://www.lemke-it.com/
diff --git a/devel/lfcxml/pkg-plist b/devel/lfcxml/pkg-plist
new file mode 100644
index 000000000000..fe357937aa6d
--- /dev/null
+++ b/devel/lfcxml/pkg-plist
@@ -0,0 +1,15 @@
+include/Attribute.h
+include/Document.h
+include/Element.h
+include/XML.h
+include/XMLEscaper.h
+include/XMLInStream.h
+include/XMLOutStream.h
+include/XMLSuite.h
+lib/libXML.a
+lib/libXML.so.1
+share/licenses/cego-xml-1.0.20/GPLv2
+share/licenses/cego-xml-1.0.20/LICENSE
+share/licenses/cego-xml-1.0.20/catalog.mk
+@dirrm share/licenses/cego-xml-1.0.20
+@dirrm share/licenses