aboutsummaryrefslogtreecommitdiff
path: root/devel/libIDL
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-12 13:37:38 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-12 13:37:38 +0000
commit7ff087dd4d85cabddc5abf4606180c6ef4178205 (patch)
treec065bd6a3d35750afef045b5348f39dbc43dfb5b /devel/libIDL
parenta918fa6f047456e275fa548cc0e00dedef93e356 (diff)
downloadports-7ff087dd4d85cabddc5abf4606180c6ef4178205.tar.gz
ports-7ff087dd4d85cabddc5abf4606180c6ef4178205.zip
Notes
Diffstat (limited to 'devel/libIDL')
-rw-r--r--devel/libIDL/Makefile35
-rw-r--r--devel/libIDL/distinfo1
-rw-r--r--devel/libIDL/files/patch-ltmain.sh28
-rw-r--r--devel/libIDL/pkg-comment1
-rw-r--r--devel/libIDL/pkg-descr7
-rw-r--r--devel/libIDL/pkg-plist11
6 files changed, 83 insertions, 0 deletions
diff --git a/devel/libIDL/Makefile b/devel/libIDL/Makefile
new file mode 100644
index 000000000000..80a2b0f81434
--- /dev/null
+++ b/devel/libIDL/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: libIDL
+# Date Created: 12 February 2002
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libIDL
+PORTVERSION= 0.7.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+
+BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+LIB_DEPENDS= glib-1.3.13:${PORTSDIR}/devel/glib13
+RUN_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconfig
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_BISON= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+
+pre-patch:
+ @find ${WRKSRC} -name Makefile.in | xargs ${PERL} -pi -e \
+ 's|\$\(libdir\)/pkgconfig|\$\(prefix\)/libdata/pkgconfig|g'
+
+.include <bsd.port.mk>
diff --git a/devel/libIDL/distinfo b/devel/libIDL/distinfo
new file mode 100644
index 000000000000..ac22dc9b9c20
--- /dev/null
+++ b/devel/libIDL/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/libIDL-0.7.3.tar.bz2) = f52fc93a78aeb97644e882f4085bac97
diff --git a/devel/libIDL/files/patch-ltmain.sh b/devel/libIDL/files/patch-ltmain.sh
new file mode 100644
index 000000000000..98cb05e4ddb3
--- /dev/null
+++ b/devel/libIDL/files/patch-ltmain.sh
@@ -0,0 +1,28 @@
+
+$FreeBSD$
+
+--- ltmain.sh 2001/08/27 09:51:26 1.1
++++ ltmain.sh 2001/08/27 09:51:42
+@@ -2408,6 +2408,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4175,10 +4178,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/libIDL/pkg-comment b/devel/libIDL/pkg-comment
new file mode 100644
index 000000000000..e6b3875dc8fd
--- /dev/null
+++ b/devel/libIDL/pkg-comment
@@ -0,0 +1 @@
+A library for creating trees of CORBA Interface Definition Language files
diff --git a/devel/libIDL/pkg-descr b/devel/libIDL/pkg-descr
new file mode 100644
index 000000000000..d681c4203d9d
--- /dev/null
+++ b/devel/libIDL/pkg-descr
@@ -0,0 +1,7 @@
+libIDL is a library for creating trees of CORBA Interface Definition Language
+(IDL) files, which is a specification for defining portable interfaces.
+libIDL was initially written for ORBit (the ORB from the GNOME project, and
+the primary means of libIDL distribution). However, the functionality was
+designed to be as reusable and portable as possible.
+
+WWW: http://www.gnome.org/
diff --git a/devel/libIDL/pkg-plist b/devel/libIDL/pkg-plist
new file mode 100644
index 000000000000..4cc68d5f75de
--- /dev/null
+++ b/devel/libIDL/pkg-plist
@@ -0,0 +1,11 @@
+bin/libIDL-config-2
+include/libIDL-2.0/libIDL/IDL.h
+@unexec install-info --delete %D/info/libIDL2.info %D/info/dir
+info/libIDL2.info
+@exec install-info %D/info/libIDL2.info %D/info/dir
+lib/libIDL-2.a
+lib/libIDL-2.so
+lib/libIDL-2.so.0
+libdata/pkgconfig/libIDL-2.0.pc
+@dirrm include/libIDL-2.0/libIDL
+@dirrm include/libIDL-2.0