aboutsummaryrefslogtreecommitdiff
path: root/devel/libarea/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-14 21:38:21 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-03-14 21:38:21 +0000
commit55bf9d47c4454f730aeb65e3408f69405bb213bb (patch)
treede97385982dd9d508c8741e00c7045fc40b1b1f2 /devel/libarea/Makefile
parentd8a33b3b60da49a05b807cb9c16bf10480ddbda6 (diff)
downloadports-55bf9d47c4454f730aeb65e3408f69405bb213bb.tar.gz
ports-55bf9d47c4454f730aeb65e3408f69405bb213bb.zip
Notes
Diffstat (limited to 'devel/libarea/Makefile')
-rw-r--r--devel/libarea/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/libarea/Makefile b/devel/libarea/Makefile
new file mode 100644
index 000000000000..4c9bb53f867d
--- /dev/null
+++ b/devel/libarea/Makefile
@@ -0,0 +1,23 @@
+# Created by: Pedro Giffuni
+# $FreeBSD$
+
+PORTNAME= libarea
+PORTVERSION= 20160313
+CATEGORIES= devel cad
+
+MAINTAINER= pfg@FreeBSD.org
+COMMENT= CAM-related software for profile and pocketing operations
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= python-config:${PORTSDIR}/lang/python
+LIB_DEPENDS= libboost_python.so:${PORTSDIR}/devel/boost-python-libs
+
+USE_GITHUB= yes
+GH_ACCOUNT= Heeks
+GH_TAGNAME= f1986ac
+
+USES= cmake:outsource python
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>