aboutsummaryrefslogtreecommitdiff
path: root/devel/libarena
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2007-04-26 02:21:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2007-04-26 02:21:58 +0000
commitbc59b0dcf776f4bd3cf3d8820ff8d9ab5401f297 (patch)
treef474b9ba5181814f5b1fa6c75537f6269fbb256b /devel/libarena
parent9ba0da79c9f384f7460f770526069b9d7b1afe86 (diff)
downloadports-bc59b0dcf776f4bd3cf3d8820ff8d9ab5401f297.tar.gz
ports-bc59b0dcf776f4bd3cf3d8820ff8d9ab5401f297.zip
Notes
Diffstat (limited to 'devel/libarena')
-rw-r--r--devel/libarena/Makefile27
-rw-r--r--devel/libarena/distinfo3
-rw-r--r--devel/libarena/pkg-descr17
3 files changed, 47 insertions, 0 deletions
diff --git a/devel/libarena/Makefile b/devel/libarena/Makefile
new file mode 100644
index 000000000000..8f3f6f8efae8
--- /dev/null
+++ b/devel/libarena/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: libarena
+# Date created: Apr 22, 2007
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= libarena
+PORTVERSION= 0.3.1
+CATEGORIES= devel
+MASTER_SITES= http://www.25thandclement.com/~william/projects/releases/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+COMMENT= Custom Memory Allocator Interface
+
+USE_GMAKE= yes
+
+PLIST_FILES= include/arena/pool.h \
+ include/arena/proto.h \
+ include/arena/rbits.h \
+ include/arena/util.h \
+ lib/libarena.a
+PLIST_DIRS= include/arena
+
+.include <bsd.port.mk>
diff --git a/devel/libarena/distinfo b/devel/libarena/distinfo
new file mode 100644
index 000000000000..60159428f6db
--- /dev/null
+++ b/devel/libarena/distinfo
@@ -0,0 +1,3 @@
+MD5 (libarena-0.3.1.tgz) = 6e2e4ac8b13c2477ddaab48ccc5f7bc5
+SHA256 (libarena-0.3.1.tgz) = c64dc09ca806dbf549405ba932e27c6cc9c37af815393377232e5641b554b035
+SIZE (libarena-0.3.1.tgz) = 20198
diff --git a/devel/libarena/pkg-descr b/devel/libarena/pkg-descr
new file mode 100644
index 000000000000..96f313cacb9a
--- /dev/null
+++ b/devel/libarena/pkg-descr
@@ -0,0 +1,17 @@
+libarena is a custom memory allocator interface and implementation. Four
+allocators are provided: flat LIFO arena allocator, object pool allocator
+and two malloc(3) wrappers: one which returns the pointers unadulterated
+and one which obeys the requested, arbitrary alignment. These can be used
+directly, or through their exported prototype interfaces.
+
+libarena is meant to provide a baseline interface so allocator's can be
+stacked, and to provide a simple and well defined interface for libraries
+and applications without becoming mired in features or capabilities. It is
+not meant to restrict or confine what custom allocators can actually
+accomplish. For instance, the included pool and arena allocators include a
+suite of string utilities which aren't available in the generic exportable
+interface. Note that these string utilities are built upon a generic
+interface (see util.h) which can take the prototypical allocation context,
+so they are also available to any 3rd party compatible allocators.
+
+WWW: http://www.25thandclement.com/~william/projects/libarena.html