aboutsummaryrefslogtreecommitdiff
path: root/devel/libassa
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-07 12:16:02 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-07 12:16:02 +0000
commitaa9dba3f8472275e1bd8ddc5afa502f9912e0af9 (patch)
treeb326fc8974ac2f6dad5143b1a371a12a36eaf0ca /devel/libassa
parent349535f180fbfb86534f098b6315977ebb3bf75b (diff)
downloadports-aa9dba3f8472275e1bd8ddc5afa502f9912e0af9.tar.gz
ports-aa9dba3f8472275e1bd8ddc5afa502f9912e0af9.zip
Notes
Diffstat (limited to 'devel/libassa')
-rw-r--r--devel/libassa/Makefile2
-rw-r--r--devel/libassa/distinfo6
-rw-r--r--devel/libassa/files/patch-assa:Address.h16
-rw-r--r--devel/libassa/files/patch-assa:INETAddress.cpp18
-rw-r--r--devel/libassa/files/patch-assa:Logger_Impl.cpp6
-rw-r--r--devel/libassa/files/patch-examples:logserver:server:MonitorConn.cpp23
-rw-r--r--devel/libassa/files/patch-tests:semaphore_test.cpp8
-rw-r--r--devel/libassa/pkg-plist3
8 files changed, 40 insertions, 42 deletions
diff --git a/devel/libassa/Makefile b/devel/libassa/Makefile
index 681ca45f40a4..0ab03ad19782 100644
--- a/devel/libassa/Makefile
+++ b/devel/libassa/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= libassa
-PORTVERSION= 3.4.1
+PORTVERSION= 3.4.2
PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
diff --git a/devel/libassa/distinfo b/devel/libassa/distinfo
index 7925e7bdb9da..d5bdc2652270 100644
--- a/devel/libassa/distinfo
+++ b/devel/libassa/distinfo
@@ -1,3 +1,3 @@
-MD5 (libassa-3.4.1.tar.gz) = 0845507869d2d081c5fdb21cbf306c86
-SHA256 (libassa-3.4.1.tar.gz) = b002e3b07fbc13e878e0b27ce73b402cf8d06e36a133bed326c84e9318a4a2db
-SIZE (libassa-3.4.1.tar.gz) = 555183
+MD5 (libassa-3.4.2.tar.gz) = f0248280c11571ac7ab511d17f4a2076
+SHA256 (libassa-3.4.2.tar.gz) = 75bd519b9900c124dbc0866ce3acd9ba0840d54e646809a89488196fb857f402
+SIZE (libassa-3.4.2.tar.gz) = 594145
diff --git a/devel/libassa/files/patch-assa:Address.h b/devel/libassa/files/patch-assa:Address.h
index 3b3e679bf477..814c06ce1a1b 100644
--- a/devel/libassa/files/patch-assa:Address.h
+++ b/devel/libassa/files/patch-assa:Address.h
@@ -1,10 +1,10 @@
---- assa/Address.h.orig Thu Jan 29 00:58:13 2004
-+++ assa/Address.h Thu Jan 29 01:11:14 2004
-@@ -12,7 +12,6 @@
- #ifndef ADDRESS_H
+--- assa/Address.h.orig Wed Sep 6 16:13:45 2006
++++ assa/Address.h Wed Sep 6 16:13:57 2006
+@@ -13,7 +13,6 @@
#define ADDRESS_H
--#include <netinet/in.h>
- #include <netdb.h>
- #include <sys/types.h>
- #include <sys/socket.h>
+ #if !defined (WIN32)
+-# include <netinet/in.h>
+ # include <netdb.h>
+ # include <sys/types.h>
+ # include <sys/socket.h>
diff --git a/devel/libassa/files/patch-assa:INETAddress.cpp b/devel/libassa/files/patch-assa:INETAddress.cpp
index 7f4de7d28d45..70f1de7231cc 100644
--- a/devel/libassa/files/patch-assa:INETAddress.cpp
+++ b/devel/libassa/files/patch-assa:INETAddress.cpp
@@ -1,10 +1,10 @@
---- assa/INETAddress.cpp.orig Thu Jan 22 23:53:34 2004
-+++ assa/INETAddress.cpp Thu Jan 22 23:53:45 2004
-@@ -14,6 +14,7 @@
-
- #include <netdb.h> // gethostbyname(3)
+--- assa/INETAddress.cpp.orig Thu Jul 20 06:13:13 2006
++++ assa/INETAddress.cpp Wed Sep 6 16:13:15 2006
+@@ -17,6 +17,7 @@
+ #else
+ # include <netdb.h> // gethostbyname(3)
extern int h_errno; // gethostbyname(3)
-+#include <sys/types.h>
- #include <sys/socket.h> // for AF_INET
- #include <unistd.h>
- #include <sys/utsname.h>
++# include <sys/types.h> // for AF_INET
+ # include <sys/socket.h> // for AF_INET
+ # include <unistd.h>
+ # include <sys/utsname.h>
diff --git a/devel/libassa/files/patch-assa:Logger_Impl.cpp b/devel/libassa/files/patch-assa:Logger_Impl.cpp
index 62fbbd030455..fdd6da34d6c1 100644
--- a/devel/libassa/files/patch-assa:Logger_Impl.cpp
+++ b/devel/libassa/files/patch-assa:Logger_Impl.cpp
@@ -1,10 +1,10 @@
---- assa/Logger_Impl.cpp.orig Thu Jan 29 01:12:05 2004
-+++ assa/Logger_Impl.cpp Thu Jan 29 01:12:37 2004
+--- assa/Logger_Impl.cpp.orig Thu Jul 20 06:30:54 2006
++++ assa/Logger_Impl.cpp Wed Sep 6 16:20:05 2006
@@ -14,6 +14,7 @@
#include <iostream>
#include <iomanip>
+#include <cstdio>
+ #include <string.h> // strerror(3)
#include "assa/TimeVal.h"
- #include "assa/Logger_Impl.h"
diff --git a/devel/libassa/files/patch-examples:logserver:server:MonitorConn.cpp b/devel/libassa/files/patch-examples:logserver:server:MonitorConn.cpp
index 81e49e4c600c..6bfc2a1c9763 100644
--- a/devel/libassa/files/patch-examples:logserver:server:MonitorConn.cpp
+++ b/devel/libassa/files/patch-examples:logserver:server:MonitorConn.cpp
@@ -1,12 +1,11 @@
---- examples/logserver/server/MonitorConn.cpp.orig Thu Jan 29 08:53:46 2004
-+++ examples/logserver/server/MonitorConn.cpp Thu Jan 29 08:54:16 2004
-@@ -19,6 +19,9 @@
- #include "Conn.h"
- #include "LogServer-main.h"
- #include "LogServer.h"
-+#include <algorithm>
-+
-+using namespace std;
-
- /** Convert user input to upper case
- */
+--- examples/logserver/server/MonitorConn.cpp.orig Thu Jul 20 10:30:55 2006
++++ examples/logserver/server/MonitorConn.cpp Thu Sep 7 16:18:01 2006
+@@ -20,6 +20,8 @@
+ #include "LogServer-main.h"
+ #include "LogServer.h"
+
++#include <algorithm>
++
+ /** Convert user input to upper case
+ */
+ template <class T>
diff --git a/devel/libassa/files/patch-tests:semaphore_test.cpp b/devel/libassa/files/patch-tests:semaphore_test.cpp
index 145bc7bcf88d..1e703fa9103d 100644
--- a/devel/libassa/files/patch-tests:semaphore_test.cpp
+++ b/devel/libassa/files/patch-tests:semaphore_test.cpp
@@ -1,10 +1,10 @@
---- tests/semaphore_test.cpp.orig Thu Jan 29 08:42:17 2004
-+++ tests/semaphore_test.cpp Thu Jan 29 08:42:43 2004
+--- tests/semaphore_test.cpp.orig Thu Jul 20 06:30:56 2006
++++ tests/semaphore_test.cpp Wed Sep 6 16:30:11 2006
@@ -16,6 +16,7 @@
using namespace std;
#include <assert.h>
+#include <sys/types.h>
- #include <sys/ipc.h> // ftok(2)
- #include "assa/Assert.h"
+ #if !defined (WIN32)
+ # include <sys/ipc.h> // ftok(2)
diff --git a/devel/libassa/pkg-plist b/devel/libassa/pkg-plist
index 639c3955c67f..9c05af22f8c7 100644
--- a/devel/libassa/pkg-plist
+++ b/devel/libassa/pkg-plist
@@ -1,4 +1,5 @@
bin/assa-genesis
+bin/assa-hexdump
include/assa-%%ASSA_VERSION%%/assa/Acceptor.h
include/assa-%%ASSA_VERSION%%/assa/Address.h
include/assa-%%ASSA_VERSION%%/assa/Assa.h
@@ -60,8 +61,6 @@ lib/libassa-%%ASSA_VERSION%%.a
lib/libassa-%%ASSA_VERSION%%.la
lib/libassa-%%ASSA_VERSION%%.so
lib/libassa-%%ASSA_VERSION%%.so.4
-@comment For non-standard prefixes
-@unexec rm -f %D/libdata/ldconfig/libassa 2>/dev/null || true
libdata/pkgconfig/assa-%%ASSA_VERSION%%.pc
@dirrm include/assa-%%ASSA_VERSION%%/assa
@dirrm include/assa-%%ASSA_VERSION%%