aboutsummaryrefslogtreecommitdiff
path: root/devel/libaura/Makefile
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-04-19 06:45:21 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-04-19 06:45:21 +0000
commit9b8c97303206065b20ca87a1351149926716c656 (patch)
tree98303f46cb7f9f8750565892722d806bb93e65fe /devel/libaura/Makefile
parentb3d28b0549ae3abb3993ccd22e6461604b49a75f (diff)
downloadports-9b8c97303206065b20ca87a1351149926716c656.tar.gz
ports-9b8c97303206065b20ca87a1351149926716c656.zip
Notes
Diffstat (limited to 'devel/libaura/Makefile')
-rw-r--r--devel/libaura/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/devel/libaura/Makefile b/devel/libaura/Makefile
new file mode 100644
index 000000000000..6a60834d1db0
--- /dev/null
+++ b/devel/libaura/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: libaura
+# Date created: 18 April 2006
+# Whom: Andrew Turner <andrew+ports@fubar.geek.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libaura
+PORTVERSION= 3.1.20051222
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= philip
+
+MAINTAINER= andrew+ports@fubar.geek.nz
+COMMENT= Library of Assorted Useful Reusable Abstractions
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+
+SONAME= ${SOLINK}.3
+SOLINK= ${PORTNAME}3.so
+
+PLIST_FILES= lib/${SONAME} \
+ lib/${SOLINK} \
+ include/aura3/buffer.h \
+ include/aura3/dict.h \
+ include/aura3/popen.h \
+ include/aura3/fspred.h \
+ include/aura3/mem.h
+PLIST_DIRS= include/aura3
+PORTDOCS= README
+
+MAKE_ENV= SONAME=${SONAME} SOLINK=${SOLINK}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${SONAME} ${PREFIX}/lib/${SONAME}
+ ${LN} -s ${PREFIX}/lib/${SONAME} ${PREFIX}/lib/${SOLINK}
+ ${MKDIR} ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/buffer.h ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/dict.h ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/popen.h ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/fspred.h ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/mem.h ${PREFIX}/include/aura3/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>