aboutsummaryrefslogtreecommitdiff
path: root/devel/libaura
diff options
context:
space:
mode:
authorPhilip Paeps <philip@FreeBSD.org>2006-04-19 06:45:21 +0000
committerPhilip Paeps <philip@FreeBSD.org>2006-04-19 06:45:21 +0000
commit9b8c97303206065b20ca87a1351149926716c656 (patch)
tree98303f46cb7f9f8750565892722d806bb93e65fe /devel/libaura
parentb3d28b0549ae3abb3993ccd22e6461604b49a75f (diff)
downloadports-9b8c97303206065b20ca87a1351149926716c656.tar.gz
ports-9b8c97303206065b20ca87a1351149926716c656.zip
Notes
Diffstat (limited to 'devel/libaura')
-rw-r--r--devel/libaura/Makefile49
-rw-r--r--devel/libaura/distinfo3
-rw-r--r--devel/libaura/files/patch-Makefile12
-rw-r--r--devel/libaura/pkg-descr10
4 files changed, 74 insertions, 0 deletions
diff --git a/devel/libaura/Makefile b/devel/libaura/Makefile
new file mode 100644
index 000000000000..6a60834d1db0
--- /dev/null
+++ b/devel/libaura/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: libaura
+# Date created: 18 April 2006
+# Whom: Andrew Turner <andrew+ports@fubar.geek.nz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libaura
+PORTVERSION= 3.1.20051222
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= philip
+
+MAINTAINER= andrew+ports@fubar.geek.nz
+COMMENT= Library of Assorted Useful Reusable Abstractions
+
+USE_BZIP2= yes
+INSTALLS_SHLIB= yes
+
+SONAME= ${SOLINK}.3
+SOLINK= ${PORTNAME}3.so
+
+PLIST_FILES= lib/${SONAME} \
+ lib/${SOLINK} \
+ include/aura3/buffer.h \
+ include/aura3/dict.h \
+ include/aura3/popen.h \
+ include/aura3/fspred.h \
+ include/aura3/mem.h
+PLIST_DIRS= include/aura3
+PORTDOCS= README
+
+MAKE_ENV= SONAME=${SONAME} SOLINK=${SOLINK}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${SONAME} ${PREFIX}/lib/${SONAME}
+ ${LN} -s ${PREFIX}/lib/${SONAME} ${PREFIX}/lib/${SOLINK}
+ ${MKDIR} ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/buffer.h ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/dict.h ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/popen.h ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/fspred.h ${PREFIX}/include/aura3/
+ ${INSTALL_DATA} ${WRKSRC}/mem.h ${PREFIX}/include/aura3/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libaura/distinfo b/devel/libaura/distinfo
new file mode 100644
index 000000000000..b51951836bf0
--- /dev/null
+++ b/devel/libaura/distinfo
@@ -0,0 +1,3 @@
+MD5 (libaura-3.1.20051222.tar.bz2) = d684f892863574c131f8ef0ccf47161a
+SHA256 (libaura-3.1.20051222.tar.bz2) = 3bb1bfcdeb6bb6025fe1e4c563060a667a71a11954e5e7efa46e71c12ab74615
+SIZE (libaura-3.1.20051222.tar.bz2) = 10929
diff --git a/devel/libaura/files/patch-Makefile b/devel/libaura/files/patch-Makefile
new file mode 100644
index 000000000000..882ea693e5e1
--- /dev/null
+++ b/devel/libaura/files/patch-Makefile
@@ -0,0 +1,12 @@
+--- Makefile.orig Tue Apr 18 12:32:27 2006
++++ Makefile Tue Apr 18 12:56:00 2006
+@@ -1,9 +1,6 @@
+ # Makefile for libaura.
+ # $Id: Makefile,v 1.20 2005/08/26 22:44:37 cpressey Exp $
+
+-BASE?=../..
+-include ${BASE}/Config
+-
+ LIB= aura
+ LIB_VER=3
+
diff --git a/devel/libaura/pkg-descr b/devel/libaura/pkg-descr
new file mode 100644
index 000000000000..c3bba1f703fa
--- /dev/null
+++ b/devel/libaura/pkg-descr
@@ -0,0 +1,10 @@
+Libaura is a library of Assorted Useful Reusable Abstractions -
+data structures and utilities for C language programming. At
+present, they include:
+
+- memory allocators/deallocators
+- key<->value dictionaries (hashed or sorted)
+- extensible buffers
+- filesystem predicates (is_dir, is_named_pipe, etc)
+- popen() variation which allows the caller to know the pid of
+ the process on the other end of the pipe.