aboutsummaryrefslogtreecommitdiff
path: root/devel/libbnr/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-01-21 00:20:56 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-01-21 00:20:56 +0000
commitc1468c1fa886fd323b2f83238244c4b5cb077f84 (patch)
treec07feebef4a421dfe7f0d04d8df6ab2b8f692a7c /devel/libbnr/Makefile
parent1fa4eb22d9e3444f33fb5cd25e87aaa09f1af108 (diff)
Notes
Diffstat (limited to 'devel/libbnr/Makefile')
-rw-r--r--devel/libbnr/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/devel/libbnr/Makefile b/devel/libbnr/Makefile
index 31b14b8fbf14..82a614de8ec2 100644
--- a/devel/libbnr/Makefile
+++ b/devel/libbnr/Makefile
@@ -11,24 +11,21 @@ MASTER_SITES= http://dspam.nuclearelephant.com/sources/extras/ \
MAINTAINER= itetcu@FreeBSD.org
COMMENT= GPL implementation of the Bayesian Noise Reduction algorithm
+OPTIONS_DEFINE= DOCS DEBUG
+
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS+= --includedir=${PREFIX}/include/${PORTNAME}
-.ifdef(WITH_DEBUG)
-CFLAGS+= -g -DDEBUG
-.endif
+DEBUG_CFLAGS= -g -DDEBUG
PORTDOCS= README
-NO_STAGE= yes
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/example.c ${EXAMPLESDIR}
-.ifndef(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/example.c ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>