aboutsummaryrefslogtreecommitdiff
path: root/devel/libbobcat
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2009-11-17 12:36:41 +0000
committerGabor Pali <pgj@FreeBSD.org>2009-11-17 12:36:41 +0000
commit0894a6e1e10cb52bbdeef9235abece9e4445d172 (patch)
treed0145a3155f485b2348e8a95cf96ae53bc2c0256 /devel/libbobcat
parent089fa70c0950887b811742c82b9f9c5d4805884a (diff)
downloadports-0894a6e1e10cb52bbdeef9235abece9e4445d172.tar.gz
ports-0894a6e1e10cb52bbdeef9235abece9e4445d172.zip
Notes
Diffstat (limited to 'devel/libbobcat')
-rw-r--r--devel/libbobcat/Makefile63
-rw-r--r--devel/libbobcat/distinfo6
-rw-r--r--devel/libbobcat/files/patch-cgi-accept.cc11
-rw-r--r--devel/libbobcat/files/patch-cgi-push.cc11
-rw-r--r--devel/libbobcat/files/patch-icmake-man8
-rw-r--r--devel/libbobcat/files/patch-localsocketbase-localsocketbase.ih12
-rw-r--r--devel/libbobcat/pkg-plist6
7 files changed, 87 insertions, 30 deletions
diff --git a/devel/libbobcat/Makefile b/devel/libbobcat/Makefile
index c6c7785e87d3..d590572ae928 100644
--- a/devel/libbobcat/Makefile
+++ b/devel/libbobcat/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libbobcat
-PORTVERSION= 2.02.02
+PORTVERSION= 2.05.00
CATEGORIES= devel
MASTER_SITES= SF/bobcat/bobcat/${PORTVERSION}
DISTNAME= bobcat_${PORTVERSION}
@@ -17,32 +17,37 @@ COMMENT= Brokken's Own Base Classes And Templates
BUILD_DEPENDS= icmake:${PORTSDIR}/devel/icmake \
${LOCALBASE}/include/X11/Xlib.h:${PORTSDIR}/x11/libX11 \
- yodl>=2.0:${PORTSDIR}/textproc/yodl
+ yodl>=2.0:${PORTSDIR}/textproc/yodl \
+ g++45:${PORTSDIR}/lang/gcc45
MANCOMPRESSED= yes
MAN1= bobcatlcgen.1
MAN3= a2x.3bobcat align.3bobcat arg.3bobcat argconfig.3bobcat \
- autoptr.3bobcat binarysearch.3bobcat cgi.3bobcat \
- clientsocket.3bobcat cmdfinder.3bobcat cmdfinderbase.3bobcat \
- configfile.3bobcat datetime.3bobcat errno.3bobcat \
- fnwrap1.3bobcat fnwrap1c.3bobcat fnwrap2.3bobcat \
- fnwrap2c.3bobcat foreach.3bobcat fork.3bobcat \
- gethostent.3bobcat glob.3bobcat hash.3bobcat hostent.3bobcat \
- hostname.3bobcat ifdstream.3bobcat ifdstreambuf.3bobcat \
- indent.3bobcat inetaddress.3bobcat iostream.3bobcat \
- iostreambuf.3bobcat irandstream.3bobcat lc.3bobcat level.3bobcat \
- lm.3bobcat localclientsocket.3bobcat localserversocket.3bobcat \
+ autoptr.3bobcat bigint.3bobcat binarysearch.3bobcat \
+ cgi.3bobcat clientsocket.3bobcat cmdfinder.3bobcat \
+ cmdfinderbase.3bobcat configfile.3bobcat datetime.3bobcat \
+ decryptbuf.3bobcat digestbuf.3bobcat encryptbuf.3bobcat \
+ errno.3bobcat fnwrap1.3bobcat fnwrap1c.3bobcat \
+ fnwrap2.3bobcat fnwrap2c.3bobcat foreach.3bobcat \
+ fork.3bobcat gethostent.3bobcat glob.3bobcat hash.3bobcat \
+ hmacbuf.3bobcat hostent.3bobcat hostname.3bobcat \
+ ifdstream.3bobcat ifdstreambuf.3bobcat indent.3bobcat \
+ inetaddress.3bobcat iostream.3bobcat iostreambuf.3bobcat \
+ irandstream.3bobcat lc.3bobcat level.3bobcat lm.3bobcat \
+ localclientsocket.3bobcat localserversocket.3bobcat \
localsocketbase.3bobcat log.3bobcat logbuffer.3bobcat \
mailheaders.3bobcat manipulators.3bobcat milter.3bobcat \
- mlm.3bobcat msg.3bobcat multistreambuf.3bobcat ofdstream.3bobcat \
- ofdstreambuf.3bobcat ofilterstreambuf.3bobcat ofoldstream.3bobcat \
- ofoldstreambuf.3bobcat onekey.3bobcat pattern.3bobcat \
- pipe.3bobcat process.3bobcat randbuffer.3bobcat \
- redirector.3bobcat refcount.3bobcat repeat.3bobcat \
- selector.3bobcat serversocket.3bobcat socketbase.3bobcat \
- stat.3bobcat string.3bobcat syslogbuf.3bobcat \
- syslogstream.3bobcat table.3bobcat tablesupport.3bobcat \
- typetrait.3bobcat user.3bobcat x2a.3bobcat xpointer.3bobcat
+ mlm.3bobcat msg.3bobcat multistreambuf.3bobcat \
+ ofdstream.3bobcat ofdstreambuf.3bobcat \
+ ofilterstreambuf.3bobcat ofoldstream.3bobcat \
+ ofoldstreambuf.3bobcat ohexstreambuf.3bobcat onekey.3bobcat \
+ pattern.3bobcat pipe.3bobcat process.3bobcat \
+ randbuffer.3bobcat redirector.3bobcat refcount.3bobcat \
+ repeat.3bobcat selector.3bobcat serversocket.3bobcat \
+ socketbase.3bobcat stat.3bobcat string.3bobcat \
+ syslogbuf.3bobcat syslogstream.3bobcat table.3bobcat \
+ tablesupport.3bobcat typetrait.3bobcat user.3bobcat \
+ x2a.3bobcat xpointer.3bobcat
MAN7= bobcat.7
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME}-${PORTVERSION}
@@ -53,19 +58,31 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}"
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/bobcat-${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+BUILD_DEPENDS+= openssl>=0.9.8:${PORTSDIR}/security/openssl
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|"/usr"|"${PREFIX}"| ; \
s|"/share/doc/libbobcat2"|"/share/doc/${PORTNAME}-${PORTVERSION}"| ; \
s|"/share/doc/libbobcat2-dev"|"/share/doc/${PORTNAME}-${PORTVERSION}/dev"| ; \
s|"/share/man"|"/man"| ; \
s|"-d"|"-Pp"| ; \
- s|#define MANHTML||' \
+ s|#define MANHTML|| ; \
+ s|g++|g++45| ; \
+ s|gcc|gcc45|' \
${WRKSRC}/INSTALL.im
@${REINPLACE_CMD} -e 's|#!/usr/bin/icmake|#!${LOCALBASE}/bin/icmake| ; \
s|"-Itmp -Wall -O3"|"-Itmp -I${LOCALBASE}/include -Wall ${CXXFLAGS}"|' \
${WRKSRC}/build
@${REINPLACE_CMD} -e 's|"cp -r |"cp -R |' \
${WRKSRC}/icmake/install
+ @${REINPLACE_CMD} -e 's|-lssl|-lssl -L${LOCALBASE}/lib| ; \
+ s|-lX11|-lX11 -L${LOCALBASE}/lib| ; \
+ s|-lmilter|-lmilter -lpthread|' \
+ ${WRKSRC}/icmake/special
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|#define DOCOTHER||' \
${WRKSRC}/INSTALL.im
@@ -77,4 +94,4 @@ do-build:
do-install:
@cd ${WRKSRC} && ./build install
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/libbobcat/distinfo b/devel/libbobcat/distinfo
index f1f1f930aac2..f292884f3a4c 100644
--- a/devel/libbobcat/distinfo
+++ b/devel/libbobcat/distinfo
@@ -1,3 +1,3 @@
-MD5 (bobcat_2.02.02.orig.tar.gz) = dd74c4447c081bbd47b70f3758567222
-SHA256 (bobcat_2.02.02.orig.tar.gz) = 188c611be803100a92480ed09ecf53cf524f87f9aa316be53409f256b66c92c5
-SIZE (bobcat_2.02.02.orig.tar.gz) = 565420
+MD5 (bobcat_2.05.00.orig.tar.gz) = 0b38b8f6962460a05c7afcfa0362d1d4
+SHA256 (bobcat_2.05.00.orig.tar.gz) = 15bb15d2a828eda52b575eefd4924eecc4504050df0f1babef8daa37e4edaac9
+SIZE (bobcat_2.05.00.orig.tar.gz) = 557462
diff --git a/devel/libbobcat/files/patch-cgi-accept.cc b/devel/libbobcat/files/patch-cgi-accept.cc
new file mode 100644
index 000000000000..5a0a3fedfbc1
--- /dev/null
+++ b/devel/libbobcat/files/patch-cgi-accept.cc
@@ -0,0 +1,11 @@
+--- cgi/accept.cc.orig 2009-09-01 10:41:09.000000000 +0200
++++ cgi/accept.cc 2009-10-05 02:52:05.000000000 +0200
+@@ -4,7 +4,7 @@
+ {
+ for_each(d_buffer.rbegin() + 1, d_buffer.rend(),
+ d_stack,
+- static_cast<void (stack<char>::*)(char &&)>(&stack<char>::push));
++ static_cast<void (stack<char>::*)(char const &)>(&stack<char>::push));
+
+ // With g++4-4 (?)
+ // static_cast<void (stack<char>::*)(char const &)>(&stack<char>::push));
diff --git a/devel/libbobcat/files/patch-cgi-push.cc b/devel/libbobcat/files/patch-cgi-push.cc
new file mode 100644
index 000000000000..16e243187aaf
--- /dev/null
+++ b/devel/libbobcat/files/patch-cgi-push.cc
@@ -0,0 +1,11 @@
+--- cgi/push.cc.orig 2009-09-01 10:41:09.000000000 +0200
++++ cgi/push.cc 2009-10-05 02:47:46.000000000 +0200
+@@ -3,7 +3,7 @@
+ void CGIFSA::push()
+ {
+ for_each(d_buffer.begin(), d_buffer.end(), d_stack,
+- static_cast<void (stack<char>::*)(char &&)>(&stack<char>::push));
++ static_cast<void (stack<char>::*)(char const &)>(&stack<char>::push));
+
+ // With g++4-4 (?)
+ // static_cast<void (stack<char>::*)(char const &)>(&stack<char>::push));
diff --git a/devel/libbobcat/files/patch-icmake-man b/devel/libbobcat/files/patch-icmake-man
index f744d470f9cc..0451d07f024c 100644
--- a/devel/libbobcat/files/patch-icmake-man
+++ b/devel/libbobcat/files/patch-icmake-man
@@ -1,5 +1,5 @@
---- icmake/man.orig 2009-03-10 05:33:46.000000000 +0100
-+++ icmake/man 2009-03-10 05:38:20.000000000 +0100
+--- icmake/man.orig 2009-09-01 10:41:10.000000000 +0200
++++ icmake/man 2009-10-04 16:00:03.000000000 +0200
@@ -9,7 +9,10 @@
special(0, 0);
@@ -25,10 +25,10 @@
yo = makelist("*.yo") - (list)"bobcat.yo" - (list)"bobcatlcgen.yo";
@@ -43,8 +48,10 @@
- run("yodl2man --no-warnings -o ../../tmp/man/man3/" +
+ run("yodl2man --no-warnings -r 15000 -o ../../tmp/man/man3/" +
base + ".3bobcat " + yodl);
+#ifdef MANHTML
- run("yodl2html --no-warnings -o ../../tmp/manhtml/" +
+ run("yodl2html --no-warnings -r 15000 -o ../../tmp/manhtml/" +
base + ".3.html " + yodl);
+#endif
}
diff --git a/devel/libbobcat/files/patch-localsocketbase-localsocketbase.ih b/devel/libbobcat/files/patch-localsocketbase-localsocketbase.ih
new file mode 100644
index 000000000000..2c1fce5703d9
--- /dev/null
+++ b/devel/libbobcat/files/patch-localsocketbase-localsocketbase.ih
@@ -0,0 +1,12 @@
+--- localsocketbase/localsocketbase.ih.orig 2007-02-13 13:29:39.000000000 +0100
++++ localsocketbase/localsocketbase.ih 2009-10-05 02:41:02.000000000 +0200
+@@ -1,6 +1,9 @@
+ #include "localsocketbase"
+
+ #include <netinet/in.h>
++#ifdef __FreeBSD__
++#include <string.h>
++#endif
+
+ using namespace std;
+ using namespace FBB;
diff --git a/devel/libbobcat/pkg-plist b/devel/libbobcat/pkg-plist
index f233d3aac9c6..3a9fcd10669b 100644
--- a/devel/libbobcat/pkg-plist
+++ b/devel/libbobcat/pkg-plist
@@ -5,12 +5,16 @@ include/bobcat/align
include/bobcat/arg
include/bobcat/argconfig
include/bobcat/autoptr
+include/bobcat/bigint
include/bobcat/cgi
include/bobcat/clientsocket
include/bobcat/cmdfinder
include/bobcat/cmdfinderbase
include/bobcat/configfile
include/bobcat/datetime
+include/bobcat/decryptbuf
+include/bobcat/digestbuf
+include/bobcat/encryptbuf
include/bobcat/errno
include/bobcat/fnwrap1
include/bobcat/fnwrap1c
@@ -21,6 +25,7 @@ include/bobcat/fork
include/bobcat/gethostent
include/bobcat/glob
include/bobcat/hash
+include/bobcat/hmacbuf
include/bobcat/hostent
include/bobcat/hostname
include/bobcat/ifdstream
@@ -46,6 +51,7 @@ include/bobcat/ofdstreambuf
include/bobcat/ofilterstreambuf
include/bobcat/ofoldstream
include/bobcat/ofoldstreambuf
+include/bobcat/ohexstreambuf
include/bobcat/onekey
include/bobcat/pattern
include/bobcat/pipe