aboutsummaryrefslogtreecommitdiff
path: root/devel/libbonobo
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
commit9c0caae1c20155b432bb0feb074a8fd9cc1c12bc (patch)
tree534d0190982c831de589344c3003940ec6f2d6b1 /devel/libbonobo
parent27d17afba2c21f490ea8472d7aa37495e02e3ed8 (diff)
Notes
Diffstat (limited to 'devel/libbonobo')
-rw-r--r--devel/libbonobo/Makefile13
-rw-r--r--devel/libbonobo/distinfo2
-rw-r--r--devel/libbonobo/files/patch-Makefile.in11
-rw-r--r--devel/libbonobo/files/patch-bonobo-activation::bonobo-activation-fork-server.c11
-rw-r--r--devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-init.c18
-rw-r--r--devel/libbonobo/files/patch-configure13
-rw-r--r--devel/libbonobo/files/patch-ltmain.sh51
-rw-r--r--devel/libbonobo/files/patch-server::Makefile.in11
-rw-r--r--devel/libbonobo/files/patch-server::activation-server-main.c11
-rw-r--r--devel/libbonobo/files/patch-utils::bonobo-slay.in21
-rw-r--r--devel/libbonobo/pkg-plist136
11 files changed, 276 insertions, 22 deletions
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index bd6b2098a51c..ca1d5b1681f0 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= libbonobo
-PORTVERSION= 2.2.3
+PORTVERSION= 2.4.0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -18,17 +18,16 @@ COMMENT= A component and compound document system for GNOME2
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
-USE_GNOME= gnomehack bonoboactivation
+GNU_CONFIGURE= yes
+USE_PERL5= yes
+USE_GNOME= gnomehack libxml2 orbit2
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
MAKE_ENV= gnomelocaledir=${PREFIX}/share/locale
-post-patch:
- @${REINPLACE_CMD} -e "/^SUBDIRS/s/tests//" ${WRKSRC}/Makefile.in
+MAN1= bonobo-activation-server.1
.include <bsd.port.mk>
diff --git a/devel/libbonobo/distinfo b/devel/libbonobo/distinfo
index 6f55c910fa4b..6b6d6d2ec391 100644
--- a/devel/libbonobo/distinfo
+++ b/devel/libbonobo/distinfo
@@ -1 +1 @@
-MD5 (gnome2/libbonobo-2.2.3.tar.bz2) = 706e3f722dc5ece02ae27c14984d9810
+MD5 (gnome2/libbonobo-2.4.0.tar.bz2) = 243a4914ae90d08da7cd34ae41e9cac6
diff --git a/devel/libbonobo/files/patch-Makefile.in b/devel/libbonobo/files/patch-Makefile.in
new file mode 100644
index 000000000000..e8a60bd28cd8
--- /dev/null
+++ b/devel/libbonobo/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig Wed May 7 13:42:52 2003
++++ Makefile.in Wed May 7 13:43:30 2003
+@@ -149,7 +149,7 @@
+ SUBDIRS = \
+ idl bonobo-activation bonobo \
+ activation-server monikers \
+- utils samples tests doc po
++ utils samples doc po
+
+
+ libincludedir = $(includedir)/libbonobo-2.0
diff --git a/devel/libbonobo/files/patch-bonobo-activation::bonobo-activation-fork-server.c b/devel/libbonobo/files/patch-bonobo-activation::bonobo-activation-fork-server.c
new file mode 100644
index 000000000000..db8d816a89d2
--- /dev/null
+++ b/devel/libbonobo/files/patch-bonobo-activation::bonobo-activation-fork-server.c
@@ -0,0 +1,11 @@
+--- bonobo-activation/bonobo-activation-fork-server.c.orig Fri Oct 18 06:15:11 2002
++++ bonobo-activation/bonobo-activation-fork-server.c Sat Oct 19 15:35:03 2002
+@@ -364,6 +364,8 @@
+ } else if ((childpid = fork ())) {
+ _exit (0); /* de-zombifier process, just exit */
+ } else {
++ sigprocmask (SIG_SETMASK, &omask, NULL);
++
+ setenv_activation_environment (environment);
+
+ if (od_iorstr != NULL) {
diff --git a/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-init.c b/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-init.c
new file mode 100644
index 000000000000..52cfebcd945e
--- /dev/null
+++ b/devel/libbonobo/files/patch-bonobo-activation_bonobo-activation-init.c
@@ -0,0 +1,18 @@
+--- bonobo-activation/bonobo-activation-init.c.orig Sat Jun 14 02:09:52 2003
++++ bonobo-activation/bonobo-activation-init.c Sat Jun 14 02:10:13 2003
+@@ -34,6 +34,7 @@
+ #include "bonobo-activation-private.h"
+ #include "bonobo-activation-register.h"
+ #include "bonobo-activation-version.h"
++#include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+ #include <fcntl.h>
+@@ -44,7 +45,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <sys/socket.h>
+-#include <sys/types.h>
+ #include <sys/wait.h>
+ #include <unistd.h>
+
diff --git a/devel/libbonobo/files/patch-configure b/devel/libbonobo/files/patch-configure
deleted file mode 100644
index d52c0a8a2fcc..000000000000
--- a/devel/libbonobo/files/patch-configure
+++ /dev/null
@@ -1,13 +0,0 @@
-
-$FreeBSD$
-
---- configure 2002/04/26 08:08:30 1.1
-+++ configure 2002/04/26 08:09:00
-@@ -7015,6 +7015,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/devel/libbonobo/files/patch-ltmain.sh b/devel/libbonobo/files/patch-ltmain.sh
new file mode 100644
index 000000000000..2719aeb6ca5a
--- /dev/null
+++ b/devel/libbonobo/files/patch-ltmain.sh
@@ -0,0 +1,51 @@
+--- ltmain.sh.orig Thu Jun 5 08:09:04 2003
++++ ltmain.sh Sat Jun 14 01:36:34 2003
+@@ -1280,7 +1280,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1290,8 +1290,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -3000,6 +3008,9 @@
+ # problems, so we reset it completely
+ verstring=
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ verstring="0.0"
+ ;;
+@@ -5428,10 +5439,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/libbonobo/files/patch-server::Makefile.in b/devel/libbonobo/files/patch-server::Makefile.in
new file mode 100644
index 000000000000..c821efc8e636
--- /dev/null
+++ b/devel/libbonobo/files/patch-server::Makefile.in
@@ -0,0 +1,11 @@
+--- activation-server/Makefile.in.orig Wed May 7 16:36:09 2003
++++ activation-server/Makefile.in Wed May 7 16:36:51 2003
+@@ -159,7 +159,7 @@
+ -I$(top_builddir) \
+ -I$(top_builddir)/bonobo-activation \
+ -I$(top_srcdir)/bonobo-activation \
+- -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers\" \
++ -DSERVERINFODIR=\"$(prefix)/libdata/bonobo/servers:${X11BASE}/libdata/bonobo/servers:${LOCALBASE}/libdata/bonobo/servers\" \
+ -DSERVER_LOCALEDIR=\""${prefix}/${DATADIRNAME}/locale"\" \
+ $(SERVER_CFLAGS) \
+ -DSERVER_CONFDIR=\"$(sysconfdir)\" \
diff --git a/devel/libbonobo/files/patch-server::activation-server-main.c b/devel/libbonobo/files/patch-server::activation-server-main.c
new file mode 100644
index 000000000000..f1a74a4a370c
--- /dev/null
+++ b/devel/libbonobo/files/patch-server::activation-server-main.c
@@ -0,0 +1,11 @@
+--- activation-server/activation-server-main.c.orig Fri Oct 18 06:15:12 2002
++++ activation-server/activation-server-main.c Sat Nov 9 01:50:36 2002
+@@ -127,7 +127,7 @@
+ g_string_append (gnome_od_source_dir,
+ gnome_dirs[i]);
+ g_string_append (gnome_od_source_dir,
+- "/lib/bonobo/servers:");
++ "/libdata/bonobo/servers:");
+ }
+ g_strfreev (gnome_dirs);
+ g_string_append_c (real_od_source_dir, ':');
diff --git a/devel/libbonobo/files/patch-utils::bonobo-slay.in b/devel/libbonobo/files/patch-utils::bonobo-slay.in
new file mode 100644
index 000000000000..44212a0418a1
--- /dev/null
+++ b/devel/libbonobo/files/patch-utils::bonobo-slay.in
@@ -0,0 +1,21 @@
+--- utils/bonobo-slay.in.orig Mon Mar 11 12:16:43 2002
++++ utils/bonobo-slay.in Tue Apr 2 18:30:30 2002
+@@ -56,15 +56,15 @@
+
+ # get Bonobo files
+ #
+-@bonobo_dirs = ( "@prefix@/lib/bonobo/servers" );
++@bonobo_dirs = ( "@prefix@/libdata/bonobo/servers" );
+ foreach $dir (split(':', $ENV{'BONOBO_ACTIVATION_INFO_PATH'})) {
+ if (-d $dir) {
+ push @bonobo_dirs, $dir;
+ }
+ }
+ foreach $dir (split(':', $ENV{'GNOME2_PATH'})) {
+- if (-d "$dir/lib/bonobo/servers") {
+- push @bonobo_dirs, "$dir/lib/bonobo/servers";
++ if (-d "$dir/libdata/bonobo/servers") {
++ push @bonobo_dirs, "$dir/libdata/bonobo/servers";
+ }
+ }
+
diff --git a/devel/libbonobo/pkg-plist b/devel/libbonobo/pkg-plist
index f965241fed0d..85fe9e44ac05 100644
--- a/devel/libbonobo/pkg-plist
+++ b/devel/libbonobo/pkg-plist
@@ -1,9 +1,24 @@
+bin/activation-client
+bin/bonobo-slay
bin/echo-client-2
+etc/bonobo-activation/bonobo-activation-config.xml
+include/bonobo-activation-2.0/bonobo-activation/Bonobo_Activation_types.h
+include/bonobo-activation-2.0/bonobo-activation/Bonobo_GenericFactory.h
+include/bonobo-activation-2.0/bonobo-activation/Bonobo_Unknown.h
+include/bonobo-activation-2.0/bonobo-activation/bonobo-activation-activate.h
+include/bonobo-activation-2.0/bonobo-activation/bonobo-activation-async.h
+include/bonobo-activation-2.0/bonobo-activation/bonobo-activation-init.h
+include/bonobo-activation-2.0/bonobo-activation/bonobo-activation-register.h
+include/bonobo-activation-2.0/bonobo-activation/bonobo-activation-server-info.h
+include/bonobo-activation-2.0/bonobo-activation/bonobo-activation-shlib.h
+include/bonobo-activation-2.0/bonobo-activation/bonobo-activation-version.h
+include/bonobo-activation-2.0/bonobo-activation/bonobo-activation.h
include/libbonobo-2.0/bonobo/Bonobo.h
include/libbonobo-2.0/bonobo/bonobo-arg.h
include/libbonobo-2.0/bonobo/bonobo-context.h
include/libbonobo-2.0/bonobo/bonobo-event-source.h
include/libbonobo-2.0/bonobo/bonobo-exception.h
+include/libbonobo-2.0/bonobo/bonobo-foreign-object.h
include/libbonobo-2.0/bonobo/bonobo-generic-factory.h
include/libbonobo-2.0/bonobo/bonobo-i18n.h
include/libbonobo-2.0/bonobo/bonobo-item-container.h
@@ -36,10 +51,112 @@ lib/bonobo/monikers/libmoniker_std_2.so
lib/libbonobo-2.a
lib/libbonobo-2.so
lib/libbonobo-2.so.0
+lib/libbonobo-activation.a
+lib/libbonobo-activation.so
+lib/libbonobo-activation.so.4
lib/orbit-2.0/Bonobo_module.so
+libdata/bonobo/servers/Bonobo_CosNaming_NamingContext.server
libdata/bonobo/servers/Bonobo_Moniker_std.server
libdata/bonobo/servers/Bonobo_Sample_Echo.server
+libdata/pkgconfig/bonobo-activation-2.0.pc
libdata/pkgconfig/libbonobo-2.0.pc
+libexec/bonobo-activation-server
+sbin/bonobo-activation-sysconf
+share/doc/bonobo-activation/api-reference.html
+share/doc/bonobo-activation/architecture.html
+share/doc/bonobo-activation/async-activation.html
+share/doc/bonobo-activation/attribute-tag.html
+share/doc/bonobo-activation/bonobo-activation-Debugging.html
+share/doc/bonobo-activation/bonobo-activation-Initialization.html
+share/doc/bonobo-activation/bonobo-activation-Query-and-Activation.html
+share/doc/bonobo-activation/bonobo-activation-Registration.html
+share/doc/bonobo-activation/bonobo-activation-Utilities.html
+share/doc/bonobo-activation/bonobo-activation.devhelp
+share/doc/bonobo-activation/bonobo-activation.png
+share/doc/bonobo-activation/checklist.html
+share/doc/bonobo-activation/configuring.html
+share/doc/bonobo-activation/fdl-section1.html
+share/doc/bonobo-activation/fdl-section10.html
+share/doc/bonobo-activation/fdl-section2.html
+share/doc/bonobo-activation/fdl-section3.html
+share/doc/bonobo-activation/fdl-section4.html
+share/doc/bonobo-activation/fdl-section5.html
+share/doc/bonobo-activation/fdl-section6.html
+share/doc/bonobo-activation/fdl-section7.html
+share/doc/bonobo-activation/fdl-section8.html
+share/doc/bonobo-activation/fdl-section9.html
+share/doc/bonobo-activation/fdl-using.html
+share/doc/bonobo-activation/fdl.html
+share/doc/bonobo-activation/home.png
+share/doc/bonobo-activation/index.html
+share/doc/bonobo-activation/index.sgml
+share/doc/bonobo-activation/left.png
+share/doc/bonobo-activation/migrating.html
+share/doc/bonobo-activation/query-langage.html
+share/doc/bonobo-activation/query-syntax.html
+share/doc/bonobo-activation/right.png
+share/doc/bonobo-activation/server-arch.html
+share/doc/bonobo-activation/server-xml-reference.html
+share/doc/bonobo-activation/tutorial.html
+share/doc/bonobo-activation/up.png
+share/doc/libbonobo/debugging.html
+share/doc/libbonobo/factories.html
+share/doc/libbonobo/general.html
+share/doc/libbonobo/home.png
+share/doc/libbonobo/index.html
+share/doc/libbonobo/index.sgml
+share/doc/libbonobo/left.png
+share/doc/libbonobo/libbonobo-bonobo-arg.html
+share/doc/libbonobo/libbonobo-bonobo-config-database.html
+share/doc/libbonobo/libbonobo-bonobo-context.html
+share/doc/libbonobo/libbonobo-bonobo-event-source.html
+share/doc/libbonobo/libbonobo-bonobo-exception.html
+share/doc/libbonobo/libbonobo-bonobo-generic-factory.html
+share/doc/libbonobo/libbonobo-bonobo-i18n.html
+share/doc/libbonobo/libbonobo-bonobo-item-container.html
+share/doc/libbonobo/libbonobo-bonobo-item-handler.html
+share/doc/libbonobo/libbonobo-bonobo-listener.html
+share/doc/libbonobo/libbonobo-bonobo-main.html
+share/doc/libbonobo/libbonobo-bonobo-moniker-context.html
+share/doc/libbonobo/libbonobo-bonobo-moniker-extender.html
+share/doc/libbonobo/libbonobo-bonobo-moniker-simple.html
+share/doc/libbonobo/libbonobo-bonobo-moniker-util.html
+share/doc/libbonobo/libbonobo-bonobo-moniker.html
+share/doc/libbonobo/libbonobo-bonobo-object.html
+share/doc/libbonobo/libbonobo-bonobo-persist-client.html
+share/doc/libbonobo/libbonobo-bonobo-persist-file.html
+share/doc/libbonobo/libbonobo-bonobo-persist-stream.html
+share/doc/libbonobo/libbonobo-bonobo-persist.html
+share/doc/libbonobo/libbonobo-bonobo-property-bag-client.html
+share/doc/libbonobo/libbonobo-bonobo-property-bag.html
+share/doc/libbonobo/libbonobo-bonobo-running-context.html
+share/doc/libbonobo/libbonobo-bonobo-shlib-factory.html
+share/doc/libbonobo/libbonobo-bonobo-shutdown.html
+share/doc/libbonobo/libbonobo-bonobo-storage-memory.html
+share/doc/libbonobo/libbonobo-bonobo-storage.html
+share/doc/libbonobo/libbonobo-bonobo-stream-client.html
+share/doc/libbonobo/libbonobo-bonobo-stream-memory.html
+share/doc/libbonobo/libbonobo-bonobo-types.html
+share/doc/libbonobo/libbonobo-faq.html
+share/doc/libbonobo/libbonobo.devhelp
+share/doc/libbonobo/misc.html
+share/doc/libbonobo/monikers-overview.html
+share/doc/libbonobo/monikers.html
+share/doc/libbonobo/persist-file.png
+share/doc/libbonobo/persist-storage.png
+share/doc/libbonobo/persist-stream.png
+share/doc/libbonobo/persist.html
+share/doc/libbonobo/persist.png
+share/doc/libbonobo/properties.html
+share/doc/libbonobo/property-bags.html
+share/doc/libbonobo/refcounting.html
+share/doc/libbonobo/right.png
+share/doc/libbonobo/running-context.png
+share/doc/libbonobo/storage.png
+share/doc/libbonobo/stream.png
+share/doc/libbonobo/streams.html
+share/doc/libbonobo/unknown.png
+share/doc/libbonobo/up.png
share/idl/bonobo-2.0/Bonobo.idl
share/idl/bonobo-2.0/Bonobo_Canvas.idl
share/idl/bonobo-2.0/Bonobo_Clipboard.idl
@@ -58,11 +175,17 @@ share/idl/bonobo-2.0/Bonobo_Sample_Echo.idl
share/idl/bonobo-2.0/Bonobo_Storage.idl
share/idl/bonobo-2.0/Bonobo_UI.idl
share/idl/bonobo-2.0/Bonobo_Zoomable.idl
+share/idl/bonobo-activation-2.0/Bonobo_ActivationContext.idl
+share/idl/bonobo-activation-2.0/Bonobo_Activation_types.idl
+share/idl/bonobo-activation-2.0/Bonobo_GenericFactory.idl
+share/idl/bonobo-activation-2.0/Bonobo_ObjectDirectory.idl
+share/idl/bonobo-activation-2.0/Bonobo_Unknown.idl
share/locale/am/LC_MESSAGES/libbonobo-2.0.mo
share/locale/ar/LC_MESSAGES/libbonobo-2.0.mo
share/locale/az/LC_MESSAGES/libbonobo-2.0.mo
share/locale/be/LC_MESSAGES/libbonobo-2.0.mo
share/locale/bg/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/bn/LC_MESSAGES/libbonobo-2.0.mo
share/locale/ca/LC_MESSAGES/libbonobo-2.0.mo
share/locale/cs/LC_MESSAGES/libbonobo-2.0.mo
share/locale/cy/LC_MESSAGES/libbonobo-2.0.mo
@@ -74,13 +197,17 @@ share/locale/es/LC_MESSAGES/libbonobo-2.0.mo
share/locale/fa/LC_MESSAGES/libbonobo-2.0.mo
share/locale/fi/LC_MESSAGES/libbonobo-2.0.mo
share/locale/fr/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/ga/LC_MESSAGES/libbonobo-2.0.mo
share/locale/gl/LC_MESSAGES/libbonobo-2.0.mo
share/locale/he/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/hi/LC_MESSAGES/libbonobo-2.0.mo
share/locale/hu/LC_MESSAGES/libbonobo-2.0.mo
share/locale/id/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/is/LC_MESSAGES/libbonobo-2.0.mo
share/locale/it/LC_MESSAGES/libbonobo-2.0.mo
share/locale/ja/LC_MESSAGES/libbonobo-2.0.mo
share/locale/ko/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/li/LC_MESSAGES/libbonobo-2.0.mo
share/locale/lv/LC_MESSAGES/libbonobo-2.0.mo
share/locale/mk/LC_MESSAGES/libbonobo-2.0.mo
share/locale/ml/LC_MESSAGES/libbonobo-2.0.mo
@@ -104,15 +231,22 @@ share/locale/ta/LC_MESSAGES/libbonobo-2.0.mo
share/locale/tr/LC_MESSAGES/libbonobo-2.0.mo
share/locale/uk/LC_MESSAGES/libbonobo-2.0.mo
share/locale/vi/LC_MESSAGES/libbonobo-2.0.mo
+share/locale/wa/LC_MESSAGES/libbonobo-2.0.mo
share/locale/yi/LC_MESSAGES/libbonobo-2.0.mo
share/locale/zh_CN/LC_MESSAGES/libbonobo-2.0.mo
share/locale/zh_TW/LC_MESSAGES/libbonobo-2.0.mo
+@dirrm share/idl/bonobo-activation-2.0
@dirrm share/idl/bonobo-2.0
+@dirrm share/doc/bonobo-activation
@dirrm share/doc/libbonobo
-@dirrm lib/orbit-2.0
+@dirrm libdata/bonobo/servers
+@dirrm libdata/bonobo
@dirrm lib/bonobo-2.0/samples
@dirrm lib/bonobo-2.0
@dirrm include/libbonobo-2.0/bonobo
@dirrm include/libbonobo-2.0
+@dirrm include/bonobo-activation-2.0/bonobo-activation
+@dirrm include/bonobo-activation-2.0
+@dirrm etc/bonobo-activation
@unexec /bin/rmdir %D/lib/bonobo/monikers 2>/dev/null || /usr/bin/true
@unexec /bin/rmdir %D/lib/bonobo 2>/dev/null || /usr/bin/true