aboutsummaryrefslogtreecommitdiff
path: root/devel/libbrotli
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2016-04-15 23:13:15 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2016-04-15 23:13:15 +0000
commitb3e923b7fc9bacfaa8591dbf162a16620cbad5c9 (patch)
tree5105dec355706ec7939752cea73aa7f4517ffcf7 /devel/libbrotli
parent1990f90c5ecca686a1baacbbef3aa91acfe77bb0 (diff)
downloadports-b3e923b7fc9bacfaa8591dbf162a16620cbad5c9.tar.gz
ports-b3e923b7fc9bacfaa8591dbf162a16620cbad5c9.zip
Notes
Diffstat (limited to 'devel/libbrotli')
-rw-r--r--devel/libbrotli/Makefile5
-rw-r--r--devel/libbrotli/distinfo4
-rw-r--r--devel/libbrotli/files/patch-CVE-2016-162424
3 files changed, 5 insertions, 28 deletions
diff --git a/devel/libbrotli/Makefile b/devel/libbrotli/Makefile
index e8de8fd46c16..e97229ce01c5 100644
--- a/devel/libbrotli/Makefile
+++ b/devel/libbrotli/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libbrotli
PORTVERSION= 1.0
+PORTREVISION= 1
MASTER_SITES= https://github.com/bagder/libbrotli/archive/
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
CATEGORIES= devel archivers
@@ -12,12 +13,12 @@ COMMENT= Library for generic-purpose lossless compression algorithm
LICENSE= MIT
-BROTLI_VERSION= 0.3.0
+BROTLI_VERSION= 3a77ebe
USE_GITHUB= nodefault
GH_ACCOUNT= google:brotli
GH_PROJECT= brotli:brotli
-GH_TAGNAME= v${BROTLI_VERSION}:brotli
+GH_TAGNAME= ${BROTLI_VERSION}:brotli
USES= pkgconfig autoreconf libtool compiler:c++0x
GNU_CONFIGURE= yes
diff --git a/devel/libbrotli/distinfo b/devel/libbrotli/distinfo
index 2f436d27b12d..258cc977f251 100644
--- a/devel/libbrotli/distinfo
+++ b/devel/libbrotli/distinfo
@@ -1,4 +1,4 @@
SHA256 (libbrotli-1.0.tar.gz) = 5b7c02eb87017e7b3886c07eca685db95fa21f9c8afbb442469370c251a54dc1
SIZE (libbrotli-1.0.tar.gz) = 3116
-SHA256 (google-brotli-v0.3.0_GH0.tar.gz) = 5d49eb1a6dd19304dd683c293abf66c8a419728f4c6d0f390fa7deb2a39eaae2
-SIZE (google-brotli-v0.3.0_GH0.tar.gz) = 8035159
+SHA256 (google-brotli-3a77ebe_GH0.tar.gz) = 109705dcb9399d4942bc7f91d56331af34a311d9b1deb63cd9616e063241d191
+SIZE (google-brotli-3a77ebe_GH0.tar.gz) = 8061078
diff --git a/devel/libbrotli/files/patch-CVE-2016-1624 b/devel/libbrotli/files/patch-CVE-2016-1624
deleted file mode 100644
index d0d0e5fbff0f..000000000000
--- a/devel/libbrotli/files/patch-CVE-2016-1624
+++ /dev/null
@@ -1,24 +0,0 @@
-From 37a320dd81db8d546cd24a45b4c61d87b45dcade Mon Sep 17 00:00:00 2001
-From: eustas <eustas.ru@gmail.com>
-Date: Thu, 4 Feb 2016 15:35:44 +0100
-Subject: [PATCH] Fix possible pointer underflow
-
----
- dec/decode.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/dec/decode.c b/dec/decode.c
-index 920959c..892a254 100644
---- brotli/dec/decode.c
-+++ brotli/dec/decode.c
-@@ -1714,6 +1714,10 @@ static BROTLI_INLINE BrotliResult ProcessCommandsInternal(int safe,
- } else {
- const uint8_t *ringbuffer_end_minus_copy_length =
- s->ringbuffer_end - i;
-+ /* Check for possible underflow and clamp the pointer to 0. */
-+ if (PREDICT_FALSE(s->ringbuffer_end < (const uint8_t*)0 + i)) {
-+ ringbuffer_end_minus_copy_length = 0;
-+ }
- uint8_t* copy_src = &s->ringbuffer[
- (pos - s->distance_code) & s->ringbuffer_mask];
- uint8_t* copy_dst = &s->ringbuffer[pos];