aboutsummaryrefslogtreecommitdiff
path: root/devel/libcache
diff options
context:
space:
mode:
authorR. Imura <imura@FreeBSD.org>2000-02-13 02:01:01 +0000
committerR. Imura <imura@FreeBSD.org>2000-02-13 02:01:01 +0000
commit53d982afed677fcf50a84afac8839e6214ea970f (patch)
tree024972eb2ee34f4c42dba086f91142f355f4112e /devel/libcache
parenta29e53c135036bb807fd3b1b43ebedf8a2269fc9 (diff)
downloadports-53d982afed677fcf50a84afac8839e6214ea970f.tar.gz
ports-53d982afed677fcf50a84afac8839e6214ea970f.zip
Notes
Diffstat (limited to 'devel/libcache')
-rw-r--r--devel/libcache/Makefile26
-rw-r--r--devel/libcache/distinfo1
-rw-r--r--devel/libcache/files/patch-aa11
-rw-r--r--devel/libcache/pkg-comment1
-rw-r--r--devel/libcache/pkg-descr10
-rw-r--r--devel/libcache/pkg-plist4
6 files changed, 53 insertions, 0 deletions
diff --git a/devel/libcache/Makefile b/devel/libcache/Makefile
new file mode 100644
index 000000000000..f91948195a6c
--- /dev/null
+++ b/devel/libcache/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libcache
+# Version required: 1.0.0
+# Date created: 04 Feb 2000
+# Whom: Will Andrews <andrews@technologist.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= libcache-1.0.0
+CATEGORIES= devel
+MASTER_SITES= http://www.afro-productions.com/
+
+MAINTAINER= andrews@technologist.com
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--enable-shared
+WRKSRC= ${WRKDIR}/libcache
+VERSION= 0
+PLIST_SUB+= VERSION="${VERSION}"
+MAKE_ENV+= PCFLAGS="${CFLAGS}"
+
+do-install:
+ @${INSTALL_DATA} ${WRKSRC}/libcache.so ${PREFIX}/lib/libcache.so.${VERSION}
+ @${LN} -sf ${PREFIX}/lib/libcache.so.${VERSION} ${PREFIX}/lib/libcache.so
+
+.include <bsd.port.mk>
diff --git a/devel/libcache/distinfo b/devel/libcache/distinfo
new file mode 100644
index 000000000000..faf490dfb083
--- /dev/null
+++ b/devel/libcache/distinfo
@@ -0,0 +1 @@
+MD5 (libcache-1.0.0.tar.gz) = f4aee79c2c4d1d25ac7f3465df13d4a2
diff --git a/devel/libcache/files/patch-aa b/devel/libcache/files/patch-aa
new file mode 100644
index 000000000000..3612e7034d92
--- /dev/null
+++ b/devel/libcache/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/Makefile.in Wed Dec 22 12:00:17 1999
++++ src/Makefile.in.new Fri Feb 4 15:13:19 2000
+@@ -6,7 +6,7 @@
+ OBJS=parse.o access.o
+
+
+-CFLAGS=${DEBUG} ${DEFINES} -Wall -O3 -I. -I../include -c
++CFLAGS=${PCFLAGS} ${DEBUG} ${DEFINES} -Wall -O3 -I. -I../include -c
+ LIBEXEC=@LIBBIN@
+
+ all: ${OBJS}
diff --git a/devel/libcache/pkg-comment b/devel/libcache/pkg-comment
new file mode 100644
index 000000000000..b36e7e8fc2f5
--- /dev/null
+++ b/devel/libcache/pkg-comment
@@ -0,0 +1 @@
+C library that allows a programmer to parse sentences easier
diff --git a/devel/libcache/pkg-descr b/devel/libcache/pkg-descr
new file mode 100644
index 000000000000..8b739bdf53f2
--- /dev/null
+++ b/devel/libcache/pkg-descr
@@ -0,0 +1,10 @@
+[ paraphrased from the README ]
+libcache is a high-level C library that allows a programmer
+to use the standard string manipulation functions (like
+strtok() and sscanf()) to parse and access deliminated sentences
+easier.
+
+WWW: http://www.afro-productions.com/libs.html
+Author: Matt Miller <mmiller@hick.org>
+
+--Will <andrews@technologist.com>
diff --git a/devel/libcache/pkg-plist b/devel/libcache/pkg-plist
new file mode 100644
index 000000000000..4d1e538dfc7c
--- /dev/null
+++ b/devel/libcache/pkg-plist
@@ -0,0 +1,4 @@
+lib/libcache.so.%%VERSION%%
+lib/libcache.so
+@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldcomfing -m %B
+@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R