aboutsummaryrefslogtreecommitdiff
path: root/devel/libcapsinetwork
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-10-24 20:43:48 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-10-24 20:43:48 +0000
commitae93e71e7e638b1f18ed7db29ba29588888e16aa (patch)
tree6511913f6f59f0cc309f6b8a33198f4fba853d6c /devel/libcapsinetwork
parent2c9cae524efd8077987cd64b01d969cdd60578e1 (diff)
downloadports-ae93e71e7e638b1f18ed7db29ba29588888e16aa.tar.gz
ports-ae93e71e7e638b1f18ed7db29ba29588888e16aa.zip
Notes
Diffstat (limited to 'devel/libcapsinetwork')
-rw-r--r--devel/libcapsinetwork/Makefile2
-rw-r--r--devel/libcapsinetwork/distinfo2
-rw-r--r--devel/libcapsinetwork/files/patch-listener.cc19
-rw-r--r--devel/libcapsinetwork/files/patch-listener.h12
-rw-r--r--devel/libcapsinetwork/files/patch-listenport.cc20
-rw-r--r--devel/libcapsinetwork/pkg-plist1
6 files changed, 49 insertions, 7 deletions
diff --git a/devel/libcapsinetwork/Makefile b/devel/libcapsinetwork/Makefile
index 7b1ab37abcda..e5b4855efe0d 100644
--- a/devel/libcapsinetwork/Makefile
+++ b/devel/libcapsinetwork/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libcapsinetwork
-PORTVERSION= 0.1.1
+PORTVERSION= 0.2.0
CATEGORIES= devel net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/libcapsinetwork/distinfo b/devel/libcapsinetwork/distinfo
index a3132e8b78e8..2d8321314dbb 100644
--- a/devel/libcapsinetwork/distinfo
+++ b/devel/libcapsinetwork/distinfo
@@ -1 +1 @@
-MD5 (libcapsinetwork-0.1.1.tar.gz) = 828a0cb9ceb7c8d6ad3d29371942c4c6
+MD5 (libcapsinetwork-0.2.0.tar.gz) = 43d5515aac68401cf383b45a0bb8162c
diff --git a/devel/libcapsinetwork/files/patch-listener.cc b/devel/libcapsinetwork/files/patch-listener.cc
index e29d42ae5f19..b55316a974b0 100644
--- a/devel/libcapsinetwork/files/patch-listener.cc
+++ b/devel/libcapsinetwork/files/patch-listener.cc
@@ -1,12 +1,21 @@
$FreeBSD$
---- listener.cc.orig Sat Jul 13 00:06:34 2002
-+++ listener.cc Sat Jul 13 00:06:36 2002
-@@ -14,6 +14,7 @@
+--- listener.cc.orig Thu Oct 24 14:26:02 2002
++++ listener.cc Thu Oct 24 14:34:19 2002
+@@ -14,11 +14,13 @@
// the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
// Boston, MA 02111-1307, USA.
+-//#include <netinet/in.h>
+#include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
++#include <sys/socket.h>
++#include <sys/time.h>
++
++#include <netinet/in.h>
#include <arpa/inet.h>
+ #include <netdb.h>
+-#include <sys/socket.h>
+-#include <sys/types.h>
+ #include <unistd.h>
+
+ #include "listener.h"
diff --git a/devel/libcapsinetwork/files/patch-listener.h b/devel/libcapsinetwork/files/patch-listener.h
new file mode 100644
index 000000000000..e768b044a6d2
--- /dev/null
+++ b/devel/libcapsinetwork/files/patch-listener.h
@@ -0,0 +1,12 @@
+$FreeBSD$
+
+--- listener.h.orig Thu Oct 24 14:37:41 2002
++++ listener.h Thu Oct 24 14:37:55 2002
+@@ -19,6 +19,7 @@
+
+ #include <string>
+ #include <vector>
++#include <sys/types.h>
+
+ class ListenPort;
+ class Socket;
diff --git a/devel/libcapsinetwork/files/patch-listenport.cc b/devel/libcapsinetwork/files/patch-listenport.cc
new file mode 100644
index 000000000000..68630eab8f3d
--- /dev/null
+++ b/devel/libcapsinetwork/files/patch-listenport.cc
@@ -0,0 +1,20 @@
+$FreeBSD$
+
+--- listenport.cc.orig Thu Oct 24 14:36:09 2002
++++ listenport.cc Thu Oct 24 14:36:27 2002
+@@ -15,12 +15,12 @@
+ // Boston, MA 02111-1307, USA.
+
+
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <arpa/inet.h>
+ #include <fcntl.h>
+ #include <netdb.h>
+-//#include <netinet/in.h>
+-#include <sys/socket.h>
+-#include <sys/types.h>
++#include <netinet/in.h>
+ #include <unistd.h>
+
+ #include "listenport.h"
diff --git a/devel/libcapsinetwork/pkg-plist b/devel/libcapsinetwork/pkg-plist
index 8d37c8b62c45..efc4a8d6db0f 100644
--- a/devel/libcapsinetwork/pkg-plist
+++ b/devel/libcapsinetwork/pkg-plist
@@ -1,4 +1,5 @@
include/libcapsinetwork/listener.h
+include/libcapsinetwork/listenport.h
include/libcapsinetwork/socket.h
lib/libcapsinetwork.a
lib/libcapsinetwork.so