aboutsummaryrefslogtreecommitdiff
path: root/devel/libcapsinetwork
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-20 21:27:18 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-20 21:27:18 +0000
commite48f944fc490329735137b448abcd4a7726387fa (patch)
tree5b2a3a199e3e2e934c2af2445be7beba7a0c9404 /devel/libcapsinetwork
parent6cca2e1afcd61108510e5966c08281662b1446bf (diff)
Notes
Diffstat (limited to 'devel/libcapsinetwork')
-rw-r--r--devel/libcapsinetwork/Makefile22
-rw-r--r--devel/libcapsinetwork/distinfo1
-rw-r--r--devel/libcapsinetwork/pkg-comment1
-rw-r--r--devel/libcapsinetwork/pkg-descr9
-rw-r--r--devel/libcapsinetwork/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/libcapsinetwork/Makefile b/devel/libcapsinetwork/Makefile
new file mode 100644
index 000000000000..10f9d17956ec
--- /dev/null
+++ b/devel/libcapsinetwork/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: libcapsinetwork
+# Date created: 11 August 2001
+# Whom: petef
+#
+# $FreeBSD$
+#
+
+PORTNAME= libcapsinetwork
+PORTVERSION= 0.0.13
+CATEGORIES= devel net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= petef@FreeBSD.org
+
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e 's!CC!CXX!g; s!CXX=!CXX?=!; s!CFLAGS=!CFLAGS+=!; \
+ s!/usr/local!${PREFIX}!' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/libcapsinetwork/distinfo b/devel/libcapsinetwork/distinfo
new file mode 100644
index 000000000000..bc45ad4f8b2c
--- /dev/null
+++ b/devel/libcapsinetwork/distinfo
@@ -0,0 +1 @@
+MD5 (libcapsinetwork-0.0.13.tar.gz) = 9180719a119d79fe5f6b0deefa0ac8da
diff --git a/devel/libcapsinetwork/pkg-comment b/devel/libcapsinetwork/pkg-comment
new file mode 100644
index 000000000000..b36e56d5042b
--- /dev/null
+++ b/devel/libcapsinetwork/pkg-comment
@@ -0,0 +1 @@
+Network library aimed at easy development of C++ server daemons
diff --git a/devel/libcapsinetwork/pkg-descr b/devel/libcapsinetwork/pkg-descr
new file mode 100644
index 000000000000..8e212b425945
--- /dev/null
+++ b/devel/libcapsinetwork/pkg-descr
@@ -0,0 +1,9 @@
+libcapsinetwork is a network library for C++ server daemons aimed
+at easy development of server daemons. Implementing the library is
+as easy as adding a few lines to your code and writing one function
+that handles input events.
+
+WWW: http://sourceforge.net/projects/libcapsinetwork/
+
+- Pete
+petef@FreeBSD.org
diff --git a/devel/libcapsinetwork/pkg-plist b/devel/libcapsinetwork/pkg-plist
new file mode 100644
index 000000000000..57b47d69b947
--- /dev/null
+++ b/devel/libcapsinetwork/pkg-plist
@@ -0,0 +1,7 @@
+include/libcapsi_network/listener.h
+include/libcapsi_network/server.h
+include/libcapsi_network/socket.h
+lib/libcapsi_network.so
+lib/libcapsi_network.so.0
+lib/libcapsi_network.so.0.0.13
+@dirrm include/libcapsi_network