aboutsummaryrefslogtreecommitdiff
path: root/devel/libccid/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2006-04-07 19:05:24 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2006-04-07 19:05:24 +0000
commit7ce363f20e24b9dc0f38a65e1dfe96b956d2a3f8 (patch)
tree3bcfe0053b9f367fd84ac15f0b846f43b0d0b904 /devel/libccid/Makefile
parent1a2d65354865213bd044cf9dc629f004ae4ea777 (diff)
Notes
Diffstat (limited to 'devel/libccid/Makefile')
-rw-r--r--devel/libccid/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/devel/libccid/Makefile b/devel/libccid/Makefile
index bdd8360f1eb3..b51d5bbc73b8 100644
--- a/devel/libccid/Makefile
+++ b/devel/libccid/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
PORTNAME= ccid
-PORTVERSION= 0.9.4
+PORTVERSION= 1.0.0
CATEGORIES= devel
-MASTER_SITES= http://alioth.debian.org/download.php/1291/
+MASTER_SITES= http://alioth.debian.org/download.php/1474/
MAINTAINER= arved@FreeBSD.org
COMMENT= Generic USB CCID (Chip/Smart Card Interface Devices) driver
@@ -15,18 +15,12 @@ COMMENT= Generic USB CCID (Chip/Smart Card Interface Devices) driver
LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb \
pcsclite.1:${PORTSDIR}/devel/pcsc-lite
-USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-libusb=${LOCALBASE} \
- --enable-usbdropdir=${LOCALBASE}/lib/pcsc/drivers \
+CONFIGURE_ARGS= --enable-usbdropdir=${LOCALBASE}/lib/pcsc/drivers \
--enable-ccidtwindir=${LOCALBASE}/lib/pcsc/drivers/serial \
- --enable-pcsclite=yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}"
-
-post-patch:
-# ${REINPLACE_CMD} -e "s,-lpcsclite,-lpcsclite ${PTHREAD_LIBS}," \
-# ${WRKSRC}/examples/Makefile.in
- ${REINPLACE_CMD} -e "s,LDLIBS,LIBS,g" ${WRKSRC}/configure
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS}" \
+ LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
+ LIBUSB_LIBS="-L${LOCALBASE}/lib -lusb"
.include <bsd.port.mk>