aboutsummaryrefslogtreecommitdiff
path: root/devel/libccid
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2006-09-20 20:05:58 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2006-09-20 20:05:58 +0000
commitbf07f531495102b433583b776fab13b4bb444241 (patch)
treea2b2ea1d3146cb28935f97a21d225b804902dca7 /devel/libccid
parent8d59eedde92d8f281e7361c0d1045f56822d9911 (diff)
downloadports-bf07f531495102b433583b776fab13b4bb444241.tar.gz
ports-bf07f531495102b433583b776fab13b4bb444241.zip
Notes
Diffstat (limited to 'devel/libccid')
-rw-r--r--devel/libccid/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/devel/libccid/Makefile b/devel/libccid/Makefile
index 4406643d2374..e522dbdba0b9 100644
--- a/devel/libccid/Makefile
+++ b/devel/libccid/Makefile
@@ -6,6 +6,7 @@
PORTNAME= ccid
PORTVERSION= 1.1.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://alioth.debian.org/download.php/1740/
@@ -16,6 +17,7 @@ LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb \
pcsclite.1:${PORTSDIR}/devel/pcsc-lite
GNU_CONFIGURE= yes
+USE_PERL5_BUILD=yes
CONFIGURE_ARGS= --enable-usbdropdir=${LOCALBASE}/lib/pcsc/drivers \
--enable-ccidtwindir=${LOCALBASE}/lib/pcsc/drivers/serial \
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
@@ -25,4 +27,9 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
PLIST_SUB= VER=${PORTVERSION}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,use warnings;,," ${WRKSRC}/src/create_Info_plist.pl
+
+.include <bsd.port.post.mk>