aboutsummaryrefslogtreecommitdiff
path: root/devel/libcfg
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-02-24 15:56:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-02-24 15:56:27 +0000
commit4017c46b09d6076c24cfe43be2c081d3500f0fe4 (patch)
tree35b30a12a739ee61bd5c19734b292b14bbad2b6e /devel/libcfg
parent891839efe7d022b9f5d595faaf778aa55e137054 (diff)
downloadports-4017c46b09d6076c24cfe43be2c081d3500f0fe4.tar.gz
ports-4017c46b09d6076c24cfe43be2c081d3500f0fe4.zip
Notes
Diffstat (limited to 'devel/libcfg')
-rw-r--r--devel/libcfg/Makefile44
-rw-r--r--devel/libcfg/pkg-plist7
2 files changed, 18 insertions, 33 deletions
diff --git a/devel/libcfg/Makefile b/devel/libcfg/Makefile
index bd0cf4445a13..5003285fe02e 100644
--- a/devel/libcfg/Makefile
+++ b/devel/libcfg/Makefile
@@ -12,53 +12,31 @@ MAINTAINER= rodrigo@FreeBSD.org
COMMENT= Library for command line and configuration file parsing
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+USES= gmake
USE_AUTOTOOLS= autoconf
GNU_CONFIGURE= yes
-USE_GMAKE= yes
USE_LDCONFIG= yes
-INSTALL_TARGET= install-strip
-
-.if !defined(NO_INSTALL_MANPAGES)
-MAN3= cfg_add_property.3 cfg_context.3 cfg_option.3 cfg_parse.3 \
- cfg_print_error.3 cfg_set_context_flag.3 libcfg+.3
-MANCOMPRESSED= yes
-INSTALL_TARGET+= install-man
-.endif
+INSTALL_TARGET= install-strip install-man
PORTDOCS= *
OPTIONS_DEFINE= EXAMPLES DOCS
+OPTIONS_SUB= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXAMPLES}
-PLIST_SUB+= EXAMPLES=""
-.else
-PLIST_SUB+= EXAMPLES="@comment "
-.endif
-
-.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
-CFLAGS+= -fPIC
-.endif
+CFLAGS_amd64= -fPIC
+CFLAGS_ia64= -fPIC
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/doc/examples/example.* ${EXAMPLESDIR}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/examples/example.* ${STAGEDIR}${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/html
.for FILE in AUTHORS README TODO
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
.endfor
- @${MKDIR} ${DOCSDIR}/html
- @for FILE in ${WRKSRC}/doc/html/*; do \
- ${INSTALL_DATA} $${FILE} ${DOCSDIR}/html; \
+ for FILE in ${WRKSRC}/doc/html/*; do \
+ ${INSTALL_DATA} $${FILE} ${STAGEDIR}${DOCSDIR}/html; \
done
-.endif
.include <bsd.port.mk>
diff --git a/devel/libcfg/pkg-plist b/devel/libcfg/pkg-plist
index 009a71307809..715443c0a78d 100644
--- a/devel/libcfg/pkg-plist
+++ b/devel/libcfg/pkg-plist
@@ -5,6 +5,13 @@ include/cfg.h
include/cfg+.h
include/platon/cfg.h
include/platon/cfg+.h
+man/man3/cfg_add_property.3.gz
+man/man3/cfg_context.3.gz
+man/man3/cfg_option.3.gz
+man/man3/cfg_parse.3.gz
+man/man3/cfg_print_error.3.gz
+man/man3/cfg_set_context_flag.3.gz
+man/man3/libcfg+.3.gz
@dirrm include/platon
%%EXAMPLES%%%%EXAMPLESDIR%%/example.c
%%EXAMPLES%%%%EXAMPLESDIR%%/example.cfg