aboutsummaryrefslogtreecommitdiff
path: root/devel/libcfg
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-04-30 13:02:27 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-04-30 13:02:27 +0000
commit9179ba7133c1c6b37b66c21cdbdae051946ae8e9 (patch)
treeca43834050da09a59ee380a854dbc6a04605fb61 /devel/libcfg
parent6c67af15a762b791a2b0113095d9d788fee1a65b (diff)
downloadports-9179ba7133c1c6b37b66c21cdbdae051946ae8e9.tar.gz
ports-9179ba7133c1c6b37b66c21cdbdae051946ae8e9.zip
Notes
Diffstat (limited to 'devel/libcfg')
-rw-r--r--devel/libcfg/Makefile66
-rw-r--r--devel/libcfg/distinfo3
-rw-r--r--devel/libcfg/files/patch-Rules.make.in19
-rw-r--r--devel/libcfg/files/patch-configure.in14
-rw-r--r--devel/libcfg/pkg-descr8
-rw-r--r--devel/libcfg/pkg-plist11
6 files changed, 121 insertions, 0 deletions
diff --git a/devel/libcfg/Makefile b/devel/libcfg/Makefile
new file mode 100644
index 000000000000..c1204a671b5a
--- /dev/null
+++ b/devel/libcfg/Makefile
@@ -0,0 +1,66 @@
+# ports collection makefile for: libcfg
+# Date created: 30 April 2007
+# Whom: Martin Matuska <mm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libcfg
+PORTVERSION= 0.6.2
+CATEGORIES= devel
+MASTER_SITES= http://platon.sk/upload/_projects/00003/
+DISTNAME= ${PORTNAME}+-${DISTVERSION}
+
+MAINTAINER= mm@FreeBSD.org
+COMMENT= Library for command line and configuration file parsing
+
+USE_AUTOTOOLS= autoconf:259
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+INSTALL_TARGET= install-strip
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN3= cfg_add_property.3 cfg_context.3 cfg_option.3 cfg_parse.3 \
+ cfg_print_error.3 cfg_set_context_flag.3 libcfg+.3
+MANCOMPRESSED= yes
+INSTALL_TARGET+= install-man
+.endif
+
+PORTDOCS= *
+
+OPTIONS= EXAMPLES "Install examples" off \
+ HTMLDOCS "Install html documentation" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_EXAMPLES)
+PLIST_SUB+= EXAMPLES=""
+.else
+PLIST_SUB+= EXAMPLES="@comment "
+.endif
+
+.if ${ARCH} == "amd64" || ${ARCH} == "ia64"
+CFLAGS+= -fPIC
+.endif
+
+post-install:
+.if defined(WITH_EXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/doc/examples/example.* ${EXAMPLESDIR}
+.endif
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in AUTHORS COPYING README TODO
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+.if defined(WITH_HTMLDOCS)
+ @${MKDIR} ${DOCSDIR}/html
+ @for FILE in ${WRKSRC}/doc/html/*; do \
+ ${INSTALL_DATA} $${FILE} ${DOCSDIR}/html; \
+ done
+.endif
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libcfg/distinfo b/devel/libcfg/distinfo
new file mode 100644
index 000000000000..edb5a80cce3e
--- /dev/null
+++ b/devel/libcfg/distinfo
@@ -0,0 +1,3 @@
+MD5 (libcfg+-0.6.2.tar.gz) = e117a2d054c5f5831fdb5ed27c26d767
+SHA256 (libcfg+-0.6.2.tar.gz) = 8f7984dc7e457c738c6f1ab778900d61183156d18a6c67f929376d9dfeac278c
+SIZE (libcfg+-0.6.2.tar.gz) = 169482
diff --git a/devel/libcfg/files/patch-Rules.make.in b/devel/libcfg/files/patch-Rules.make.in
new file mode 100644
index 000000000000..dafb67eb5ed9
--- /dev/null
+++ b/devel/libcfg/files/patch-Rules.make.in
@@ -0,0 +1,19 @@
+--- Rules.make.in.orig Mon Apr 30 11:56:50 2007
++++ Rules.make.in Mon Apr 30 11:57:50 2007
+@@ -15,6 +15,7 @@
+
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
++SHLIB_MAJOR = @SHLIB_MAJOR@
+
+ CVSTAG = $(PACKAGE)-$(subst .,_,$(VERSION))
+
+@@ -25,7 +26,7 @@
+
+ LIBSTATIC = $(PACKAGE).a
+ LIBDYNAMIC = $(PACKAGE).so
+-LIBDYNAMICV = $(PACKAGE).so.$(VERSION)
++LIBDYNAMICV = $(PACKAGE).so.$(SHLIB_MAJOR)
+
+ install_LIB = $(LIBSTATIC) $(LIBDYNAMICV)
+ SCRIPTS =
diff --git a/devel/libcfg/files/patch-configure.in b/devel/libcfg/files/patch-configure.in
new file mode 100644
index 000000000000..91bb21a4ac79
--- /dev/null
+++ b/devel/libcfg/files/patch-configure.in
@@ -0,0 +1,14 @@
+--- configure.in.orig Tue Feb 17 17:37:47 2004
++++ configure.in Mon Apr 30 12:04:01 2007
+@@ -63,8 +63,11 @@
+ prefix="`cd $prefix && pwd`"
+ fi
+
++SHLIB_MAJOR="0"
++
+ AC_SUBST(PACKAGE)
+ AC_SUBST(VERSION)
++AC_SUBST(SHLIB_MAJOR)
+ AC_SUBST(DATE)
+ AC_SUBST(DATE_HUMAN)
+ AC_SUBST(MANVOLNUM)
diff --git a/devel/libcfg/pkg-descr b/devel/libcfg/pkg-descr
new file mode 100644
index 000000000000..2cebf708ca2b
--- /dev/null
+++ b/devel/libcfg/pkg-descr
@@ -0,0 +1,8 @@
+libcfg+ is a C library that features multi- command line and configuration
+file parsing. It is possible to set up various special properties such as
+quoting characters, deliminator strings, file comment prefixes, multi-line
+postfixes, and more. It supports many data types such as booleans, integers,
+decimal numbers, strings with many additional data type flags (such as
+multiple values for a single option).
+
+WWW: http://platon.sk/projects/libcfg+
diff --git a/devel/libcfg/pkg-plist b/devel/libcfg/pkg-plist
new file mode 100644
index 000000000000..009a71307809
--- /dev/null
+++ b/devel/libcfg/pkg-plist
@@ -0,0 +1,11 @@
+lib/libcfg+.a
+lib/libcfg+.so.0
+lib/libcfg+.so
+include/cfg.h
+include/cfg+.h
+include/platon/cfg.h
+include/platon/cfg+.h
+@dirrm include/platon
+%%EXAMPLES%%%%EXAMPLESDIR%%/example.c
+%%EXAMPLES%%%%EXAMPLESDIR%%/example.cfg
+%%EXAMPLES%%@dirrm %%EXAMPLESDIR%%