aboutsummaryrefslogtreecommitdiff
path: root/devel/libcfu
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2013-02-22 17:26:02 +0000
committerChris Rees <crees@FreeBSD.org>2013-02-22 17:26:02 +0000
commitcd953da87373f2af58c9ec086500763e8be0f300 (patch)
tree2a5b217322863ae3ddbb9a95335fc27c73662335 /devel/libcfu
parente4a869dcb18429e32bcf024acdda305f57365628 (diff)
downloadports-cd953da87373f2af58c9ec086500763e8be0f300.tar.gz
ports-cd953da87373f2af58c9ec086500763e8be0f300.zip
Notes
Diffstat (limited to 'devel/libcfu')
-rw-r--r--devel/libcfu/Makefile16
-rw-r--r--devel/libcfu/distinfo2
-rw-r--r--devel/libcfu/files/patch-examples__hash_usage.c49
-rw-r--r--devel/libcfu/files/patch-examples__large_hash.c31
-rw-r--r--devel/libcfu/files/patch-examples__strings.c29
-rw-r--r--devel/libcfu/pkg-descr6
-rw-r--r--devel/libcfu/pkg-plist11
7 files changed, 144 insertions, 0 deletions
diff --git a/devel/libcfu/Makefile b/devel/libcfu/Makefile
new file mode 100644
index 000000000000..66eb63b5901b
--- /dev/null
+++ b/devel/libcfu/Makefile
@@ -0,0 +1,16 @@
+# $FreeBSD$
+
+PORTNAME= libcfu
+PORTVERSION= 0.03
+CATEGORIES= devel
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}/
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Simple library of tools for developing multithreaded software
+
+LICENSE= BSD
+
+GNU_CONFIGURE= yes
+INFO= ${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/libcfu/distinfo b/devel/libcfu/distinfo
new file mode 100644
index 000000000000..b4f81dd4d370
--- /dev/null
+++ b/devel/libcfu/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libcfu-0.03.tar.gz) = 0581559917edaba3e6a0df9115658f6490ea9f4bb88334eb2bfed26181150e51
+SIZE (libcfu-0.03.tar.gz) = 193634
diff --git a/devel/libcfu/files/patch-examples__hash_usage.c b/devel/libcfu/files/patch-examples__hash_usage.c
new file mode 100644
index 000000000000..e9b14157d13b
--- /dev/null
+++ b/devel/libcfu/files/patch-examples__hash_usage.c
@@ -0,0 +1,49 @@
+--- ./examples/hash_usage.c.orig 2013-02-22 17:00:53.679654885 +0000
++++ ./examples/hash_usage.c 2013-02-22 17:02:43.078657742 +0000
+@@ -36,8 +36,8 @@
+ cfuhash_set_flag(hash, CFUHASH_FROZEN_UNTIL_GROWS);
+
+ for (i = 0; i < 32; i++) {
+- sprintf(list[i][0], "test_var%d", i);
+- sprintf(list[i][1], "value%d", i);
++ sprintf(list[i][0], "test_var%zd", i);
++ sprintf(list[i][1], "value%zd", i);
+ }
+
+ cfuhash_put(hash, "var1", "value1");
+@@ -58,7 +58,7 @@
+ printf("got var2='%s'\n", val);
+ printf("var4 %s\n", cfuhash_exists(hash, "var4") ? "exists" : "does NOT exist!!!");
+
+- printf("%d entries, %d buckets used out of %d\n", cfuhash_num_entries(hash), cfuhash_num_buckets_used(hash), cfuhash_num_buckets(hash));
++ printf("%zd entries, %zd buckets used out of %zd\n", cfuhash_num_entries(hash), cfuhash_num_buckets_used(hash), cfuhash_num_buckets(hash));
+
+ cfuhash_pretty_print(hash, stdout);
+
+@@ -69,7 +69,7 @@
+ size_t num_buckets = cfuhash_num_buckets(hash);
+ size_t num_entries = cfuhash_num_entries(hash);
+ cfuhash_put(hash, list[i][0], list[i][1]);
+- printf("%d entries, %d buckets used out of %d (%.2f)\n", num_entries, used, num_buckets, (float)num_entries/(float)num_buckets);
++ printf("%zd entries, %zd buckets used out of %zd (%.2f)\n", num_entries, used, num_buckets, (float)num_entries/(float)num_buckets);
+
+ }
+
+@@ -82,7 +82,7 @@
+
+ keys = (char **)cfuhash_keys_data(hash, &key_count, &key_sizes, 0);
+
+- printf("\n\nkeys (%u):\n", key_count);
++ printf("\n\nkeys (%zu):\n", key_count);
+ for (i = 0; i < key_count; i++) {
+ printf("\t%s\n", keys[i]);
+ free(keys[i]);
+@@ -92,7 +92,7 @@
+ }
+
+ cfuhash_clear(hash);
+- printf("%d entries, %d buckets used out of %d\n", cfuhash_num_entries(hash), cfuhash_num_buckets_used(hash), cfuhash_num_buckets(hash));
++ printf("%zd entries, %zd buckets used out of %zd\n", cfuhash_num_entries(hash), cfuhash_num_buckets_used(hash), cfuhash_num_buckets(hash));
+
+ cfuhash_destroy(hash);
+
diff --git a/devel/libcfu/files/patch-examples__large_hash.c b/devel/libcfu/files/patch-examples__large_hash.c
new file mode 100644
index 000000000000..0030cef20558
--- /dev/null
+++ b/devel/libcfu/files/patch-examples__large_hash.c
@@ -0,0 +1,31 @@
+--- ./examples/large_hash.c.orig 2013-02-22 17:03:12.957659394 +0000
++++ ./examples/large_hash.c 2013-02-22 17:03:58.328654728 +0000
+@@ -113,8 +113,8 @@
+
+ cfutime_begin(time);
+ for (i = 0; i < num_tests; i++) {
+- sprintf(key, "%u", 15000000 - i);
+- sprintf(value, "value%d", i);
++ sprintf(key, "%zu", 15000000 - i);
++ sprintf(value, "value%zd", i);
+ cfuhash_put(hash, key, dup_str(value));
+ }
+ cfutime_end(time);
+@@ -123,7 +123,7 @@
+ used = cfuhash_num_buckets_used(hash);
+ num_buckets = cfuhash_num_buckets(hash);
+ num_entries = cfuhash_num_entries(hash);
+- printf("%d entries, %d/%d buckets (%.2f%%), %.2f%% threshold check\n", num_entries, used, num_buckets, 100.0 * (float)used/(float)num_buckets, 100.0 * (float)num_entries/(float)num_buckets);
++ printf("%zd entries, %zd/%zd buckets (%.2f%%), %.2f%% threshold check\n", num_entries, used, num_buckets, 100.0 * (float)used/(float)num_buckets, 100.0 * (float)num_entries/(float)num_buckets);
+
+ cfuhash_destroy_with_free_fn(hash, free_data);
+
+@@ -138,7 +138,7 @@
+ argc = argc;
+ argv = argv;
+
+- printf("mutex is %d bytes\n", sizeof(pthread_mutex_t));
++ printf("mutex is %zd bytes\n", sizeof(pthread_mutex_t));
+
+ printf("default:\n");
+ time_it(NULL, &elapsed_time, num_tests);
diff --git a/devel/libcfu/files/patch-examples__strings.c b/devel/libcfu/files/patch-examples__strings.c
new file mode 100644
index 000000000000..116580a3ff40
--- /dev/null
+++ b/devel/libcfu/files/patch-examples__strings.c
@@ -0,0 +1,29 @@
+--- ./examples/strings.c.orig 2013-02-22 17:04:18.476679318 +0000
++++ ./examples/strings.c 2013-02-22 17:04:45.041658118 +0000
+@@ -39,7 +39,7 @@
+ cfustring_append(buf, "test^*string%2^*3");
+ strings = cfustring_split_to_c_str(buf, &num_strings, 0, "%", "^*", NULL);
+
+- printf("got back %u strings\n", num_strings);
++ printf("got back %zu strings\n", num_strings);
+
+ printf("\n");
+ for (i = 0; i < num_strings; i++) {
+@@ -52,7 +52,7 @@
+ free(strings);
+
+ header_lines = cfustring_split(header_block, &num_headers, 0, "\r\n", "\n", NULL);
+- printf("got back %u headers\n", num_strings);
++ printf("got back %zu headers\n", num_strings);
+
+ for (i = 0; i < num_headers; i++) {
+ strings = cfustring_split_to_c_str(header_lines[i], &num_strings, 2, ":", NULL);
+@@ -61,7 +61,7 @@
+ size_t j = 0;
+ for (j = 0; j < num_strings; j++) free(strings[j]);
+ free(strings);
+- fprintf(stderr, "bad header: %u strings from split -- '%s'\n", num_strings, cfustring_get_buffer(header_lines[i]));
++ fprintf(stderr, "bad header: %zu strings from split -- '%s'\n", num_strings, cfustring_get_buffer(header_lines[i]));
+ continue;
+ }
+
diff --git a/devel/libcfu/pkg-descr b/devel/libcfu/pkg-descr
new file mode 100644
index 000000000000..66906eafccf1
--- /dev/null
+++ b/devel/libcfu/pkg-descr
@@ -0,0 +1,6 @@
+Libcfu is a library of tools that may be useful, particularly when
+developing multithreaded software. It includes a hash table, a linked list,
+self-extending strings, a config file parser, a simple timer, a thread
+queue, and command-line parser.
+
+WWW: http://libcfu.sourceforge.net/
diff --git a/devel/libcfu/pkg-plist b/devel/libcfu/pkg-plist
new file mode 100644
index 000000000000..88bb32b29a33
--- /dev/null
+++ b/devel/libcfu/pkg-plist
@@ -0,0 +1,11 @@
+lib/libcfu.a
+bin/libcfu-config
+include/cfulist.h
+include/cfuhash.h
+include/cfutime.h
+include/cfuconf.h
+include/cfuthread_queue.h
+include/cfuopt.h
+include/cfustring.h
+include/cfutypes.h
+include/cfu.h