aboutsummaryrefslogtreecommitdiff
path: root/devel/libcheck
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-07-09 19:13:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-07-09 19:13:00 +0000
commite3fc0f414f05a8f64a716016970ccb9c368da916 (patch)
tree89bdbcf2197ceb908bf120ed309e59f749774eac /devel/libcheck
parent71c50eaabcafaa6dedba759aca1549b9178d9e47 (diff)
downloadports-e3fc0f414f05a8f64a716016970ccb9c368da916.tar.gz
ports-e3fc0f414f05a8f64a716016970ccb9c368da916.zip
Notes
Diffstat (limited to 'devel/libcheck')
-rw-r--r--devel/libcheck/Makefile9
-rw-r--r--devel/libcheck/pkg-descr11
-rw-r--r--devel/libcheck/pkg-plist28
3 files changed, 25 insertions, 23 deletions
diff --git a/devel/libcheck/Makefile b/devel/libcheck/Makefile
index ef3b1eb0e517..0a9159b04158 100644
--- a/devel/libcheck/Makefile
+++ b/devel/libcheck/Makefile
@@ -14,6 +14,8 @@ DISTNAME= check-${PORTVERSION}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= A unit test framework for C
+OPTIONS_DEFINE= DOCS EXAMPLES
+
GNU_CONFIGURE= yes
PLIST_SUB= CHECK_VERSION=${PORTVERSION}
USE_GMAKE= yes
@@ -21,16 +23,17 @@ USE_LDCONFIG= yes
DOCSDIR= ${PREFIX}/share/doc/check-${PORTVERSION}
EXAMPLESDIR= ${PREFIX}/share/examples/check-${PORTVERSION}
-
INFO= check
+.include <bsd.port.options.mk>
+
post-patch:
-.if defined(NOPORTDOCS)
+.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} \
-e '/^install-data-am:/ s/ install-docDATA//' \
${WRKSRC}/Makefile.in
.endif
-.if defined(NOPORTEXAMPLES)
+.if empty(PORT_OPTIONS:MEXAMPLES)
@${REINPLACE_CMD} \
-e '/^install-data-am:/ s/ install-exampleDATA//' \
-e '/^install-data-am:/ s/ install-examplesrcDATA//' \
diff --git a/devel/libcheck/pkg-descr b/devel/libcheck/pkg-descr
index ff78df45596e..f4e0e5bc38e1 100644
--- a/devel/libcheck/pkg-descr
+++ b/devel/libcheck/pkg-descr
@@ -1,7 +1,6 @@
-Check is a unit test framework for C. It features a simple interface
-for defining unit tests, putting little in the way of the
-developer. Tests are run in a separate address space, so Check can
-catch both assertion failures and code errors that cause segmentation
-faults or other signals.
+Check is a unit test framework for C. It features a simple interface for
+defining unit tests, putting little in the way of the developer. Tests are run
+in a separate address space, so Check can catch both assertion failures and code
+errors that cause segmentation faults or other signals.
-WWW: http://check.sourceforge.net
+WWW: http://check.sourceforge.net/
diff --git a/devel/libcheck/pkg-plist b/devel/libcheck/pkg-plist
index 2c9e0f8a2895..cddda4ab3646 100644
--- a/devel/libcheck/pkg-plist
+++ b/devel/libcheck/pkg-plist
@@ -1,37 +1,37 @@
include/check.h
-lib/libcheck.so.0
-lib/libcheck.so
-lib/libcheck.la
lib/libcheck.a
+lib/libcheck.la
+lib/libcheck.so
+lib/libcheck.so.0
libdata/pkgconfig/check.pc
share/aclocal/check.m4
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%/ChangeLogOld
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/SVNChangeLog
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile.am
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/configure.ac
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/Makefile.am
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/main.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.c
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.h
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.1.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.1.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.2.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.1.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.3.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.4.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.5.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.6.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.c
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/src/money.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/Makefile.am
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/check_money.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/check_money.1.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/check_money.2.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/check_money.3.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/check_money.6.c
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/check_money.7.c
-%%PORTDOCS%%%%DOCSDIR%%/SVNChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLogOld
-%%PORTDOCS%%%%DOCSDIR%%/NEWS
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/src
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tests/check_money.c
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/tests
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/src
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%