aboutsummaryrefslogtreecommitdiff
path: root/devel/libchipcard/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-02-17 23:56:56 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-02-17 23:56:56 +0000
commitb8980341895fd597b544b990f185b4fe48ecdec8 (patch)
tree2ec9cf1ed5e9828128633f639a799ac504147812 /devel/libchipcard/Makefile
parent8873f425a75ad5ebed0262aed4a637a97f1d4031 (diff)
downloadports-b8980341895fd597b544b990f185b4fe48ecdec8.tar.gz
ports-b8980341895fd597b544b990f185b4fe48ecdec8.zip
Notes
Diffstat (limited to 'devel/libchipcard/Makefile')
-rw-r--r--devel/libchipcard/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/libchipcard/Makefile b/devel/libchipcard/Makefile
new file mode 100644
index 000000000000..916955355a41
--- /dev/null
+++ b/devel/libchipcard/Makefile
@@ -0,0 +1,33 @@
+# Ports collection makefile for: LibChipCard
+# Date created: 19 January 2003
+# Whom: Martin Preuss<martin@libchipcard.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libchipcard
+PORTVERSION= 0.7.5
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= libchipcard
+
+MAINTAINER= martin@libchipcard.de
+COMMENT= "A library for easy access to chipcards."
+
+LIB_DEPENDS= pcsclite.0:${PORTSDIR}/devel/pcsc-lite
+
+USE_GMAKE= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= ctfstool.1 chipcardd.1 geldkarte.1 hbcicard.1
+MAN5= libchipcard.conf.5 chipcardc.conf.5 chipcardd.conf.5
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/freebsd/chipcardd.sh ${PREFIX}/etc/rc.d
+ @${SED} -e 's,%%PREFIX%%,${PREFIX},' ${PKGMESSAGE}
+
+.include <bsd.port.mk>