aboutsummaryrefslogtreecommitdiff
path: root/devel/libchipcard
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-12-29 14:25:02 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-12-29 14:25:02 +0000
commitf1feed3a98288e49b2bc8b53a399dffb69b0fd8d (patch)
tree5f4b42bc20d7280ca46b03555809775426e36c63 /devel/libchipcard
parent3e979fa8f08aaeeb5861dcc2e016db9ee30aebdc (diff)
downloadports-f1feed3a98288e49b2bc8b53a399dffb69b0fd8d.tar.gz
ports-f1feed3a98288e49b2bc8b53a399dffb69b0fd8d.zip
Notes
Diffstat (limited to 'devel/libchipcard')
-rw-r--r--devel/libchipcard/Makefile8
-rw-r--r--devel/libchipcard/files/patch-hbcicard.cpp13
2 files changed, 14 insertions, 7 deletions
diff --git a/devel/libchipcard/Makefile b/devel/libchipcard/Makefile
index 14d165a5f7e1..bee887d1adf9 100644
--- a/devel/libchipcard/Makefile
+++ b/devel/libchipcard/Makefile
@@ -29,14 +29,8 @@ MAN1= ctfstool.1 chipcardd.1 geldkarte.1 hbcicard.1 \
MAN5= libchipcard.conf.5 chipcardc.conf.5 chipcardd.conf.5
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
-.endif
-
post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/freebsd/chipcardd.sh ${PREFIX}/etc/rc.d
@${SED} -e 's,%%PREFIX%%,${PREFIX},' ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libchipcard/files/patch-hbcicard.cpp b/devel/libchipcard/files/patch-hbcicard.cpp
new file mode 100644
index 000000000000..954c79e93fdc
--- /dev/null
+++ b/devel/libchipcard/files/patch-hbcicard.cpp
@@ -0,0 +1,13 @@
+--- src/libchipcard/cards/hbcicard.cpp.orig Mon Dec 29 10:58:25 2003
++++ src/libchipcard/cards/hbcicard.cpp Mon Dec 29 10:59:41 2003
+@@ -401,8 +401,8 @@
+ string id;
+ string fcp;
+ CTError err;
+- unsigned char id1[9]={{0xd2},{0x76},{0x00},{0x00},{0x25},{0x48},{0x42},{0x01},{0x00}};
+- unsigned char id2[9]={{0xd2},{0x76},{0x00},{0x00},{0x25},{0x48},{0x42},{0x02},{0x00}};
++ unsigned char id1[9]={0xd2,0x76,0x00,0x00,0x25,0x48,0x42,0x01,0x00};
++ unsigned char id2[9]={0xd2,0x76,0x00,0x00,0x25,0x48,0x42,0x02,0x00};
+
+ #if DEBUGMODE>15
+ fprintf(stderr,"LIBCHIPCARD: Checking type.\n");