aboutsummaryrefslogtreecommitdiff
path: root/devel/libclaw
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2012-06-01 05:26:28 +0000
commit2b74a89bc8342f0b9b737c37d87737caf7b0ea1e (patch)
treec04604583d8be53b3ed7f10975be828c731f87cb /devel/libclaw
parent24315159daa0089f08acea4ba1b130fb6721ad5c (diff)
Notes
Diffstat (limited to 'devel/libclaw')
-rw-r--r--devel/libclaw/Makefile4
-rw-r--r--devel/libclaw/files/patch-png.hpp10
2 files changed, 12 insertions, 2 deletions
diff --git a/devel/libclaw/Makefile b/devel/libclaw/Makefile
index eecc0662c71a..6aebeaf06560 100644
--- a/devel/libclaw/Makefile
+++ b/devel/libclaw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libclaw
PORTVERSION= 1.5.3
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel
MASTER_SITES= SF
@@ -15,7 +15,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= C++ Library Absolutely Wonderful
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png.6:${PORTSDIR}/graphics/png
+ png15:${PORTSDIR}/graphics/png
USE_BZIP2= yes
diff --git a/devel/libclaw/files/patch-png.hpp b/devel/libclaw/files/patch-png.hpp
new file mode 100644
index 000000000000..15e0afefa97d
--- /dev/null
+++ b/devel/libclaw/files/patch-png.hpp
@@ -0,0 +1,10 @@
+--- claw/png.hpp.orig 2008-07-08 11:52:14.000000000 +0200
++++ claw/png.hpp 2012-04-25 19:37:48.000000000 +0200
+@@ -32,6 +32,7 @@
+
+ #include <claw/image.hpp>
+ #include <png.h>
++#include <zlib.h>
+ #include <setjmp.h>
+ #include <iostream>
+ #include <string>