aboutsummaryrefslogtreecommitdiff
path: root/devel/libcli
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2011-05-02 21:44:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2011-05-02 21:44:50 +0000
commitaa07b93950f8c4fe9b34967a972c42386adad571 (patch)
tree4e41b71f0c82d25df3a12451143335e7fbc53db9 /devel/libcli
parent6bbab5e1ef6165b675bdc669999b8cc9b78e0194 (diff)
downloadports-aa07b93950f8c4fe9b34967a972c42386adad571.tar.gz
ports-aa07b93950f8c4fe9b34967a972c42386adad571.zip
Notes
Diffstat (limited to 'devel/libcli')
-rw-r--r--devel/libcli/files/patch-Makefile46
-rw-r--r--devel/libcli/files/patch-clitest.c2
-rw-r--r--devel/libcli/files/patch-libcli.c2
3 files changed, 48 insertions, 2 deletions
diff --git a/devel/libcli/files/patch-Makefile b/devel/libcli/files/patch-Makefile
new file mode 100644
index 000000000000..7577b5921bf7
--- /dev/null
+++ b/devel/libcli/files/patch-Makefile
@@ -0,0 +1,46 @@
+--- ./Makefile.orig 2008-10-09 04:38:01.000000000 +0200
++++ ./Makefile 2011-05-02 23:43:52.002280937 +0200
+@@ -3,14 +3,12 @@
+
+ MAJOR = 1
+ MINOR = 9
+-REVISION = 3
++REVISION = 4
+ LIB = libcli.so
+
+ CC = gcc
+-DEBUG = -g
+-OPTIM = -O3
+-CFLAGS += $(DEBUG) $(OPTIM) -Wall -Wformat-security -Wno-format-zero-length
+-LDFLAGS += -shared -Wl,-soname,$(LIB).$(MAJOR).$(MINOR)
++CFLAGS += -Wall -Wformat-security -Wno-format-zero-length
++LDFLAGS += -shared -Wl,-soname,$(LIB).$(MAJOR)$(MINOR)
+ LIBPATH += -L.
+ LIBS = -lcrypt
+
+@@ -18,9 +16,10 @@
+
+ $(LIB): libcli.o
+ $(CC) -o $(LIB).$(MAJOR).$(MINOR).$(REVISION) $^ $(LDFLAGS) $(LIBS)
+- -rm -f $(LIB) $(LIB).$(MAJOR).$(MINOR)
+- ln -s $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR)
+- ln -s $(LIB).$(MAJOR).$(MINOR) $(LIB)
++ -rm -f $(LIB) $(LIB).$(MAJOR).$(MINOR) $(LIB).$(MAJOR)$(MINOR)
++ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR)$(MINOR)
++ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR)
++ ln -sf $(LIB).$(MAJOR)$(MINOR) $(LIB)
+
+ %.o: %.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) -fPIC -o $@ -c $<
+@@ -41,8 +40,9 @@
+ install -m 0644 libcli.h $(DESTDIR)$(PREFIX)/include
+ install -m 0755 $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(DESTDIR)$(PREFIX)/lib
+ cd $(DESTDIR)$(PREFIX)/lib && \
+- ln -s $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR) && \
+- ln -s $(LIB).$(MAJOR).$(MINOR) $(LIB)
++ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR).$(MINOR) && \
++ ln -sf $(LIB).$(MAJOR).$(MINOR).$(REVISION) $(LIB).$(MAJOR)$(MINOR) && \
++ ln -sf $(LIB).$(MAJOR)$(MINOR) $(LIB)
+
+ rpm:
+ mkdir libcli-$(MAJOR).$(MINOR).$(REVISION)
diff --git a/devel/libcli/files/patch-clitest.c b/devel/libcli/files/patch-clitest.c
index 442d89d362b4..88f645ef7bf9 100644
--- a/devel/libcli/files/patch-clitest.c
+++ b/devel/libcli/files/patch-clitest.c
@@ -1,5 +1,5 @@
--- ./clitest.c.orig 2008-10-09 04:38:01.000000000 +0200
-+++ ./clitest.c 2011-04-28 08:16:34.501647287 +0200
++++ ./clitest.c 2011-05-02 23:42:29.730543145 +0200
@@ -4,6 +4,7 @@
#include <winsock2.h>
#include <windows.h>
diff --git a/devel/libcli/files/patch-libcli.c b/devel/libcli/files/patch-libcli.c
index 0e09b56ed563..ddb982c6454b 100644
--- a/devel/libcli/files/patch-libcli.c
+++ b/devel/libcli/files/patch-libcli.c
@@ -1,5 +1,5 @@
--- ./libcli.c.orig 2008-10-09 04:38:01.000000000 +0200
-+++ ./libcli.c 2011-04-28 08:16:34.504647662 +0200
++++ ./libcli.c 2011-05-02 23:42:29.732543394 +0200
@@ -9,7 +9,6 @@
#include <stdarg.h>
#include <stdlib.h>