aboutsummaryrefslogtreecommitdiff
path: root/devel/libconfig/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-09-26 12:22:13 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-09-26 12:22:13 +0000
commit732672fa4ad0ca1f03c54131c4696b485f8c7104 (patch)
tree16b43c7452928eee6d6efbfa39936d57831ff542 /devel/libconfig/Makefile
parenta5420725e014b6935ac26c28c745a9e314564604 (diff)
downloadports-732672fa4ad0ca1f03c54131c4696b485f8c7104.tar.gz
ports-732672fa4ad0ca1f03c54131c4696b485f8c7104.zip
Notes
Diffstat (limited to 'devel/libconfig/Makefile')
-rw-r--r--devel/libconfig/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/libconfig/Makefile b/devel/libconfig/Makefile
new file mode 100644
index 000000000000..d402dbd6d35a
--- /dev/null
+++ b/devel/libconfig/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libconfig
+# Date created: September 26, 2007
+# Whom: Nikos Ntarmos <ntarmos@ceid.upatras.gr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libconfig
+PORTVERSION= 1.1.3
+CATEGORIES= devel
+MASTER_SITES= http://www.hyperrealm.com/libconfig/
+
+MAINTAINER= ntarmos@ceid.upatras.gr
+COMMENT= A simple library for manipulating structured configuration files
+
+USE_GNOME= gnomehack pkgconfig
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}
+INFO= libconfig
+
+.include <bsd.port.mk>