aboutsummaryrefslogtreecommitdiff
path: root/devel/libconfig
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-09-26 12:22:13 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-09-26 12:22:13 +0000
commit732672fa4ad0ca1f03c54131c4696b485f8c7104 (patch)
tree16b43c7452928eee6d6efbfa39936d57831ff542 /devel/libconfig
parenta5420725e014b6935ac26c28c745a9e314564604 (diff)
downloadports-732672fa4ad0ca1f03c54131c4696b485f8c7104.tar.gz
ports-732672fa4ad0ca1f03c54131c4696b485f8c7104.zip
Notes
Diffstat (limited to 'devel/libconfig')
-rw-r--r--devel/libconfig/Makefile23
-rw-r--r--devel/libconfig/distinfo3
-rw-r--r--devel/libconfig/pkg-descr16
-rw-r--r--devel/libconfig/pkg-plist10
4 files changed, 52 insertions, 0 deletions
diff --git a/devel/libconfig/Makefile b/devel/libconfig/Makefile
new file mode 100644
index 000000000000..d402dbd6d35a
--- /dev/null
+++ b/devel/libconfig/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libconfig
+# Date created: September 26, 2007
+# Whom: Nikos Ntarmos <ntarmos@ceid.upatras.gr>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libconfig
+PORTVERSION= 1.1.3
+CATEGORIES= devel
+MASTER_SITES= http://www.hyperrealm.com/libconfig/
+
+MAINTAINER= ntarmos@ceid.upatras.gr
+COMMENT= A simple library for manipulating structured configuration files
+
+USE_GNOME= gnomehack pkgconfig
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}
+INFO= libconfig
+
+.include <bsd.port.mk>
diff --git a/devel/libconfig/distinfo b/devel/libconfig/distinfo
new file mode 100644
index 000000000000..c2c7ba927d21
--- /dev/null
+++ b/devel/libconfig/distinfo
@@ -0,0 +1,3 @@
+MD5 (libconfig-1.1.3.tar.gz) = c0cd4b5ed44bbc1dca32eafaac377e33
+SHA256 (libconfig-1.1.3.tar.gz) = 3ee6dfd0edad6744a4c858578a2fc1a758ca0a2c3b3f93759695e23624a2c018
+SIZE (libconfig-1.1.3.tar.gz) = 494149
diff --git a/devel/libconfig/pkg-descr b/devel/libconfig/pkg-descr
new file mode 100644
index 000000000000..e73ef74a6b19
--- /dev/null
+++ b/devel/libconfig/pkg-descr
@@ -0,0 +1,16 @@
+Libconfig is a simple library for manipulating structured configuration
+files. The file format is more compact and more readable than XML. And
+unlike XML, it is type-aware, so it is not necessary to do string
+parsing in application code.
+
+Libconfig is very compact -- just 25K for the stripped C shared library
+(one-fifth the size of the expat XML parser library) and 39K for the
+stripped C++ shared library. This makes it well-suited for
+memory-constrained systems like handheld devices.
+
+The library includes bindings for both the C and C++ languages. It works
+on POSIX-compliant UNIX systems (GNU/Linux, Mac OS X, Solaris, FreeBSD)
+and Windows (2000, XP and later).
+
+
+WWW: http://www.hyperrealm.com/libconfig/libconfig.html
diff --git a/devel/libconfig/pkg-plist b/devel/libconfig/pkg-plist
new file mode 100644
index 000000000000..fc9672d4d411
--- /dev/null
+++ b/devel/libconfig/pkg-plist
@@ -0,0 +1,10 @@
+include/libconfig.h
+include/libconfig.h++
+lib/libconfig.a
+lib/libconfig.la
+lib/libconfig.so.4
+lib/libconfig++.a
+lib/libconfig++.la
+lib/libconfig++.so.4
+libdata/pkgconfig/libconfig.pc
+libdata/pkgconfig/libconfig++.pc