aboutsummaryrefslogtreecommitdiff
path: root/devel/libcutl/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-06 21:49:50 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-09-06 21:49:50 +0000
commitbcde9b96ca73a38e56487f0fd78448148e8d71e1 (patch)
tree53ec0ee4e336b26875e390f75aaebceaf69cfb6e /devel/libcutl/Makefile
parentb7598bc7bb6072b62db9e9cc7101810bf0f90496 (diff)
downloadports-bcde9b96ca73a38e56487f0fd78448148e8d71e1.tar.gz
ports-bcde9b96ca73a38e56487f0fd78448148e8d71e1.zip
Notes
Diffstat (limited to 'devel/libcutl/Makefile')
-rw-r--r--devel/libcutl/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/libcutl/Makefile b/devel/libcutl/Makefile
new file mode 100644
index 000000000000..ded55b6c149f
--- /dev/null
+++ b/devel/libcutl/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= libcutl
+PORTVERSION= 1.9.0
+CATEGORIES= devel
+MASTER_SITES= http://www.codesynthesis.com/download/${PORTNAME}/${PORTVERSION:R}/
+
+MAINTAINER= rakuco@FreeBSD.org
+COMMENT= C++ utility library with generic and independent components
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libboost_system.so:${PORTSDIR}/devel/boost-libs \
+ libexpat.so:${PORTSDIR}/textproc/expat2
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+USES= libtool
+
+# The checks for external boost and external expat are quite limited and do not
+# add the ${LOCALBASE} paths correctly (libboost.m4 uses wrong paths and
+# libexpat.m4 does nothing at all).
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+CONFIGURE_ARGS= --disable-static \
+ --with-boost=${LOCALBASE} \
+ --with-external-boost \
+ --with-external-expat \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
+
+.include <bsd.port.mk>