aboutsummaryrefslogtreecommitdiff
path: root/devel/libdbusmenu-qt
diff options
context:
space:
mode:
authorAlberto Villa <avilla@FreeBSD.org>2011-10-16 22:56:58 +0000
committerAlberto Villa <avilla@FreeBSD.org>2011-10-16 22:56:58 +0000
commit5053a7f65b5fa06fb7a6696cd2dde0ff154a4c3e (patch)
tree419fda42f64004edaf12e7199f48048ea2f2d6eb /devel/libdbusmenu-qt
parent2868f3cea873dac17620f80c7c4dd2069876dc1d (diff)
Notes
Diffstat (limited to 'devel/libdbusmenu-qt')
-rw-r--r--devel/libdbusmenu-qt/Makefile14
-rw-r--r--devel/libdbusmenu-qt/distinfo4
-rw-r--r--devel/libdbusmenu-qt/files/patch-CMakeLists.txt19
-rw-r--r--devel/libdbusmenu-qt/pkg-plist2
4 files changed, 35 insertions, 4 deletions
diff --git a/devel/libdbusmenu-qt/Makefile b/devel/libdbusmenu-qt/Makefile
index 5428760cbf76..9e1e970494ec 100644
--- a/devel/libdbusmenu-qt/Makefile
+++ b/devel/libdbusmenu-qt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libdbusmenu-qt
-PORTVERSION= 0.8.0
+PORTVERSION= 0.9.0
CATEGORIES= devel
MASTER_SITES= http://launchpad.net/${PORTNAME}/trunk/${PORTVERSION}/+download/
@@ -27,6 +27,18 @@ USE_LDCONFIG= yes
CMAKE_OUTSOURCE= yes
MAKE_JOBS_SAFE= yes
+OPTIONS= DOCS "Install API documentation (requires Doxygen)" off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_DOCS)
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+PORTDOCS= *
+CMAKE_ARGS+= -DDOC_INSTALL_DIR:PATH="${DOCSDIR_REL}"
+.else
+CMAKE_ARGS+= -DWITH_DOC:BOOL=OFF
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/pkgconfig/ s/$${LIB_SUFFIX}/data/' \
-e '/tests/ d' -e '/tools/ d' \
diff --git a/devel/libdbusmenu-qt/distinfo b/devel/libdbusmenu-qt/distinfo
index e91df91f711e..8caac0d66d9e 100644
--- a/devel/libdbusmenu-qt/distinfo
+++ b/devel/libdbusmenu-qt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libdbusmenu-qt-0.8.0.tar.bz2) = f35a14a9263a6a718eec7654f1e19965ba80b362fb64901b78811b03f5060530
-SIZE (libdbusmenu-qt-0.8.0.tar.bz2) = 32424
+SHA256 (libdbusmenu-qt-0.9.0.tar.bz2) = 071d8215c17999cdef8f8361964b45e135edf96c955d6618f4ebf1eac662b175
+SIZE (libdbusmenu-qt-0.9.0.tar.bz2) = 37153
diff --git a/devel/libdbusmenu-qt/files/patch-CMakeLists.txt b/devel/libdbusmenu-qt/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..7cceebad8c39
--- /dev/null
+++ b/devel/libdbusmenu-qt/files/patch-CMakeLists.txt
@@ -0,0 +1,19 @@
+--- CMakeLists.txt~ 2011-09-01 14:05:32.000000000 -0300
++++ CMakeLists.txt 2011-09-01 14:08:06.000000000 -0300
+@@ -64,6 +64,8 @@
+ add_subdirectory(tools)
+
+ if(WITH_DOC)
++ set(DOC_INSTALL_DIR "share/doc/dbusmenu-qt" CACHE PATH "Directory where to install the documentation")
++
+ configure_file(Doxyfile.in ${CMAKE_BINARY_DIR}/Doxyfile @ONLY)
+
+ add_custom_target(doc ALL doxygen
+@@ -71,6 +73,6 @@
+ )
+
+ install(DIRECTORY ${CMAKE_BINARY_DIR}/html/
+- DESTINATION share/doc/dbusmenu-qt
++ DESTINATION ${DOC_INSTALL_DIR}
+ )
+ endif(WITH_DOC)
diff --git a/devel/libdbusmenu-qt/pkg-plist b/devel/libdbusmenu-qt/pkg-plist
index 05b502bdb7d4..a6ae3007a935 100644
--- a/devel/libdbusmenu-qt/pkg-plist
+++ b/devel/libdbusmenu-qt/pkg-plist
@@ -4,6 +4,6 @@ include/dbusmenu-qt/dbusmenuexporter.h
include/dbusmenu-qt/dbusmenuimporter.h
lib/libdbusmenu-qt.so
lib/libdbusmenu-qt.so.2
-lib/libdbusmenu-qt.so.2.5.0
+lib/libdbusmenu-qt.so.2.6.0
libdata/pkgconfig/dbusmenu-qt.pc
@dirrm include/dbusmenu-qt