aboutsummaryrefslogtreecommitdiff
path: root/devel/libdict
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-04-19 14:19:50 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-04-19 14:19:50 +0000
commitb8d5a770958c002141f662907a25f5a9fc6f9b65 (patch)
tree865c408e1e99d2427275d21e757cb1d14c978628 /devel/libdict
parent6571dcf3dd0175d02c15e6647c3cd7981ed95b10 (diff)
Notes
Diffstat (limited to 'devel/libdict')
-rw-r--r--devel/libdict/Makefile43
-rw-r--r--devel/libdict/distinfo8
-rw-r--r--devel/libdict/pkg-descr17
-rw-r--r--devel/libdict/pkg-plist18
4 files changed, 86 insertions, 0 deletions
diff --git a/devel/libdict/Makefile b/devel/libdict/Makefile
new file mode 100644
index 000000000000..7a179fbfb58b
--- /dev/null
+++ b/devel/libdict/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: libdict
+# Date created: Apr 19 2003
+# Whom: Alex Semenyaka <alex@rinet.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdict
+PORTVERSION= 0.2.0
+CATEGORIES= devel
+MASTER_SITES= http://home.earthlink.net/~smela1/libdict/ \
+ http://home.earthlink.net/~smela1/ \
+ http://home.earthlink.net/~smela1/libdict/algorithms/
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}.html \
+ treap_insert.dvi treap_insert.pdf \
+ avl_insert.dvi avl_insert.pdf \
+ empty.dvi empty.pdf
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= alexs@snark.rinet.ru
+COMMENT= Library providing access to ``dictionary'' data structures
+
+USE_GMAKE= yes
+MAKEFILE= GNUmakefile
+INSTALLS_SHLIB= yes
+
+post-extract:
+ @${CP} ${DISTDIR}/${PORTNAME}.html ${WRKSRC}/
+. for ___f in avl_insert.dvi avl_insert.pdf empty.dvi empty.pdf treap_insert.dvi treap_insert.pdf
+ @${CP} ${DISTDIR}/${___f} ${WRKSRC}/
+. endfor
+
+pre-install:
+ -@${MKDIR} ${PREFIX}/include/
+ -@${MKDIR} ${PREFIX}/lib/
+ -@${MKDIR} ${DOCSDIR}
+
+post-install:
+. for ___f in avl_insert.dvi avl_insert.pdf empty.dvi empty.pdf treap_insert.dvi treap_insert.pdf ${PORTNAME}.html
+ @${CP} ${WRKSRC}/${___f} ${DOCSDIR}
+. endfor
+
+.include <bsd.port.mk>
diff --git a/devel/libdict/distinfo b/devel/libdict/distinfo
new file mode 100644
index 000000000000..566415c8cd44
--- /dev/null
+++ b/devel/libdict/distinfo
@@ -0,0 +1,8 @@
+MD5 (libdict-0.2.0.tar.gz) = 1969906fdb25186e2c3f5d5d5a8491f2
+MD5 (libdict.html) = 7aa27454390de77780653bad555dbed5
+MD5 (treap_insert.dvi) = 03c98375a884b42b4f05c93ad443adff
+MD5 (treap_insert.pdf) = de189a70639b4be88589aea2b0f49eed
+MD5 (avl_insert.dvi) = de9922e8def3d8b371578d3a68a076c4
+MD5 (avl_insert.pdf) = 621cedabf3238e8199250cb5c7ffcde1
+MD5 (empty.dvi) = fa5fa829f5768b00e12e562aac7f3cd2
+MD5 (empty.pdf) = 11d4e61f6fc8beccc1beaffd13bf202e
diff --git a/devel/libdict/pkg-descr b/devel/libdict/pkg-descr
new file mode 100644
index 000000000000..31907f63978c
--- /dev/null
+++ b/devel/libdict/pkg-descr
@@ -0,0 +1,17 @@
+Libdict is a compact, ANSI C library which provides access to a set of
+generic and flexible ``dictionary'' data structures. All algorithms
+used in libdict have been optimized, and, with one very small exception,
+are not recursive but iterative. It was written by Farooq Mela, and is
+released under a BSD style licence.
+
+Libdict implements the following data structures: AVL Tree, Red-Black
+Tree, Splay Tree, Treap, Weight-balanced tree, Path-reduction tree,
+Hashtable (Chained).
+
+These structures can be used to efficiently store and retrieve key-data
+pairs. Each of these structures can be accessed using its direct API, or
+it can be accessed using a dictionary abstraction. Despite it's name,
+libdict can be used to store any kind of data and any kind of key (provided
+it fits into a 'void' pointer on your system).
+
+WWW: http://home.earthlink.net/~smela1/libdict.html
diff --git a/devel/libdict/pkg-plist b/devel/libdict/pkg-plist
new file mode 100644
index 000000000000..fb79ff04345f
--- /dev/null
+++ b/devel/libdict/pkg-plist
@@ -0,0 +1,18 @@
+lib/libdict.so.2
+lib/libdict.a
+lib/libdict_p.a
+include/dict/dict.h
+include/dict/hashtable.h
+include/dict/hb_tree.h
+include/dict/pr_tree.h
+include/dict/rb_tree.h
+include/dict/sp_tree.h
+include/dict/tr_tree.h
+include/dict/wb_tree.h
+share/doc/libdict/avl_insert.dvi
+share/doc/libdict/avl_insert.pdf
+share/doc/libdict/empty.dvi
+share/doc/libdict/empty.pdf
+share/doc/libdict/treap_insert.dvi
+share/doc/libdict/treap_insert.pdf
+share/doc/libdict/libdict.html