aboutsummaryrefslogtreecommitdiff
path: root/devel/libdispatch/Makefile
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2009-10-20 22:33:24 +0000
committerStanislav Sedov <stas@FreeBSD.org>2009-10-20 22:33:24 +0000
commitb8431d8349fdaee1092999e8d6164aee72d13698 (patch)
tree4c7e0673531327ab50111dd1cdffa0cc34fabfd3 /devel/libdispatch/Makefile
parent57c82b0734e95f92bfdb9133628cefac903d2826 (diff)
downloadports-b8431d8349fdaee1092999e8d6164aee72d13698.tar.gz
ports-b8431d8349fdaee1092999e8d6164aee72d13698.zip
Notes
Diffstat (limited to 'devel/libdispatch/Makefile')
-rw-r--r--devel/libdispatch/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/devel/libdispatch/Makefile b/devel/libdispatch/Makefile
index 1069303cce72..115ee96e8b64 100644
--- a/devel/libdispatch/Makefile
+++ b/devel/libdispatch/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= libdispatch
-PORTVERSION= 46
+PORTVERSION= 53
CATEGORIES= devel
MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
-DISTNAME= ${PORTNAME}-r${PORTVERSION}
+#DISTNAME= ${PORTNAME}-r${PORTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= Grand Central Dispatch API support library
@@ -18,6 +18,8 @@ GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_LDCONFIG= yes
+OPTIONS= CLANG "Build with LLVM/Clang (required for blocks support)" on
+
MAN3= dispatch.3 dispatch_after.3 dispatch_api.3 dispatch_apply.3 \
dispatch_async.3 dispatch_benchmark.3 dispatch_group_create.3 \
dispatch_object.3 dispatch_once.3 dispatch_queue_create.3 \
@@ -36,4 +38,14 @@ post-configure:
IGNORE= is not supported on this OS version
.endif
+.if !defined(WITHOUT_CLANG)
+BUILD_DEPENDS+= clang:${PORTSDIR}/devel/llvm-devel \
+ ${LOCALBASE}/lib/libBlocksRuntime.so:${PORTSDIR}/devel/compiler-rt
+RUN_DEPENDS+= clang:${PORTSDIR}/devel/llvm-devel \
+ ${LOCALBASE}/lib/libBlocksRuntime.so:${PORTSDIR}/devel/compiler-rt
+CONFIGURE_ARGS+= --with-blocks-runtime=/usr/local/lib
+CONFIGURE_ENV+= CC="clang"
+MAKE_ENV+= CC="clang"
+.endif
+
.include <bsd.port.post.mk>