aboutsummaryrefslogtreecommitdiff
path: root/devel/libdispatch
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2013-10-18 13:57:10 +0000
committerBrooks Davis <brooks@FreeBSD.org>2013-10-18 13:57:10 +0000
commit1a783275460552a25934b073d805376c164e1936 (patch)
treed0cc9eaa1e07325656dc5e75c225fb9236ec6c27 /devel/libdispatch
parent6f132fa4e26be02218ce103461113696abbc1500 (diff)
downloadports-1a783275460552a25934b073d805376c164e1936.tar.gz
ports-1a783275460552a25934b073d805376c164e1936.zip
Notes
Diffstat (limited to 'devel/libdispatch')
-rw-r--r--devel/libdispatch/Makefile123
1 files changed, 66 insertions, 57 deletions
diff --git a/devel/libdispatch/Makefile b/devel/libdispatch/Makefile
index 7f606b3fd844..5d13ffcc27df 100644
--- a/devel/libdispatch/Makefile
+++ b/devel/libdispatch/Makefile
@@ -22,60 +22,61 @@ OPTIONS_DEFINE= CLANG
OPTIONS_DEFAULT= CLANG
CLANG_DESC= Build with LLVM/Clang (required for blocks support)
-MAN3= dispatch.3 dispatch_after.3 dispatch_api.3 dispatch_apply.3 \
- dispatch_async.3 dispatch_benchmark.3 dispatch_group_create.3 \
- dispatch_object.3 dispatch_once.3 dispatch_queue_create.3 \
- dispatch_semaphore_create.3 dispatch_source_create.3 dispatch_time.3
-
-MLINKS= dispatch_after.3 dispatch_after_f.3 \
- dispatch_apply.3 dispatch_apply_f.3 \
- dispatch_async.3 dispatch_sync.3 \
- dispatch_async.3 dispatch_async_f.3 \
- dispatch_async.3 dispatch_sync_f.3 \
- dispatch_benchmark.3 dispatch_benchmark_f.3 \
- dispatch_group_create.3 dispatch_group_enter.3 \
- dispatch_group_create.3 dispatch_group_leave.3 \
- dispatch_group_create.3 dispatch_group_wait.3 \
- dispatch_group_create.3 dispatch_group_notify.3 \
- dispatch_group_create.3 dispatch_group_notify_f.3 \
- dispatch_group_create.3 dispatch_group_async.3 \
- dispatch_group_create.3 dispatch_group_async_f.3 \
- dispatch_object.3 dispatch_retain.3 \
- dispatch_object.3 dispatch_release.3 \
- dispatch_object.3 dispatch_suspend.3 \
- dispatch_object.3 dispatch_resume.3 \
- dispatch_object.3 dispatch_get_context.3 \
- dispatch_object.3 dispatch_set_context.3 \
- dispatch_object.3 dispatch_set_finalizer_f.3 \
- dispatch_once.3 dispatch_once_f.3 \
- dispatch_queue_create.3 dispatch_queue_get_label.3 \
- dispatch_queue_create.3 dispatch_get_current_queue.3 \
- dispatch_queue_create.3 dispatch_get_global_queue.3 \
- dispatch_queue_create.3 dispatch_get_main_queue.3 \
- dispatch_queue_create.3 dispatch_main.3 \
- dispatch_queue_create.3 dispatch_set_target_queue.3 \
- dispatch_semaphore_create.3 dispatch_semaphore_signal.3 \
- dispatch_semaphore_create.3 dispatch_semaphore_wait.3 \
- dispatch_source_create.3 dispatch_source_set_event_handler.3 \
- dispatch_source_create.3 dispatch_source_set_event_handler_f.3 \
- dispatch_source_create.3 dispatch_source_set_cancel_handler.3 \
- dispatch_source_create.3 dispatch_source_set_cancel_handler_f.3 \
- dispatch_source_create.3 dispatch_source_cancel.3 \
- dispatch_source_create.3 dispatch_source_testcancel.3 \
- dispatch_source_create.3 dispatch_source_get_handle.3 \
- dispatch_source_create.3 dispatch_source_get_mask.3 \
- dispatch_source_create.3 dispatch_source_get_data.3 \
- dispatch_source_create.3 dispatch_source_merge_data.3 \
- dispatch_source_create.3 dispatch_source_set_timer.3 \
- dispatch_time.3 dispatch_walltime.3
-
-#
-# Get rid of .la and static library files
-#
-NO_STAGE= yes
-post-configure:
- @${REINPLACE_CMD} -E -e \
- '/Install the pseudo-library/,/staticlibs=/s,^,#,' ${WRKSRC}/libtool
+_MAN3= dispatch.3 \
+ dispatch_after.3 \
+ dispatch_after_f.3 \
+ dispatch_api.3 \
+ dispatch_apply.3 \
+ dispatch_apply_f.3 \
+ dispatch_async.3 \
+ dispatch_async_f.3 \
+ dispatch_benchmark.3 \
+ dispatch_benchmark_f.3 \
+ dispatch_get_context.3 \
+ dispatch_get_current_queue.3 \
+ dispatch_get_global_queue.3 \
+ dispatch_get_main_queue.3 \
+ dispatch_group_async.3 \
+ dispatch_group_async_f.3 \
+ dispatch_group_create.3 \
+ dispatch_group_enter.3 \
+ dispatch_group_leave.3 \
+ dispatch_group_notify.3 \
+ dispatch_group_notify_f.3 \
+ dispatch_group_wait.3 \
+ dispatch_main.3 \
+ dispatch_object.3 \
+ dispatch_once.3 \
+ dispatch_once_f.3 \
+ dispatch_queue_create.3 \
+ dispatch_queue_get_label.3 \
+ dispatch_release.3 \
+ dispatch_resume.3 \
+ dispatch_retain.3 \
+ dispatch_semaphore_create.3 \
+ dispatch_semaphore_signal.3 \
+ dispatch_semaphore_wait.3 \
+ dispatch_set_context.3 \
+ dispatch_set_finalizer_f.3 \
+ dispatch_set_target_queue.3 \
+ dispatch_source_cancel.3 \
+ dispatch_source_create.3 \
+ dispatch_source_get_data.3 \
+ dispatch_source_get_handle.3 \
+ dispatch_source_get_mask.3 \
+ dispatch_source_merge_data.3 \
+ dispatch_source_set_cancel_handler.3 \
+ dispatch_source_set_cancel_handler_f.3 \
+ dispatch_source_set_event_handler.3 \
+ dispatch_source_set_event_handler_f.3 \
+ dispatch_source_set_timer.3 \
+ dispatch_source_testcancel.3 \
+ dispatch_suspend.3 \
+ dispatch_sync.3 \
+ dispatch_sync_f.3 \
+ dispatch_time.3 \
+ dispatch_walltime.3
+PLIST_FILES+= ${_MAN3:S|^|man/man3/|:S|$|.gz|}
.include <bsd.port.pre.mk>
@@ -93,16 +94,24 @@ BROKEN= Does not link on sparc64-9
.if ${PORT_OPTIONS:MCLANG}
. if ${OSVERSION} < 900024
-BUILD_DEPENDS+= clang:${PORTSDIR}/lang/clang \
+BUILD_DEPENDS+= clang33:${PORTSDIR}/lang/clang33 \
${LOCALBASE}/lib/libBlocksRuntime.so:${PORTSDIR}/devel/compiler-rt
-RUN_DEPENDS+= clang:${PORTSDIR}/lang/clang \
+RUN_DEPENDS+= clang33:${PORTSDIR}/lang/clang33 \
${LOCALBASE}/lib/libBlocksRuntime.so:${PORTSDIR}/devel/compiler-rt
CONFIGURE_ARGS+= --with-blocks-runtime=${LOCALBASE}/lib
-CONFIGURE_ENV+= CC="${LOCALBASE}/bin/clang" CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV+= CC="${LOCALBASE}/bin/clang33" CPPFLAGS="-I${LOCALBASE}/include"
. else
CONFIGURE_ARGS+= --with-blocks-runtime=/usr/lib
CONFIGURE_ENV+= CC="/usr/bin/clang"
. endif
.endif
+#
+# Get rid of .la and static library files
+#
+post-configure:
+ @${REINPLACE_CMD} -E -e \
+ '/Install the pseudo-library/,/staticlibs=/s,^,#,' ${WRKSRC}/libtool
+
+
.include <bsd.port.post.mk>